summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/web.scm13
1 files changed, 2 insertions, 11 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index ff40743832..163bfa22dc 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -894,7 +894,6 @@ data.")
(define-public json-c
(package
- (replacement json-c/fixed)
(name "json-c")
(version "0.14")
(source (origin
@@ -904,7 +903,8 @@ data.")
version ".tar.gz"))
(sha256
(base32
- "0w381krr99q5a2rypx4g437fa7gzgl82i64sgnrs6g5jr44dwxxk"))))
+ "0w381krr99q5a2rypx4g437fa7gzgl82i64sgnrs6g5jr44dwxxk"))
+ (patches (search-patches "json-c-CVE-2020-12762.patch"))))
(build-system cmake-build-system)
(home-page "https://github.com/json-c/json-c/wiki")
(synopsis "JSON implementation in C")
@@ -915,15 +915,6 @@ parse JSON-formatted strings back into the C representation of JSON objects.
It aims to conform to RFC 7159.")
(license license:x11)))
-(define json-c/fixed
- (package
- (inherit json-c)
- (name "json-c")
- (version "0.14")
- (source (origin
- (inherit (package-source json-c))
- (patches (search-patches "json-c-CVE-2020-12762.patch"))))))
-
;; TODO: Remove these old versions when all dependents have been updated.
(define-public json-c-0.13
(package