summaryrefslogtreecommitdiff
path: root/etc
diff options
context:
space:
mode:
Diffstat (limited to 'etc')
-rw-r--r--etc/guix-daemon.cil.in21
-rwxr-xr-xetc/guix-install.sh12
-rw-r--r--etc/snippets/tempel/text-mode2
-rw-r--r--etc/teams.scm.in19
4 files changed, 45 insertions, 9 deletions
diff --git a/etc/guix-daemon.cil.in b/etc/guix-daemon.cil.in
index f4767ff666..f55ef226c1 100644
--- a/etc/guix-daemon.cil.in
+++ b/etc/guix-daemon.cil.in
@@ -1,6 +1,6 @@
; -*- lisp -*-
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2018, 2022 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Daniel Brooks <db48x@db48x.net>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;;
@@ -37,11 +37,13 @@
(block guix_daemon
;; Require existing types
+ (typeattributeset cil_gen_require domain)
(typeattributeset cil_gen_require init_t)
- (typeattributeset cil_gen_require tmp_t)
+ (typeattributeset cil_gen_require init_var_run_t)
(typeattributeset cil_gen_require nscd_var_run_t)
+ (typeattributeset cil_gen_require system_dbusd_var_run_t)
+ (typeattributeset cil_gen_require tmp_t)
(typeattributeset cil_gen_require var_log_t)
- (typeattributeset cil_gen_require domain)
;; Declare own types
(type guix_daemon_t)
@@ -92,6 +94,9 @@
(allow init_t
guix_store_content_t
(file (open read execute)))
+ (allow init_t
+ guix_profiles_t
+ (dir (setattr)))
;; guix-daemon needs to know the names of users
(allow guix_daemon_t
@@ -284,6 +289,14 @@
guix_store_content_t
(sock_file (create getattr setattr unlink write)))
+ ;; Access to run state directories
+ (allow guix_daemon_t
+ system_dbusd_var_run_t
+ (dir (search)))
+ (allow guix_daemon_t
+ init_var_run_t
+ (dir (search)))
+
;; Access to configuration files and directories
(allow guix_daemon_t
guix_daemon_conf_t
@@ -447,6 +460,8 @@
any (unconfined_u object_r guix_store_content_t (low low)))
(filecon "@prefix@/bin/guix-daemon"
file (system_u object_r guix_daemon_exec_t (low low)))
+ (filecon "@guix_localstatedir@/guix/profiles/per-user/[^/]+/current-guix/bin/guix-daemon"
+ file (system_u object_r guix_daemon_exec_t (low low)))
(filecon "@storedir@/.+-(guix-.+|profile)/bin/guix-daemon"
file (system_u object_r guix_daemon_exec_t (low low)))
(filecon "@storedir@/[a-z0-9]+-guix-daemon"
diff --git a/etc/guix-install.sh b/etc/guix-install.sh
index fb9006b3e2..3ce9affc06 100755
--- a/etc/guix-install.sh
+++ b/etc/guix-install.sh
@@ -53,6 +53,7 @@ REQUIRE=(
"chmod"
"uname"
"groupadd"
+ "useradd"
"tail"
"tr"
"xz"
@@ -120,10 +121,8 @@ chk_require()
command -v "$c" &>/dev/null || warn+=("$c")
done
- [ "${#warn}" -ne 0 ] &&
- { _err "${ERR}Missing commands: ${warn[*]}.";
- return 1; }
-
+ [ "${#warn}" -ne 0 ] && die "Missing commands: ${warn[*]}."
+
_msg "${PAS}verification of required commands completed"
}
@@ -615,7 +614,10 @@ https://www.gnu.org/software/guix/
EOF
# Don't use ‘read -p’ here! It won't display when run non-interactively.
echo -n "Press return to continue..."$'\r'
- read -r char
+ if ! read -r char; then
+ echo
+ die "Can't read standard input. Hint: don't pipe scripts into a shell."
+ fi
if [ "$char" ]; then
echo
echo "...that ($char) was not a return!"
diff --git a/etc/snippets/tempel/text-mode b/etc/snippets/tempel/text-mode
index fd0e95eaa6..1cda91cba0 100644
--- a/etc/snippets/tempel/text-mode
+++ b/etc/snippets/tempel/text-mode
@@ -1,6 +1,6 @@
-*- mode: lisp-data -*-
-text-mode :when (and (fboundp 'git-commit-mode) (git-commit-mode))
+text-mode :when (and (fboundp 'git-commit-mode) git-commit-mode)
(add\ "gnu: Add "
(p (with-temp-buffer
diff --git a/etc/teams.scm.in b/etc/teams.scm.in
index 57d4357900..f42a7f6f28 100644
--- a/etc/teams.scm.in
+++ b/etc/teams.scm.in
@@ -360,6 +360,17 @@ asdf-build-system."
"gnu/packages/motti.scm"
"guix/build/minetest-build-system.scm")))
+(define-team localization
+ (team 'localization
+ #:name "Localization (l10n) team"
+ #:description
+ "Localization of your system to specific languages."
+ #:scope (list "gnu/packages/anthy.scm"
+ "gnu/packages/fcitx5.scm"
+ "gnu/packages/fcitx.scm"
+ "gnu/packages/fonts.scm"
+ "gnu/packages/ibus.scm")))
+
(define-team translations
(team 'translations
#:name "Translations"
@@ -428,6 +439,10 @@ importer."
"andreas@enge.fr")
science)
+(define-member (person "Tobias Geerinckx-Rice"
+ "me@tobias.gr")
+ core kernel mentors)
+
(define-member (person "Björn Höfling"
"bjoern.hoefling@bjoernhoefling.de")
java)
@@ -500,6 +515,10 @@ importer."
"rg@raghavgururajan.name")
mentors)
+(define-member (person "宋文武"
+ "iyzsong@envs.net")
+ games localization)
+
(define (find-team name)
(or (hash-ref %teams (string->symbol name))