summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm24
1 files changed, 11 insertions, 13 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 4dba607bd6..113b8e2481 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -67,6 +67,7 @@
;;; Copyright © 2024 dan <i@dan.games>
;;; Copyright © 2024 gemmaro <gemmaro.dev@gmail.com>
;;; Copyright © 2024 Richard Sent <richard@freakingpenguin.com>
+;;; Copyright © 2024 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -384,11 +385,9 @@ interface and is based on GNU Guile.")
"/lib/guile/3.0/site-ccache"))))))
#~%standard-phases)))
- ;; Note: Use 'guile-3.0-latest' to address the continuation-related memory
- ;; leak reported at <https://issues.guix.gnu.org/58631>.
- (native-inputs (list pkg-config guile-3.0-latest
+ (native-inputs (list pkg-config guile-3.0
guile-fibers-1.1)) ;for cross-compilation
- (inputs (list guile-3.0-latest guile-fibers-1.1))))
+ (inputs (list guile-3.0 guile-fibers-1.1))))
(define-public shepherd-0.10
(package
@@ -2715,7 +2714,7 @@ environment variable is set and output is to tty.")
(define-public lr
(package
(name "lr")
- (version "1.5.1")
+ (version "1.6")
(source
(origin
(method git-fetch)
@@ -2724,10 +2723,10 @@ environment variable is set and output is to tty.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1wv2acm4r5y5gg6f64v2hiwpg1f3lnr4fy1a9zssw77fmdc7ys3j"))))
+ (base32 "0qixmvxikyz02348xc0a718m9b1pzcazvf36rjbdk6ayn66g9hsd"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f
+ `(#:tests? #f ; There are no tests.
#:make-flags (list (string-append "CC=" ,(cc-for-target))
(string-append "PREFIX=" %output))
#:phases (modify-phases %standard-phases
@@ -2862,13 +2861,13 @@ specified directories.")
(define-public ansible-core
(package
(name "ansible-core")
- (version "2.15.5")
+ (version "2.17.1")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "ansible-core" version))
+ (uri (pypi-uri "ansible_core" version))
(sha256
- (base32 "00hnwjk4dxgxbz4xlza2wqx20yks5xr7074hzlzsyja3ip5kkicc"))))
+ (base32 "007ginimzbizx2c3fp3vccizscyki0fp4yg3bzl3qz6ipdqrsi26"))))
(build-system python-build-system)
(arguments
`(#:modules ((guix build python-build-system)
@@ -3000,13 +2999,13 @@ provides the following commands:
(define-public ansible
(package
(name "ansible")
- (version "8.5.0")
+ (version "10.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "ansible" version))
(sha256
- (base32 "0bazj5h12wraf30bb2schzwk553y20n9vh45km4b5kgmvadm0z1j"))))
+ (base32 "0apj783acx4jzkf3bnibn4y5jc6jd8ly7l0rdqq8f1jpgxal933x"))))
(build-system python-build-system)
(propagated-inputs (list ansible-core))
;; The Ansible collections are found by ansible-core via the Python search
@@ -6146,7 +6145,6 @@ file or files to several hosts.")
(arguments
(list #:import-path "github.com/digitalocean/doctl/cmd/doctl"
#:unpack-path "github.com/digitalocean/doctl"
- #:go go-1.19
#:build-flags
#~(list (string-append "-ldflags=-X github.com/digitalocean/doctl.Label=release"
" -X github.com/digitalocean/doctl.Major="