summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm48
1 files changed, 25 insertions, 23 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 4dba607bd6..73d1b68855 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -67,6 +67,7 @@
;;; Copyright © 2024 dan <i@dan.games>
;;; Copyright © 2024 gemmaro <gemmaro.dev@gmail.com>
;;; Copyright © 2024 Richard Sent <richard@freakingpenguin.com>
+;;; Copyright © 2024 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -219,7 +220,7 @@
(lambda _
(substitute* "configure.ac"
(("supath=`which su 2>/dev/null`")
- "supath=/run/setuid-programs/su"))
+ "supath=/run/privileged/bin/su"))
#t)))))
(native-inputs
(list autoconf automake libtool pkg-config))
@@ -384,11 +385,9 @@ interface and is based on GNU Guile.")
"/lib/guile/3.0/site-ccache"))))))
#~%standard-phases)))
- ;; Note: Use 'guile-3.0-latest' to address the continuation-related memory
- ;; leak reported at <https://issues.guix.gnu.org/58631>.
- (native-inputs (list pkg-config guile-3.0-latest
+ (native-inputs (list pkg-config guile-3.0
guile-fibers-1.1)) ;for cross-compilation
- (inputs (list guile-3.0-latest guile-fibers-1.1))))
+ (inputs (list guile-3.0 guile-fibers-1.1))))
(define-public shepherd-0.10
(package
@@ -2157,7 +2156,7 @@ commands and their arguments.")
(substitute* "doas.c"
(("safepath =" match)
(string-append match " \""
- "/run/setuid-programs:"
+ "/run/privileged/bin:"
"/run/current-system/profile/bin:"
"/run/current-system/profile/sbin:"
"\" ")))))
@@ -2594,7 +2593,11 @@ system is under heavy load.")
(base32 "1z9vjn2131iv3pwrh04z6r5ygi1qgad5bi3jhghcvc3v1b4k5ran"))))
(build-system gnu-build-system)
(arguments
- (list #:make-flags
+ ;; XXX The test suite seems to cause instability on the VisionFive 2
+ ;; build machines, maybe it's stressing them as intended but this is
+ ;; unhelpful
+ (list #:tests? (not (target-riscv64?))
+ #:make-flags
#~(list (string-append "CC=" #$(cc-for-target))
(string-append "BINDIR=" #$output "/bin")
;; XXX Really: MAN1DIR, or man pages won't be found.
@@ -2715,7 +2718,7 @@ environment variable is set and output is to tty.")
(define-public lr
(package
(name "lr")
- (version "1.5.1")
+ (version "1.6")
(source
(origin
(method git-fetch)
@@ -2724,10 +2727,10 @@ environment variable is set and output is to tty.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1wv2acm4r5y5gg6f64v2hiwpg1f3lnr4fy1a9zssw77fmdc7ys3j"))))
+ (base32 "0qixmvxikyz02348xc0a718m9b1pzcazvf36rjbdk6ayn66g9hsd"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f
+ `(#:tests? #f ; There are no tests.
#:make-flags (list (string-append "CC=" ,(cc-for-target))
(string-append "PREFIX=" %output))
#:phases (modify-phases %standard-phases
@@ -2742,14 +2745,14 @@ features of ls(1), find(1), stat(1) and du(1).")
(define-public direvent
(package
(name "direvent")
- (version "5.3")
+ (version "5.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/direvent/direvent-"
version ".tar.gz"))
(sha256
(base32
- "15y4jk5vlcd003bvf42c6z9zd4gz4pwqpwaapqmyk7x4gnksh1cl"))))
+ "1flmswj1by9afqal55hc70l2hshcawyn0j2if92y6rxb58cwdfqx"))))
(build-system gnu-build-system)
(arguments
(list #:phases
@@ -2862,13 +2865,13 @@ specified directories.")
(define-public ansible-core
(package
(name "ansible-core")
- (version "2.15.5")
+ (version "2.17.1")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "ansible-core" version))
+ (uri (pypi-uri "ansible_core" version))
(sha256
- (base32 "00hnwjk4dxgxbz4xlza2wqx20yks5xr7074hzlzsyja3ip5kkicc"))))
+ (base32 "007ginimzbizx2c3fp3vccizscyki0fp4yg3bzl3qz6ipdqrsi26"))))
(build-system python-build-system)
(arguments
`(#:modules ((guix build python-build-system)
@@ -3000,13 +3003,13 @@ provides the following commands:
(define-public ansible
(package
(name "ansible")
- (version "8.5.0")
+ (version "10.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "ansible" version))
(sha256
- (base32 "0bazj5h12wraf30bb2schzwk553y20n9vh45km4b5kgmvadm0z1j"))))
+ (base32 "0apj783acx4jzkf3bnibn4y5jc6jd8ly7l0rdqq8f1jpgxal933x"))))
(build-system python-build-system)
(propagated-inputs (list ansible-core))
;; The Ansible collections are found by ansible-core via the Python search
@@ -3615,14 +3618,14 @@ a new command using the matched rule, and runs it.")
(define-public di
(package
(name "di")
- (version "4.52")
+ (version "4.53")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/diskinfo-di/"
"di-" version ".tar.gz"))
(sha256
- (base32 "07vsnn1gxm3r7dchbrq63iazd64gza2ac7b2m1039708rf5flxdp"))))
+ (base32 "0gp806m7jk2rfymy5r62a2lfd8jq879qy94blrjqvb0xq7pmpp80"))))
(build-system gnu-build-system)
(arguments
(list
@@ -5087,7 +5090,7 @@ text table representation to stdout.")
":" (assoc-ref %build-inputs "grep") "/bin"
":" (assoc-ref %build-inputs "ncurses") "/bin"
":" (assoc-ref %build-inputs "sed") "/bin"
- ":" "/run/setuid-programs"
+ ":" "/run/privileged/bin"
":" (getenv "PATH")))
(substitute* "hosts"
(("#!/usr/bin/env bash")
@@ -5166,14 +5169,14 @@ Netgear devices.")
(define-public atop
(package
(name "atop")
- (version "2.10.0")
+ (version "2.11.0")
(source (origin
(method url-fetch)
(uri (string-append "https://www.atoptool.nl/download/atop-"
version ".tar.gz"))
(sha256
(base32
- "14szbpvsm9czib1629cbh8qcp7pxhgn0vjrfv1yqwmw25k7p79p7"))
+ "083fckjn2s3276fqyjb3rcwqrws7qc3fgk1f82zzgzrfc1kcd54v"))
(snippet
;; The 'mkdate' script generates a new 'versdate.h' header
;; containing the build date. That makes builds
@@ -6146,7 +6149,6 @@ file or files to several hosts.")
(arguments
(list #:import-path "github.com/digitalocean/doctl/cmd/doctl"
#:unpack-path "github.com/digitalocean/doctl"
- #:go go-1.19
#:build-flags
#~(list (string-append "-ldflags=-X github.com/digitalocean/doctl.Label=release"
" -X github.com/digitalocean/doctl.Major="