summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 5fb621e027..668d710739 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2506,20 +2506,24 @@ characters can be replaced as well, as can UTF-8 characters.")
(define-public tree
(package
(name "tree")
- (version "2.0.3")
+ (version "2.0.4")
(source (origin
(method url-fetch)
(uri (string-append
- "http://mama.indstate.edu/users/ice/tree/src/tree-"
+ "https://mama.indstate.edu/users/ice/tree/src/tree-"
version ".tgz"))
(sha256
- (base32 "079vda37d5i3nfx12wx81z6r6bxynv2jww1z1hjziiwxbxxyf55s"))))
+ (base32 "0x7s9wxvf83fw4qah16kapswl2277pybw3d514zrlms9g0cr5smh"))))
(build-system gnu-build-system)
(arguments
(list
#:phases
#~(modify-phases %standard-phases
- (delete 'configure)) ; No configure script.
+ (delete 'configure) ; No configure script.
+ (add-after 'unpack 'fix-manpage-version
+ (lambda _
+ (substitute* "doc/tree.1"
+ (("Tree 2\\.0\\.0") (string-append "Tree " #$version))))))
#:tests? #f ; No check target.
#:make-flags
#~(list (string-append "PREFIX=" #$output)
@@ -2529,7 +2533,7 @@ characters can be replaced as well, as can UTF-8 characters.")
"Tree is a recursive directory listing command that produces a depth
indented listing of files, which is colorized ala dircolors if the LS_COLORS
environment variable is set and output is to tty.")
- (home-page "http://mama.indstate.edu/users/ice/tree/")
+ (home-page "https://mama.indstate.edu/users/ice/tree/")
(license license:gpl2+)))
(define-public lr