summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm41
1 files changed, 36 insertions, 5 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index dcd4711513..cf06732e18 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -8,8 +8,8 @@
;;; Copyright © 2016, 2017 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2016 ng0 <ng0@n0.is>
;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
-;;; Copyright © 2016, 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018 okapi <okapi@firemail.cc>
;;; Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
@@ -722,6 +722,36 @@ performances. The plugins include a cellular automaton synthesizer, an
envelope follower, distortion effects, tape effects and more.")
(license license:gpl2+)))
+(define-public swh-plugins
+ (package
+ (name "swh-plugins")
+ (version "0.4.17")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/swh/ladspa.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1c98z2xxz9pgcb4dg99gz8qrylh5cnag0j18a52d88ifsy24isvq"))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gettext" ,gettext-minimal) ;for autopoint
+ ("libtool" ,libtool)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("which" ,which)))
+ (inputs
+ `(("fftwf" ,fftwf)
+ ("perl-xml-parser" ,perl-xml-parser)))
+ (build-system gnu-build-system)
+ (home-page "http://plugin.org.uk")
+ (synopsis "The SWH Plugins package for the LADSPA plugin system")
+ (description "This package provides Steve Harris's LADSPA plugins.")
+ (license license:gpl2+)))
+
(define-public swh-plugins-lv2
(package
(name "swh-plugins-lv2")
@@ -2733,7 +2763,7 @@ Tracker 3 S3M and Impulse Tracker IT files.")
(define-public soundtouch
(package
(name "soundtouch")
- (version "2.1.1")
+ (version "2.1.2")
(source
(origin
(method git-fetch)
@@ -2742,7 +2772,7 @@ Tracker 3 S3M and Impulse Tracker IT files.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0p6jzgfgqw061702dmd2b6r4arz48ac3mmx2qkvvzf8s5jjzykdh"))))
+ (base32 "174wgm3s0inmbnkrlnspxjwm2014qhjhkbdqa5r8rbfi0nzqxzsz"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
@@ -3562,7 +3592,8 @@ the following features:
`(("which" ,which)))
(inputs
`(("fftw" ,fftw)
- ("googletest" ,googletest)
+ ;; TODO: Try using the latest googletest for versions > 1.6.
+ ("googletest" ,googletest-1.8)
("ncurses" ,ncurses)
("pulseaudio" ,pulseaudio)))
(arguments