summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm152
1 files changed, 152 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 6fea723fd8..426618147f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2016, 2018 Raoul Bonnal <ilpuccio.febo@gmail.com>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -12685,6 +12686,13 @@ once. This package provides tools to perform Drop-seq analyses.")
`(#:parallel-tests? #f ; not supported
#:phases
(modify-phases %standard-phases
+ ;; "test.sh" runs STAR, which requires excessive amounts of memory.
+ (add-after 'unpack 'disable-resource-intensive-test
+ (lambda _
+ (substitute* "Makefile.in"
+ (("(^ tests/test_trim_galore/test.sh).*" _ m) m)
+ (("^ test.sh") ""))
+ #t))
(add-after 'install 'wrap-executable
;; Make sure the executable finds all R modules.
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -12864,3 +12872,147 @@ data of bisulfite experiments; it produces reports on aggregate methylation
and coverage and can be used to produce information on differential
methylation and segmentation.")
(license license:gpl3+)))
+
+(define-public pigx-scrnaseq
+ (package
+ (name "pigx-scrnaseq")
+ (version "0.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/BIMSBbioinfo/pigx_scrnaseq/"
+ "releases/download/v" version
+ "/pigx_scrnaseq-" version ".tar.gz"))
+ (sha256
+ (base32
+ "03gwp83823ji59y6nvyz89i4yd3faaqpc3791qia71i91470vfsg"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list (string-append "PICARDJAR=" (assoc-ref %build-inputs "java-picard")
+ "/share/java/picard.jar")
+ (string-append "DROPSEQJAR=" (assoc-ref %build-inputs "dropseq-tools")
+ "/share/java/dropseq.jar"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-executable
+ ;; Make sure the executable finds all R modules.
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (wrap-program (string-append out "/bin/pigx-scrnaseq")
+ `("R_LIBS_SITE" ":" = (,(getenv "R_LIBS_SITE")))
+ `("PYTHONPATH" ":" = (,(getenv "PYTHONPATH")))))
+ #t)))))
+ (inputs
+ `(("dropseq-tools" ,dropseq-tools)
+ ("fastqc" ,fastqc)
+ ("java-picard" ,java-picard)
+ ("java" ,icedtea-8)
+ ("python-wrapper" ,python-wrapper)
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-pandas" ,python-pandas)
+ ("python-numpy" ,python-numpy)
+ ("python-loompy" ,python-loompy)
+ ("ghc-pandoc" ,ghc-pandoc)
+ ("ghc-pandoc-citeproc" ,ghc-pandoc-citeproc)
+ ("snakemake" ,snakemake)
+ ("star" ,star)
+ ("r-minimal" ,r-minimal)
+ ("r-argparser" ,r-argparser)
+ ("r-cowplot" ,r-cowplot)
+ ("r-data-table" ,r-data-table)
+ ("r-delayedarray" ,r-delayedarray)
+ ("r-delayedmatrixstats" ,r-delayedmatrixstats)
+ ("r-dplyr" ,r-dplyr)
+ ("r-dropbead" ,r-dropbead)
+ ("r-dt" ,r-dt)
+ ("r-genomicalignments" ,r-genomicalignments)
+ ("r-genomicfiles" ,r-genomicfiles)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-hdf5array" ,r-hdf5array)
+ ("r-pheatmap" ,r-pheatmap)
+ ("r-rmarkdown" ,r-rmarkdown)
+ ("r-rsamtools" ,r-rsamtools)
+ ("r-rtracklayer" ,r-rtracklayer)
+ ("r-rtsne" ,r-rtsne)
+ ("r-scater" ,r-scater)
+ ("r-scran" ,r-scran)
+ ("r-singlecellexperiment" ,r-singlecellexperiment)
+ ("r-stringr" ,r-stringr)
+ ("r-yaml" ,r-yaml)))
+ (home-page "http://bioinformatics.mdc-berlin.de/pigx/")
+ (synopsis "Analysis pipeline for single-cell RNA sequencing experiments")
+ (description "PiGX scRNAseq is an analysis pipeline for preprocessing and
+quality control for single cell RNA sequencing experiments. The inputs are
+read files from the sequencing experiment, and a configuration file which
+describes the experiment. It produces processed files for downstream analysis
+and interactive quality reports. The pipeline is designed to work with UMI
+based methods.")
+ (license license:gpl3+)))
+
+(define-public pigx
+ (package
+ (name "pigx")
+ (version "0.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/BIMSBbioinfo/pigx/"
+ "releases/download/v" version
+ "/pigx-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1nxb2hbp40yg3j7n56k4dhsd2fl1j8g0wpiiln56prqzljwnlgmf"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("python" ,python)
+ ("pigx-bsseq" ,pigx-bsseq)
+ ("pigx-chipseq" ,pigx-chipseq)
+ ("pigx-rnaseq" ,pigx-rnaseq)
+ ("pigx-scrnaseq" ,pigx-scrnaseq)))
+ (home-page "http://bioinformatics.mdc-berlin.de/pigx/")
+ (synopsis "Analysis pipelines for genomics")
+ (description "PiGx is a collection of genomics pipelines. It includes the
+following pipelines:
+
+@itemize
+@item PiGx BSseq for raw fastq read data of bisulfite experiments
+@item PiGx RNAseq for RNAseq samples
+@item PiGx scRNAseq for single cell dropseq analysis
+@item PiGx ChIPseq for reads from ChIPseq experiments
+@end itemize
+
+All pipelines are easily configured with a simple sample sheet and a
+descriptive settings file. The result is a set of comprehensive, interactive
+HTML reports with interesting findings about your samples.")
+ (license license:gpl3+)))
+
+(define-public r-diversitree
+ (package
+ (name "r-diversitree")
+ (version "0.9-10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "diversitree" version))
+ (sha256
+ (base32
+ "0gh4rcrp0an3jh8915i1fsxlgyfk7njywgbd5ln5r2jhr085kpz7"))))
+ (build-system r-build-system)
+ (native-inputs
+ `(("gfortran" ,gfortran)))
+ (inputs `(("fftw" ,fftw) ("gsl" ,gsl)))
+ (propagated-inputs
+ `(("r-ape" ,r-ape)
+ ("r-desolve" ,r-desolve)
+ ("r-rcpp" ,r-rcpp)
+ ("r-suplex" ,r-subplex)))
+ (home-page "https://www.zoology.ubc.ca/prog/diversitree")
+ (synopsis "Comparative 'phylogenetic' analyses of diversification")
+ (description "This package contains a number of comparative \"phylogenetic\"
+methods, mostly focusing on analysing diversification and character evolution.
+Contains implementations of \"BiSSE\" (Binary State Speciation and Extinction)
+and its unresolved tree extensions, \"MuSSE\" (Multiple State Speciation and
+Extinction), \"QuaSSE\", \"GeoSSE\", and \"BiSSE-ness\" Other included methods
+include Markov models of discrete and continuous trait evolution and constant
+rate speciation and extinction.")
+ (license license:gpl2+)))