summaryrefslogtreecommitdiff
path: root/gnu/packages/bittorrent.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bittorrent.scm')
-rw-r--r--gnu/packages/bittorrent.scm16
1 files changed, 10 insertions, 6 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 731c8e1c20..8c032940d4 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -488,12 +488,16 @@ and will take advantage of multiple processor cores where possible.")
;; test_fast_extension, test_privacy and test_resolve_links
;; to hang, even with FAKETIME_ONLY_CMDS. Not sure why. So
;; execute only test_ssl under faketime.
- (invoke "faketime" "2022-10-24"
- "ctest"
- "-R" "^test_ssl$"
- "-j" jobs
- "--timeout" timeout
- "--output-on-failure"))))))))
+ ;;
+ ;; Note: The test_ssl test times out in the ci.
+ ;; Temporarily disable it until that is resolved.
+ ;; (invoke "faketime" "2022-10-24"
+ ;; "ctest"
+ ;; "-R" "^test_ssl$"
+ ;; "-j" jobs
+ ;; "--timeout" timeout
+ ;; "--output-on-failure")
+ )))))))
(inputs (list boost openssl))
(native-inputs `(("libfaketime" ,libfaketime)
("python-wrapper" ,python-wrapper)