summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm26
1 files changed, 25 insertions, 1 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 17c2b7284e..87728fefa3 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -24,7 +24,7 @@
;;; Copyright © 2017, 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017, 2019 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2017 Nikita <nikita@n0.is>
-;;; Copyright © 2015, 2017, 2018, 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2017, 2018, 2020, 2021, 2023 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016-2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2017, 2018, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
@@ -2465,6 +2465,30 @@ Pytest that runs the mypy static type checker on your source files as part of
a Pytest test execution.")
(license license:expat)))
+(define-public python-pytest-mypy-plugins
+ (package
+ (name "python-pytest-mypy-plugins")
+ (version "1.10.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-mypy-plugins" version))
+ (sha256
+ (base32
+ "05ng29b05gasqj195i9hyyhx5shmwypyvajb7plxwha3g36qq98z"))))
+ (build-system pyproject-build-system)
+ (arguments (list #:tests? #false)) ;there are none
+ (propagated-inputs (list python-chevron
+ python-decorator
+ python-mypy
+ python-pytest
+ python-pyyaml
+ python-regex))
+ (home-page "https://github.com/TypedDjango/pytest-mypy-plugins")
+ (synopsis "Pytest plugin for writing tests for mypy plugins")
+ (description "This package provides a pytest plugin for writing tests for
+mypy plugins.")
+ (license license:expat)))
+
(define-public python-pytest-pep8
(package
(name "python-pytest-pep8")