summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 7cf7269f7f..c8df516834 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -2102,6 +2102,22 @@ different floating point sizes and complex transformations.")
parsing with only a single memory allocation.")
(license license:expat))))
+(define-public sajson-for-gemmi
+ (package/inherit sajson
+ (name "sajson-for-gemmi")
+ (source (origin
+ (inherit (package-source sajson))
+ (patches (cons
+ (search-patch
+ "sajson-for-gemmi-numbers-as-strings.patch")
+ (origin-patches (package-source sajson))))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments sajson)
+ ;; This is a modified version used in gemmi, in which numbers are kept
+ ;; as strings. Building the tests fails with the modification.
+ ((#:tests? _ #f) #f)))
+ (properties '((hidden? . #t)))))
+
(define-public optionparser
(package
(name "optionparser")