summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm37
1 files changed, 27 insertions, 10 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 35b9db04d2..2002b34c52 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -31092,30 +31092,47 @@ package is part of Gitoxide, a pure Rust implementation of Git.")
("rust-serde" ,rust-serde-1)
("rust-thiserror" ,rust-thiserror-1))))))
-(define-public rust-gix-hashtable-0.2
+(define-public rust-gix-hashtable-0.4
(package
(name "rust-gix-hashtable")
- (version "0.2.4")
+ (version "0.4.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "gix-hashtable" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "13f5v6vghfpzxm5xkmk86gjhsjfqng9rpam37hqjssgkxkk4qprq"))))
+ (base32 "05ka2z2z1qcxmfw8abvc5fgvygrrjfiaaz61h6701ba11146i4j0"))))
(build-system cargo-build-system)
(arguments
- `(#:cargo-inputs
- (("rust-gix-hash" ,rust-gix-hash-0.11)
- ("rust-hashbrown" ,rust-hashbrown-0.14)
- ("rust-parking-lot" ,rust-parking-lot-0.12))))
+ `(#:cargo-inputs (("rust-gix-hash" ,rust-gix-hash-0.13)
+ ("rust-hashbrown" ,rust-hashbrown-0.14)
+ ("rust-parking-lot" ,rust-parking-lot-0.12))))
(home-page "https://github.com/Byron/gitoxide")
- (synopsis "Hashtable based data structures optimized to utilize ObjectId keys")
+ (synopsis
+ "Hashtable based data structures optimized to utilize ObjectId keys")
(description
- "This package provides a crate that provides hashtable based data structures
-optimized to utilize @code{ObjectId} keys.")
+ "Hashtable based data structures optimized to utilize @code{ObjectId}
+keys. Part of Gitoxide a Rust implementation of Git.")
(license (list license:expat license:asl2.0))))
+(define-public rust-gix-hashtable-0.2
+ (package
+ (inherit rust-gix-hashtable-0.4)
+ (name "rust-gix-hashtable")
+ (version "0.2.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "gix-hashtable" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "13f5v6vghfpzxm5xkmk86gjhsjfqng9rpam37hqjssgkxkk4qprq"))))
+ (arguments
+ `(#:cargo-inputs (("rust-gix-hash" ,rust-gix-hash-0.11)
+ ("rust-hashbrown" ,rust-hashbrown-0.14)
+ ("rust-parking-lot" ,rust-parking-lot-0.12))))))
+
(define-public rust-gix-ignore-0.3
(package
(name "rust-gix-ignore")