summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm43
1 files changed, 37 insertions, 6 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 61328fec39..96a59e8024 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -59,7 +59,7 @@
;;; Copyright © 2022 muradm <mail@muradm.net>
;;; Copyright © 2022 Thomas Albers Raviola <thomas@thomaslabs.org>
;;; Copyright © 2021, 2022 jgart <jgart@dismail.de>
-;;; Copyright © 2023 Felix Gruber <felgru@posteo.ne
+;;; Copyright © 2023, 2024 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2023 Munyoki Kilyungi <me@bonfacemunyoki.com>
;;; Copyright © 2023 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
@@ -195,7 +195,7 @@
(define-public duckdb
(package
(name "duckdb")
- (version "0.9.2")
+ (version "1.0.0")
(source
(origin
(method git-fetch)
@@ -205,7 +205,7 @@
(file-name (git-file-name name version))
(sha256
(base32
- "0dbsxyiz7c8sxflbfj87qv0b2s69zk802vsk5h00ra8w8fcbqlj0"))
+ "11yqgnf354g3fjj0rvsw8zzz915vf9i3jxmpchpwy09yzxd72cbg"))
(modules '((guix build utils)))
(snippet
#~(begin
@@ -614,6 +614,38 @@ the API, and provides features such as:
@end itemize")
(license license:bsd-3)))
+(define-public python-adbc-driver-manager
+ (package
+ (name "python-adbc-driver-manager")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "adbc_driver_manager" version))
+ (sha256
+ (base32 "00i3zg6rbzdz767j9w22ajw8rxwbhkrmzwwlmx11q56cvnig0cm3"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; TODO: Pack arrow-adbc/c/driver/sqlite for tests.
+ #:tests? #f
+ #:build-backend "setuptools.build_meta"))
+ (propagated-inputs
+ (list python-typing-extensions))
+ (native-inputs
+ (list python-cython-3
+ python-pytest))
+ (home-page "https://arrow.apache.org/adbc/")
+ (synopsis "Generic entrypoint for ADBC drivers in Python")
+ (description
+ "This package contains bindings for the ADBC Driver Manager, as well as a
+@url{https://peps.python.org/pep-0249/,DBAPI 2.0/PEP 249-compatible} interface
+on top. This can be used to load ADBC drivers at runtime and use them from
+Python. Backend-specific packages like @code{adbc_driver_postgresql} wrap
+this package in a more convenient interface, and should be preferred where
+they exist.")
+ (license license:asl2.0)))
+
(define-public python-prisma
(package
(name "python-prisma")
@@ -4618,7 +4650,7 @@ with integrated support for finding required rows quickly.")
(define-public apache-arrow
(package
(name "apache-arrow")
- (version "15.0.1")
+ (version "16.1.0")
(source
(origin
(method git-fetch)
@@ -4628,7 +4660,7 @@ with integrated support for finding required rows quickly.")
(file-name (git-file-name name version))
(sha256
(base32
- "0zrcwsq9c976xncc1kg6lw24s5r3ag8vfzhmcnkvi5z2c9x4lvvc"))))
+ "1xl7apk7yaiv7cikpw5h846bsqb935cr3212b8bzhxqvkswxsm7f"))))
(build-system cmake-build-system)
(arguments
(list
@@ -5471,7 +5503,6 @@ compatible with SQLite using a graphical user interface.")
(build-system go-build-system)
(arguments
(list
- #:go go-1.21
#:install-source? #f
#:import-path "github.com/lighttiger2505/sqls"))
(native-inputs