summaryrefslogtreecommitdiff
path: root/gnu/packages/diffoscope.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/diffoscope.scm')
-rw-r--r--gnu/packages/diffoscope.scm31
1 files changed, 16 insertions, 15 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 16e3b2a481..1cb0a7ad76 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -74,7 +74,7 @@
(define-public diffoscope
(package
(name "diffoscope")
- (version "214")
+ (version "215")
(source
(origin
(method git-fetch)
@@ -83,7 +83,7 @@
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "05vzvs8yn963wzxmnqifj0zsa9scxcq3iqrq9msm0vqznb1xgp7q"))
+ (base32 "16pyqbyrfsxjnpmr9913x2brz3mxplhz62rxwix1c0p7afwjw835"))
(patches
(search-patches "diffoscope-fix-llvm-test.patch"))))
(build-system python-build-system)
@@ -98,19 +98,19 @@
(add-after 'unpack 'embed-tool-references
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "diffoscope/comparators/utils/compare.py"
- (("\\['xxd',")
- (string-append "['" (which "xxd") "',")))
- (substitute* "diffoscope/comparators/elf.py"
- (("@tool_required\\('readelf'\\)") "")
- (("get_tool_name\\('readelf'\\)")
- (string-append "'" (which "readelf") "'")))
+ (("\\[\"xxd\",")
+ (string-append "[\"" (which "xxd") "\",")))
+ (substitute* "diffoscope/diff.py"
+ (("@tool_required\\(\"diff\"\\)") "")
+ (("get_tool_name\\(\"diff\"\\)")
+ (string-append "get_tool_name(\"" (which "diff") "\")")))
(substitute* "diffoscope/comparators/directory.py"
- (("@tool_required\\('stat'\\)") "")
- (("@tool_required\\('getfacl'\\)") "")
- (("\\['stat',")
- (string-append "['" (which "stat") "',"))
- (("\\['getfacl',")
- (string-append "['" (which "getfacl") "',")))))
+ (("@tool_required\\(\"stat\"\\)") "")
+ (("@tool_required\\(\"getfacl\"\\)") "")
+ (("\\[\"stat\",")
+ (string-append "[\"" (which "stat") "\","))
+ (("\\[\"getfacl\",")
+ (string-append "[\"" (which "getfacl") "\",")))))
(add-after 'build 'build-man-page
(lambda* (#:key (make-flags '()) #:allow-other-keys)
(apply invoke "make" "-C" "doc" make-flags)))
@@ -147,7 +147,8 @@
python-magic
python-tlsh
acl ;for getfacl
- colordiff
+ coreutils ;for stat
+ diffutils ;for diff
xxd))
(native-inputs
(append