summaryrefslogtreecommitdiff
path: root/gnu/packages/docker.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/docker.scm')
-rw-r--r--gnu/packages/docker.scm32
1 files changed, 22 insertions, 10 deletions
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index cdde807046..4beba12c11 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -47,7 +48,7 @@
#:use-module (gnu packages version-control)
#:use-module (gnu packages virtualization))
-(define %docker-version "19.03.11")
+(define %docker-version "19.03.12")
(define-public python-docker-py
(package
@@ -65,7 +66,6 @@
(arguments '(#:tests? #f))
(inputs
`(("python-requests" ,python-requests-2.20)
- ("python-ipaddress" ,python-ipaddress)
("python-six" ,python-six)
("python-urllib3" ,python-urllib3-1.24)
("python-websocket-client" ,python-websocket-client)))
@@ -178,7 +178,7 @@ Python without keeping their credentials in a Docker configuration file.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/containerd/containerd.git")
+ (url "https://github.com/containerd/containerd")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -256,7 +256,7 @@ network attachments.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/docker/libnetwork.git")
+ (url "https://github.com/docker/libnetwork")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -310,11 +310,11 @@ built-in registry server of Docker.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/docker/engine.git")
+ (url "https://github.com/docker/engine")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1pmbggxbazipl24hxiaccbj32379zv79xba76l78v5131ihx922h"))
+ (base32 "1dj6llfcgcbpq9q9j6b4wb0anbn1g5wzm8ikq2lyhg54i3154m93"))
(patches
(search-patches "docker-fix-tests.patch"))))
(build-system gnu-build-system)
@@ -390,6 +390,17 @@ built-in registry server of Docker.")
(substitute* "pkg/archive/archive.go"
(("string\\{\"xz")
(string-append "string{\"" (assoc-ref inputs "xz") "/bin/xz")))
+ ;; TODO: Remove when Docker proper uses v1.14.x to build
+ (substitute* "registry/resumable/resumablerequestreader_test.go"
+ (("I%27m%20not%20an%20url" all)
+ (string-append "\"" all "\"")))
+ ;; TODO: Remove when Docker proper uses v1.14.x to build
+ (substitute* "vendor/gotest.tools/x/subtest/context.go"
+ (("func \\(tc \\*testcase\\) Cleanup\\(" all)
+ (string-append all "func()"))
+ (("tc\\.Cleanup\\(" all)
+ (string-append all "nil")))
+
(let ((source-files (filter (lambda (name)
(not (string-contains name "test")))
(find-files "." "\\.go$"))))
@@ -488,6 +499,7 @@ built-in registry server of Docker.")
;; Timeouts after 5 min.
(delete-file "plugin/manager_linux_test.go")
;; Operation not permitted.
+ (delete-file "daemon/graphdriver/aufs/aufs_test.go")
(delete-file "daemon/graphdriver/btrfs/btrfs_test.go")
(delete-file "daemon/graphdriver/overlay/overlay_test.go")
(delete-file "daemon/graphdriver/overlay2/overlay_test.go")
@@ -588,11 +600,11 @@ provisioning etc.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/docker/cli.git")
+ (url "https://github.com/docker/cli")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1y9ymv70r1hndblr64h19q34arxl2f3dqqi2qcrai5zfimcml6lr"))))
+ (base32 "1bynmnaykhh1m42v6bxparlpm9kajpqsvlrlwgz1b9ivcklf5ik6"))))
(build-system go-build-system)
(arguments
`(#:import-path "github.com/docker/cli"
@@ -658,7 +670,7 @@ provisioning etc.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/savoirfairelinux/cqfd.git")
+ (url "https://github.com/savoirfairelinux/cqfd")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -696,7 +708,7 @@ defined in a per-project configuration file.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/krallin/tini.git")
+ (url "https://github.com/krallin/tini")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256