summaryrefslogtreecommitdiff
path: root/gnu/packages/ebook.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ebook.scm')
-rw-r--r--gnu/packages/ebook.scm25
1 files changed, 14 insertions, 11 deletions
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index df4064ae56..b21fcfdc9a 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -56,12 +56,13 @@
#:use-module (gnu packages gnome)
#:use-module (gnu packages glib)
#:use-module (gnu packages gstreamer)
+ #:use-module (gnu packages hunspell)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages image)
#:use-module (gnu packages javascript)
#:use-module (gnu packages language)
- #:use-module (gnu packages libusb)
#:use-module (gnu packages libreoffice)
+ #:use-module (gnu packages libusb)
#:use-module (gnu packages music)
#:use-module (gnu packages pantheon)
#:use-module (gnu packages pdf)
@@ -197,6 +198,7 @@ with Microsoft Compiled HTML (CHM) files")
python-psutil
python-py7zr
python-pychm
+ python-pycryptodome
python-pygments
python-pyqt-without-qtwebkit
python-pyqtwebengine
@@ -386,34 +388,35 @@ accessing and converting various ebook file formats.")
(package
(name "inkbox")
(version "1.7")
+ (home-page "https://github.com/Kobo-InkBox/inkbox")
(source
(origin
(method git-fetch)
(uri
(git-reference
- (url "https://alpinekobox.ddns.net/InkBox/inkbox/")
+ (url home-page)
(commit version)))
(file-name (git-file-name name version))
(sha256
(base32 "126cqn0ixcn608lv2hd9f7zmzj4g448bnpxc7wv9cvg83qqajh5n"))))
(build-system qt-build-system)
(arguments
- '(#:tests? #f ; no test suite
- #:make-flags
- (list (string-append "PREFIX="
- (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
+ (list
+ #:tests? #f ; no test suite
+ #:make-flags
+ #~(list (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
(add-after 'unpack 'prefix-opt
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda _
(substitute* "inkbox.pro"
- (("/opt/\\$\\$\\{TARGET\\}") (string-append (assoc-ref outputs "out"))))))
+ (("/opt/\\$\\$\\{TARGET\\}")
+ #$output))))
(replace 'configure
(lambda* (#:key make-flags #:allow-other-keys)
(apply invoke (cons "qmake" make-flags)))))))
(native-inputs
(list qtbase-5))
- (home-page "https://alpinekobox.ddns.net/InkBox/inkbox/")
(synopsis "EBook reader")
(description "This package provides InkBox eBook reader.")
(license license:gpl3)))