summaryrefslogtreecommitdiff
path: root/gnu/packages/electronics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/electronics.scm')
-rw-r--r--gnu/packages/electronics.scm22
1 files changed, 9 insertions, 13 deletions
diff --git a/gnu/packages/electronics.scm b/gnu/packages/electronics.scm
index 98b71e041e..e1ab054bc7 100644
--- a/gnu/packages/electronics.scm
+++ b/gnu/packages/electronics.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2019 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -252,7 +252,7 @@ supported devices, as well as input/output file format support.")
(define-public openboardview
(package
(name "openboardview")
- (version "8.95.2")
+ (version "9.95.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -271,10 +271,10 @@ supported devices, as well as input/output file format support.")
(scandir "." (negate (cut member <> keep))))))
(patches
(search-patches "openboardview-use-system-imgui.patch"
- "openboardview-use-system-utf8.patch"))
+ "openboardview-use-system-mpc.patch"))
(sha256
(base32
- "1n2yfi8wpky0y231kq2zdgwn7f7kff8m53m904hxi5ppmwhx1d6q"))))
+ "1safjd729a7591rigkiy3c678bivrj5q1qwg1f18sijhlsfkf5b3"))))
(build-system cmake-build-system)
(arguments
(list
@@ -298,13 +298,6 @@ supported devices, as well as input/output file format support.")
"add_subdirectory("
(search-input-directory inputs "share/glad") ;source_dir
" src/glad)\n"))))) ;binary dir
- (add-before 'configure 'fix-utf8-include-directive
- ;; Our utf8-h package makes the header available as "utf8.h"
- ;; directly rather than "utf8/utf8.h".
- (lambda _
- (substitute* '("src/openboardview/FileFormats/BRDFile.cpp"
- "src/openboardview/BoardView.cpp")
- (("utf8/utf8.h") "utf8.h"))))
(add-before 'configure 'dynamically-load-gtk-via-absolute-path
;; The GTK library is not linked thus not present in the RUNPATH of
;; the produced binary; the absolute path of the libraries must to
@@ -327,11 +320,14 @@ supported devices, as well as input/output file format support.")
(inputs
(list fontconfig
gtk+
- imgui
+ ;; OpenBoardView can build with Dear ImGui 1.88, but there are some
+ ;; usability problems such as the difficulty to register clicks.
+ imgui-1.87
+ orangeduck-mpc
sdl2
sqlite
zlib))
- (home-page "https://openboardview.org/")
+ (home-page "https://github.com/OpenBoardView/OpenBoardView")
(synopsis "Viewer for BoardView files")
(description "OpenBoardView is a viewer for BoardView files, which present
the details of a printed circuit board (PCB). It comes with features