summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm178
1 files changed, 100 insertions, 78 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 17dc6b456e..c8c914e283 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -153,6 +153,7 @@
#:use-module (gnu packages guile)
#:use-module (gnu packages gtk)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages graphviz)
#:use-module (gnu packages haskell-apps)
#:use-module (gnu packages ibus)
#:use-module (gnu packages java)
@@ -4083,7 +4084,7 @@ files and directories.")
(define-public emacs-fountain-mode
(package
(name "emacs-fountain-mode")
- (version "3.5.1")
+ (version "3.5.3")
(source
(origin
(method git-fetch)
@@ -4092,7 +4093,7 @@ files and directories.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0y7dd6qq4b95scj7fay4zzhkf0g0x89npylc4v1hz59b1yyylfqy"))))
+ (base32 "13k84dzjar67fa1ixicl6h8gxzblszd0ik8vi11bvipysgp3j3ws"))))
(build-system emacs-build-system)
(home-page "https://github.com/rnkn/fountain-mode")
(synopsis "Major mode for screenwriting in Fountain markup")
@@ -10860,6 +10861,28 @@ Emacs completion function instead.")
that uses the standard completion function completing-read.")
(license license:gpl3+)))
+(define-public emacs-yaml
+ (package
+ (name "emacs-yaml")
+ (version "0.3.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zkry/yaml.el")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13fjxrr7iyfagbm21p5is5jw1zv56ns2mnac145v8lqli6mrr5gx"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/zkry/yaml.el")
+ (synopsis "YAML parser in Elisp")
+ (description
+ "@code{yaml.el} is a YAML parser written in Emacs Lisp without any
+external dependencies. It provides an interface similar to the Emacs JSON
+parsing utility.")
+ (license license:gpl3+)))
+
(define-public emacs-yaml-mode
(package
(name "emacs-yaml-mode")
@@ -12262,7 +12285,7 @@ programming and reproducible research.")
(define-public emacs-org-contrib
(package
(name "emacs-org-contrib")
- (version "0.2")
+ (version "0.3")
(source
(origin
(method git-fetch)
@@ -12271,9 +12294,9 @@ programming and reproducible research.")
(commit (string-append "release_" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0dn6arrmm0rrm2vi94fj5fjb030ggxf8cvpmi68wr0fh8xm5l1sh"))
+ (base32 "17aca4mc3gbdh6nhlcaa5ymh1yy76nwysrvy9sfcqkzvd5lgagzc"))
;; XXX: ob-sclang.el is packaged separately to avoid the dependency on
- ;; SuperCollider and qtwebengine. This will be unnecessary in 0.3+
+ ;; SuperCollider and qtwebengine. This will be unnecessary in 0.4+
;; release as the file is going to be removed from the repository.
(modules '((guix build utils)))
(snippet '(begin (delete-file "lisp/ob-sclang.el")))))
@@ -12285,7 +12308,7 @@ programming and reproducible research.")
(lambda _
(chdir "lisp"))))))
(propagated-inputs
- `(("arduino-mode" ,emacs-arduino-mode) ;XXX: remove after 0.3+ release.
+ `(("arduino-mode" ,emacs-arduino-mode) ;XXX: remove after 0.4+ release.
("cider" ,emacs-cider)
("org" ,emacs-org)))
(home-page "https://git.sr.ht/~bzg/org-contrib")
@@ -14610,7 +14633,7 @@ a @url{http://json.org/, JSON} file.")
(define-public emacs-json-mode
(package
(name "emacs-json-mode")
- (version "1.7.0")
+ (version "1.8.0")
(source
(origin
(method git-fetch)
@@ -14619,7 +14642,7 @@ a @url{http://json.org/, JSON} file.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0i79lqzdg59vkqwjd3q092xxn9vhxspb1vn4pkis0vfvn46g01jy"))))
+ (base32 "0r0k56q58kb133l9x9nbisz9p2kbphfgw1l4g2xp0pjqsc9wvq8z"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-json-reformat" ,emacs-json-reformat)
@@ -18048,7 +18071,7 @@ navigate and display hierarchy structures.")
(define-public emacs-datetime
(package
(name "emacs-datetime")
- (version "0.7")
+ (version "0.7.1")
(source
(origin
(method git-fetch)
@@ -18057,7 +18080,7 @@ navigate and display hierarchy structures.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0g6qgp6zvrbiaq6yfzqs3bmnry43xspp3ra3hm17x80b6izdsn90"))))
+ (base32 "108zfj5hz9irgksgg48xdvvaa635m6nzclx7xaymylfcvlycskpl"))))
(build-system emacs-build-system)
(arguments
`(#:include (cons "^[^/]*\\.extmap$" %default-include)))
@@ -18070,12 +18093,12 @@ timestamps and date-time format strings library for Emacs.")
(license license:gpl3+)))
(define-public emacs-org-mind-map
- (let ((commit "9d6e262bedd94daf9de269f4d56de277275677cb")
- (revision "1"))
+ ;; XXX: Upstream does not provide any tag. The commit below corresponds to
+ ;; an exact version bump from the main file.
+ (let ((commit "477701b15cb0c8ed7f021ca76a4cb1a7d9ad6aa5"))
(package
(name "emacs-org-mind-map")
- (version (string-append "0.0.1" "-" revision "."
- (string-take commit 7)))
+ (version "0.4")
(source
(origin
(method git-fetch)
@@ -18084,8 +18107,7 @@ timestamps and date-time format strings library for Emacs.")
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32
- "0jgkkgq7g64zckrmjib0hvz0qy3ynz5vz13qbmlpf096l3bb65wn"))))
+ (base32 "08sj43py6aid4vpqgsm0v5n94mcmcil0047qjk033492glz6q55c"))))
(propagated-inputs
`(("emacs-dash" ,emacs-dash)))
(build-system emacs-build-system)
@@ -18116,12 +18138,12 @@ timestamps and date-time format strings library for Emacs.")
(license license:gpl3+)))
(define-public emacs-itail
- (let ((commit "6e43c20da03be3b9c6ece93b7dc3495975ec1888")
- (revision "1"))
+ ;; XXX: Upstream provides no tags. The commit below corresponds to an exact
+ ;; version bump from main file.
+ (let ((commit "6e43c20da03be3b9c6ece93b7dc3495975ec1888"))
(package
(name "emacs-itail")
- (version (string-append "0.0.1" "-" revision "."
- (string-take commit 7)))
+ (version "0.0.8")
(source
(origin
(method git-fetch)
@@ -18130,15 +18152,13 @@ timestamps and date-time format strings library for Emacs.")
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32
- "044nzxh1hq41faxw3lix0wy78vfz304pjcaa5a11dqfz7q3gx5cv"))))
+ (base32 "044nzxh1hq41faxw3lix0wy78vfz304pjcaa5a11dqfz7q3gx5cv"))))
(build-system emacs-build-system)
(home-page "https://github.com/re5et/itail")
(synopsis "Interactive @code{tail} Emacs mode")
- (description "@code{itail} provides interactive @code{tail} mode
-that allows you to filter the tail with unix pipes and highlight the
-contents of the tailed file. Works locally or on remote files using
-tramp.")
+ (description "@code{itail} provides interactive @code{tail} mode that
+allows you to filter the tail with Unix pipes and highlight the contents of
+the tailed file. It works locally or on remote files using Tramp.")
(license license:gpl3+))))
(define-public emacs-loop
@@ -20957,7 +20977,7 @@ See @code{helm-exwm-switch-browser} for an example.")
(define-public emacs-helm-ls-git
(package
(name "emacs-helm-ls-git")
- (version "1.9.2")
+ (version "1.9.3")
(source
(origin
(method git-fetch)
@@ -20966,7 +20986,7 @@ See @code{helm-exwm-switch-browser} for an example.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "07jgkc8csnc2hcg4csy07zy3wjbm4fbk4lqiy82rdlxp1vad25vi"))))
+ (base32 "1bqk0z6zd3aza7ibb8h0ghya5kid4m6z01gs7jf4sr6p49rzp7hd"))))
(build-system emacs-build-system)
(propagated-inputs `(("emacs-helm" ,emacs-helm)))
(home-page "https://github.com/emacs-helm/helm-ls-git")
@@ -21668,23 +21688,20 @@ docstring of the thing at point.")
(define-public emacs-rust-mode
(package
(name "emacs-rust-mode")
- (version "0.5.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/rust-lang/rust-mode")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1f3nnl0d7p9b5cv1bpm0hj898qmr2psxfvmqr61bh684z7fgc045"))))
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rust-lang/rust-mode")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "08gz7wq1las3bqqs8qhmhmncax4j6kjnyxpfzslby3b1dkclc7ig"))))
(build-system emacs-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (invoke "sh" "run_rust_emacs_tests.sh"))))))
+ `(#:tests? #false ;FIXME: phase fail with status 127
+ #:test-command '("make test")))
(home-page "https://github.com/rust-lang/rust-mode")
(synopsis "Major Emacs mode for editing Rust source code")
(description "This package provides a major Emacs mode for editing Rust
@@ -23797,7 +23814,7 @@ processes for Emacs")
(define-public emacs-treemacs
(package
(name "emacs-treemacs")
- (version "2.9.2")
+ (version "2.9.3")
(source
(origin
(method git-fetch)
@@ -23806,7 +23823,7 @@ processes for Emacs")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "14f40q3zi79j9ss2m5i0s1kv16b3a9kqy2hn5vk4ig9w9dkg8jk5"))))
+ (base32 "0ik7wkv6w5vga29pmj8zzn3lq9a2ww26gkl380hmaak809in6k65"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-ace-window" ,emacs-ace-window)
@@ -24186,7 +24203,7 @@ commands (a prefix and a suffix) we prefer to call it just a \"transient\".")
(define-public emacs-forge
(package
(name "emacs-forge")
- (version "0.2.1")
+ (version "0.3.0")
(source
(origin
(method git-fetch)
@@ -24195,8 +24212,7 @@ commands (a prefix and a suffix) we prefer to call it just a \"transient\".")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32
- "0j28vc0q1h36pk0y2nidnlsc2y7n0vpfrd8civiv1zp8z0jwfyc9"))))
+ (base32 "15zm5azgl8gyd91i40a00ih4s2iwg1r8007n2gcfnmi6m4b7s0ak"))))
(build-system emacs-build-system)
(native-inputs
`(("texinfo" ,texinfo)))
@@ -24208,7 +24224,8 @@ commands (a prefix and a suffix) we prefer to call it just a \"transient\".")
("emacs-let-alist" ,emacs-let-alist)
("emacs-magit" ,emacs-magit)
("emacs-markdown-mode" ,emacs-markdown-mode)
- ("emacs-transient" ,emacs-transient)))
+ ("emacs-transient" ,emacs-transient)
+ ("emacs-yaml" ,emacs-yaml)))
(arguments
`(#:tests? #f ;no tests
#:phases
@@ -27407,7 +27424,7 @@ data, including buffers, window configuration, variables, and more.")
(define-public emacs-parseedn
(package
(name "emacs-parseedn")
- (version "1.0.4")
+ (version "1.0.6")
(source
(origin
(method git-fetch)
@@ -27416,7 +27433,7 @@ data, including buffers, window configuration, variables, and more.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1cz2bgaddlrcqzra8q50yh90rdl0kpyf5js2vxccdsq6ngr8bnmv"))))
+ (base32 "1xp2d42yvqkimb7a15bv89bj0124lljw9cb36g49m13d7ny4fafn"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-a" ,emacs-a)
@@ -27431,7 +27448,7 @@ It uses parseclj's shift-reduce parser internally.")
(define-public emacs-parseclj
(package
(name "emacs-parseclj")
- (version "1.0.4")
+ (version "1.0.6")
(source
(origin
(method git-fetch)
@@ -27440,7 +27457,7 @@ It uses parseclj's shift-reduce parser internally.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "15aar5fsci2y8hy045ypdrig4z4kqrd8318im3yzyyf40y1xrz1d"))))
+ (base32 "0n0m3xc2dawgdhb68zznpsbzbbvf9fwgf9v8pzzwa2jncgi1yhh0"))))
(build-system emacs-build-system)
(propagated-inputs `(("emacs-a" ,emacs-a)))
(home-page "https://cider.mx")
@@ -27632,29 +27649,26 @@ Wordnet.")
(license license:gpl3+))))
(define-public emacs-helm-xref
- (let ((commit "23f1174cfca7667d95828dcd388c655a4a9c877d")
- (revision "1"))
- (package
- (name "emacs-helm-xref")
- (version (git-version "0.5" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/brotzeit/helm-xref")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0v0lkabpi1n4hgnp28jk19f7b78yk93ssm0gr0fr25yqx5zskdnk"))))
- (build-system emacs-build-system)
- (propagated-inputs
- `(("emacs-helm" ,emacs-helm)))
- (home-page "https://github.com/brotzeit/helm-xref")
- (synopsis "Helm interface for @code{xref}")
- (description "This package provides a Helm interface for selecting
+ (package
+ (name "emacs-helm-xref")
+ (version "1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/brotzeit/helm-xref")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0v0wm1x11r1h9p139c5rl0r4s5q6092bmwrsnr2140ddbq34mnvy"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-helm" ,emacs-helm)))
+ (home-page "https://github.com/brotzeit/helm-xref")
+ (synopsis "Helm interface for @code{xref}")
+ (description "This package provides a Helm interface for selecting
@code{xref} results.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-metal-mercury-mode
(let ((commit "99e2d8fb7177cae3bfa2dec2910fc28216d5f5a8")
@@ -28357,6 +28371,13 @@ snippets for Emacs.")
(rename-file f (basename f)))
el-files))
#t))
+ (add-after 'move-source-files 'patch-exec-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (make-file-writable "org-roam-graph.el")
+ (emacs-substitute-variables "org-roam-graph.el"
+ ("org-roam-graph-executable"
+ (string-append (assoc-ref inputs "graphviz")
+ "/bin/dot")))))
(add-after 'install 'install-image
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
@@ -28369,6 +28390,8 @@ snippets for Emacs.")
(invoke "makeinfo" "-o" "org-roam.info" "org-roam.texi")
(install-file "org-roam.info"
(string-append out "/share/info")))))))))
+ (inputs
+ `(("graphviz" ,graphviz)))
(native-inputs
`(("texinfo" ,texinfo)))
(propagated-inputs
@@ -28708,7 +28731,7 @@ and Emacs lisp commands.")
(define-public emacs-extmap
(package
(name "emacs-extmap")
- (version "1.1.1")
+ (version "1.2")
(source
(origin
(method git-fetch)
@@ -28717,8 +28740,7 @@ and Emacs lisp commands.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32
- "09kia3mr4si8kn46kyiza9nl669b22vmgc70ng3mqz742lph5siw"))))
+ (base32 "0dl630jl46jz5slpv28l8b745051ghp0g296x5180vl5v88v3hsl"))))
(build-system emacs-build-system)
(home-page "https://github.com/doublep/extmap")
(synopsis "Externally-stored constant mapping for Emacs Lisp")