summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm107
1 files changed, 101 insertions, 6 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 64335d89f7..4e465ddb7d 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -819,7 +819,7 @@ required for Fritzing app.")
(native-inputs
(list pkg-config qttools-5))
(inputs
- (list kcoreaddons kwidgetsaddons qtbase-5 qtsvg-5 sqlite))
+ (list kcoreaddons-5 kwidgetsaddons-5 qtbase-5 qtsvg-5 sqlite))
(home-page "https://qelectrotech.org/")
(synopsis "CAD/CAE editor focusing on schematics drawing features")
(description "QElectroTech, or QET in short, is a desktop application to
@@ -1670,7 +1670,7 @@ fully-vectorial and three-dimensional methods.")
(define-public meep
(package
(name "meep")
- (version "1.28.0")
+ (version "1.29.0")
(source (origin
(method url-fetch)
(uri
@@ -1679,7 +1679,7 @@ fully-vectorial and three-dimensional methods.")
version "/meep-" version ".tar.gz"))
(sha256
(base32
- "199a29mb64cfv89azzdh8arpy9ib6050cqh86yw5ypm5jhy6178v"))))
+ "1511849g6wlpa42kfrj6zvmc3ivad9ync8r01xp2ld7r5j39y9v8"))))
(build-system gnu-build-system)
(arguments
(list #:configure-flags
@@ -1787,6 +1787,7 @@ analyzer (FFT) and frequency sweep plot.")
(version "5.0.1")
(source (origin
(method git-fetch)
+ (patches (search-patches "capstone-fix-python-constants.patch"))
(uri (git-reference
(url "https://github.com/capstone-engine/capstone")
(commit version)))
@@ -1798,7 +1799,7 @@ analyzer (FFT) and frequency sweep plot.")
(arguments
`(#:tests? #f
#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
- "CC=gcc")
+ (string-append "CC=" ,(cc-for-target)))
#:phases
(modify-phases %standard-phases
(delete 'configure) ; no configure script
@@ -2626,10 +2627,69 @@ specification can be downloaded at @url{http://3mf.io/specification/}.")
measurement devices and test equipment via GPIB, RS232, Ethernet or USB.")
(license license:expat)))
+(define-public python-pandapower
+ (package
+ (name "python-pandapower")
+ (version "2.14.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pandapower" version ".zip"))
+ (sha256
+ (base32 "0c5vgiq795kd5q4wcy2x7s3l7x9xdj2nqyfx188dmhgqckrym161"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-pyproj python-pytest unzip))
+ (propagated-inputs (list python-deepdiff
+ python-geojson
+ python-networkx
+ python-numpy
+ python-packaging
+ python-pandas
+ python-scipy
+ python-tqdm
+ python-typing-extensions))
+ (home-page "https://www.pandapower.org/")
+ (synopsis "Power system modelling and analysis")
+ (description "@code{pandapower} is an easy to use network calculation
+program aimed to automate the analysis and optimization of power systems.
+It uses the data analysis library @code{pandas} and is compatible with the
+commonly used @code{MATPOWER} / @code{PYPOWER} case format. @code{pandapower}
+allows using different solvers including an improved Newton-Raphson power flow
+implementation, all @code{PYPOWER} solvers, the C++ library solvers for fast
+steady-state distribution power system analysis of @code{PowerGridModel}, the
+Newton-Raphson power flow solvers in the C++ library lightsim2grid, and the
+@code{PowerModels.jl} library.")
+ (license license:bsd-3)))
+
+(define-public python-pandapipes
+ (package
+ (name "python-pandapipes")
+ (version "0.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pandapipes" version ".zip"))
+ (sha256
+ (base32 "06yqqd25hxa6q49qcbpy0njwxkqzfhbff4frrrxd84391njgvdhq"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-nbmake
+ python-pytest
+ python-pytest-xdist
+ unzip))
+ (propagated-inputs (list python-matplotlib
+ python-pandapower
+ python-shapely))
+ (home-page "http://www.pandapipes.org")
+ (synopsis "Simulation of multi energy grids")
+ (description
+ "This package provides a pipeflow calculation tool that complements
+@code{pandapower} in the simulation of multi energy grids.")
+ (license license:bsd-3)))
+
(define-public python-scikit-rf
(package
(name "python-scikit-rf")
- (version "1.0.0")
+ (version "1.1.0")
(source (origin
(method git-fetch) ;PyPI misses some files required for tests
(uri (git-reference
@@ -2637,7 +2697,7 @@ measurement devices and test equipment via GPIB, RS232, Ethernet or USB.")
(commit (string-append "v" version))))
(sha256
(base32
- "0qfijh2r93jn3za2h9wdv2y49gd4alcww35zrdvmxrx6kbv67m2f"))
+ "0ji1c8b9cbgb0w18dx976hza690npkypz8kav4a3yin2wysjvf64"))
(file-name (git-file-name name version))))
(build-system pyproject-build-system)
(propagated-inputs (list python-matplotlib
@@ -2663,6 +2723,41 @@ measurement devices and test equipment via GPIB, RS232, Ethernet or USB.")
Microwave engineering.")
(license license:bsd-3)))
+(define-public python-lcapy
+ (package
+ (name "python-lcapy")
+ (version "1.23")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "lcapy" version))
+ (sha256
+ (base32 "13swd2nd2s20hixy4as924sr223flcvcy9zw3qlzsrcvhppzb84n"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; This test fails by FileNotFoundError (a schematic file), possibly
+ ;; because it's not included in PyPI.
+ #:test-flags #~(list "-k" "not test_circuitgraph")))
+ (propagated-inputs (list python-ipython
+ python-matplotlib
+ python-networkx
+ python-numpy
+ python-property-cached
+ python-scipy
+ python-sympy
+ python-wheel))
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/mph-/lcapy")
+ (synopsis "Symbolic linear circuit analysis")
+ (description "Lcapy is a Python package for linear circuit analysis. It
+uses SymPy for symbolic mathematics.
+
+Lcapy can symbolically analyse circuits described with netlists or by
+series/parallel combinations of components. It can also manipulate
+ontinuous-time and discret-time expressions.")
+ (license license:lgpl2.1+)))
+
(define-public openscad
(package
(name "openscad")