summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm80
1 files changed, 68 insertions, 12 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index ed87cd8d6a..f195179413 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -67,6 +67,7 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system emacs)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system meson)
#:use-module (guix build-system python)
#:use-module (guix build-system qt)
#:use-module (gnu packages)
@@ -88,6 +89,7 @@
#:use-module (gnu packages digest)
#:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages file)
#:use-module (gnu packages flex)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages fpga)
@@ -142,6 +144,7 @@
#:use-module (gnu packages tbb)
#:use-module (gnu packages tcl)
#:use-module (gnu packages texinfo)
+ #:use-module (gnu packages text-editors)
#:use-module (gnu packages tls)
#:use-module (gnu packages tex)
#:use-module (gnu packages version-control)
@@ -2438,7 +2441,7 @@ comments.")))
(define-public freecad
(package
(name "freecad")
- (version "0.20")
+ (version "0.20.1")
(source
(origin
(method git-fetch)
@@ -2447,7 +2450,7 @@ comments.")))
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "14bn75bjh93f8k3hinqw913z1q0ywq7niklwbbd99hf5n342hsv4"))))
+ (base32 "1pgkjlahisqjvi3dd7ywj1zwhsl3wn3p15sifbmrdfdmw9is3z2b"))))
(build-system qt-build-system)
(native-inputs
(list doxygen
@@ -2524,12 +2527,11 @@ comments.")))
(home-page "https://www.freecadweb.org/")
(synopsis "Your Own 3D Parametric Modeler")
(description
- "FreeCAD is a general purpose feature-based, parametric 3D modeler for
-CAD, MCAD, CAx, CAE and PLM, aimed directly at mechanical engineering and
-product design but also fits a wider range of uses in engineering, such as
-architecture or other engineering specialties. It is 100% Open Source (LGPL2+
-license) and extremely modular, allowing for very advanced extension and
-customization.")
+ "FreeCAD is a general-purpose, feature-based, parametric 3D modeler for
+CAD, MCAD, CAx, CAE, and PLM. It is aimed directly at mechanical engineering
+and product design but also fits a wider range of uses in engineering, such as
+architecture or other engineering specialties. It is modular, allowing for
+extension and customization.")
(license
(list
license:lgpl2.1+
@@ -3352,10 +3354,10 @@ facilitate the communication between Cura and its backend and similar code.")
"stb_image.h")))))))
(home-page "https://github.com/Ultimaker/CuraEngine")
(synopsis "Cura slicing engine")
- (description "CuraEngine is a powerful, fast and robust engine for
-processing 3D models into 3D printing instruction for Ultimaker and other
-GCode based 3D printers. It is part of the larger open source project called
-Cura.")
+ (description
+ "CuraEngine is an engine for processing 3D models into 3D printing
+instructions for Ultimaker and other GCode-based 3D printers. It is part of a
+larger project called Cura.")
(license license:agpl3+)))
(define-public cura-binary-data
@@ -3757,3 +3759,57 @@ form, numpad.
@item Visualizing G-code files.
@end itemize")
(license license:gpl3+))))
+
+(define-public rizin
+ (package
+ (name "rizin")
+ (version "0.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/rizinorg/rizin/releases/download/v"
+ version "/rizin-src-v" version ".tar.xz"))
+ (sha256
+ (base32
+ "0nkb6v9lks25w5sv5s6p2ghgqnnnsf39md8nlx1cy4z89xlaisq9"))))
+ (build-system meson-build-system)
+ (arguments
+ (list
+ #:configure-flags
+ #~(list "-Dpackager=guix"
+ (string-append "-Dpackager_version=" #$version)
+ "-Duse_sys_capstone=enabled"
+ "-Duse_sys_magic=enabled"
+ "-Duse_sys_libzip=enabled"
+ "-Duse_sys_zlib=enabled"
+ "-Duse_sys_lz4=enabled"
+ "-Duse_sys_xxhash=enabled"
+ "-Duse_sys_openssl=enabled"
+ "-Duse_sys_tree_sitter=enabled"
+ "-Duse_sys_libuv=enabled"
+ "-Duse_gpl=true")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'skip-integration-tests
+ (lambda _
+ ;; Skip integration tests, which require prebuilt binaries at:
+ ;; <https://github.com/rizinorg/rizin-testbins>.
+ ;; And 2 of them are failing, reported upstream:
+ ;; <https://github.com/rizinorg/rizin/issues/2905>.
+ (substitute* "test/meson.build"
+ (("subdir\\('integration'\\)") "")))))))
+ (native-inputs (list pkg-config))
+ (inputs
+ (list capstone file libuv libzip lz4 openssl tree-sitter xxhash zlib))
+ (home-page "https://rizin.re")
+ (synopsis "Disasm, debug, analyze and manipulate binary files")
+ (description
+ "Rizin is a reverse engineering framework and a set of small command-line
+utilities, providing a complete binary analysis experience with features like
+disassembler, hexadecimal editor, emulation, binary inspection, debugger, and
+more.")
+ ;; Most files are under LGPL-3.0-only, other are under: Apache-2.0,
+ ;; BSD-2-Clause, BSD-3-Clause, CC0-1.0, CC-BY-SA-4.0, GPL-1.0-or-later,
+ ;; GPL-2.0-only, GPL-2.0-or-later, GPL-3.0-or-later, LGPL-2.0-or-later,
+ ;; LGPL-2.1-only, LGPL-2.1-or-later, LGPL-3.0-only, MIT, NCSA.
+ (license license:gpl3+)))