summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm80
1 files changed, 38 insertions, 42 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 767de69823..4cc570cfb4 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -9,9 +9,9 @@
;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2018 Adriano Peluso <catonano@gmail.com>
-;;; Copyright © 2018-2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2018-2022, 2024 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
-;;; Copyright © 2019-2023 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2019-2024 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2019, 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2019 Sebastian Schott <sschott@mailbox.org>
@@ -296,14 +296,14 @@ Accounting.")
(define-public homebank
(package
(name "homebank")
- (version "5.7.4")
+ (version "5.8.1")
(source (origin
(method url-fetch)
(uri (string-append "https://www.gethomebank.org/public/sources"
"/homebank-" version ".tar.gz"))
(sha256
(base32
- "1r2lpf2qjvyc9l4llgy6453dn527pylvd49kr6ihrskmr1373kj2"))))
+ "00fwadn6q2hryx7q1xf5fhb5q3ywfnlb1r4xxn7yq6ilzvm5zhv0"))))
(build-system glib-or-gtk-build-system)
(native-inputs
(list pkg-config intltool))
@@ -1690,9 +1690,8 @@ trezord as a regular user instead of needing to it run as root.")
(file-name (git-file-name name version))))
(build-system go-build-system)
(arguments
- `(#:import-path "github.com/trezor/trezord-go"
- ;; Requires go 1.18 or later: https://github.com/trezor/trezord-go/commit/f559ee5079679aeb5f897c65318d3310f78223ca
- #:go ,go-1.20))
+ `(#:go ,go-1.18
+ #:import-path "github.com/trezor/trezord-go"))
(native-inputs
(list go-github-com-gorilla-csrf
go-github-com-gorilla-handlers
@@ -2078,29 +2077,25 @@ software Beancount with a focus on features and usability.")
(license license:expat)))
(define-public emacs-beancount
- ;; Note that upstream has not made any release since this project moved
- ;; into its own repository (it was originally part of beancount itself)
- (let ((commit "687775da63784d153a3c1cfee9801090c6b51842")
- (revision "1"))
- (package
- (name "emacs-beancount")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/beancount/beancount-mode")
- (commit commit)))
- (sha256
- (base32
- "08383yqqanx29al1hg1r6ndx3gwjg6fj7kl340f1zz9m9cfiyvg3"))
- (file-name (git-file-name name version))))
- (build-system emacs-build-system)
- (home-page "https://github.com/beancount/beancount-mode")
- (synopsis "Emacs mode for Beancount")
- (description
- "Emacs-beancount is an Emacs mode for the Beancount accounting tool.")
- (license license:gpl3+))))
+ (package
+ (name "emacs-beancount")
+ (version "0.9.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/beancount/beancount-mode")
+ (commit version)))
+ (sha256
+ (base32
+ "01ivxgv1g0pkr0xi43366pghc3j3mmhk5bshis6kkn04bq04cx7f"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/beancount/beancount-mode")
+ (synopsis "Emacs mode for Beancount")
+ (description
+ "Emacs-beancount is an Emacs mode for the Beancount accounting tool.")
+ (license license:gpl3+)))
(define-public hledger-web
(package
@@ -2175,15 +2170,15 @@ editing on the Web.")
(define-public quantlib
(package
(name "quantlib")
- (version "1.26")
+ (version "1.34")
(source
(origin
(method url-fetch)
(uri (string-append
- "https://github.com/lballabio/QuantLib/releases/download/QuantLib-v"
+ "https://github.com/lballabio/QuantLib/releases/download/v"
version "/QuantLib-" version ".tar.gz"))
(sha256
- (base32 "1sbk6rg51x5xpa93xmqmrj32a1l9vba51xck0017cxzblg0nrzh4"))))
+ (base32 "0l7yn9bal0csyix0ydzcfj003kma4sx7w5hyfxhh6mbnxn6am1zb"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -2228,13 +2223,13 @@ interactive controls. This package provides a GTK+ graphical user interface
(define-public python-ta-lib
(package
(name "python-ta-lib")
- (version "0.4.21")
+ (version "0.4.32")
(source
(origin
(method url-fetch)
(uri (pypi-uri "TA-Lib" version))
(sha256
- (base32 "17sf222mq2vx924f15qlz5czkkq5vsnsjy9ibwkrk8lalr6g5lkl"))))
+ (base32 "186sgkpggy50gs2pa2p22zppl57xgfhpmja5l13xiskv44iw6x7v"))))
(build-system python-build-system)
(inputs
(list ta-lib))
@@ -2322,7 +2317,7 @@ and manipulation.")
(define-public xmrig
(package
(name "xmrig")
- (version "6.21.2")
+ (version "6.21.3")
(source
(origin
(method git-fetch)
@@ -2330,7 +2325,7 @@ and manipulation.")
(url "https://github.com/xmrig/xmrig")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
- (sha256 (base32 "0rxnrn92v2w9f0zyv4zchilnrc3wa8nw4d4b4isaxx411zxgds6i"))
+ (sha256 (base32 "0nykvw45s9c5rpf01mmvam4na7ka5jryyrxnbml89raqkp22nlnn"))
(modules '((guix build utils)))
(snippet
;; TODO: Try to use system libraries instead of bundled ones in
@@ -2379,7 +2374,7 @@ mining.")
(define-public p2pool
(package
(name "p2pool")
- (version "3.10")
+ (version "4.0")
(source
(origin
(method git-fetch)
@@ -2388,7 +2383,7 @@ mining.")
(commit (string-append "v" version))
(recursive? #t)))
(file-name (git-file-name name version))
- (sha256 (base32 "0lp9slfwaq3wp4x6xpsiazam5lv6dz57m20adzlzzk0anb1ascr0"))
+ (sha256 (base32 "0x6s7fm5gn0q2274b2nja8hj84cvmxp4rr9x4xw050sxj74880jh"))
(modules '((guix build utils)))
(snippet
#~(for-each delete-file-recursively
@@ -2397,10 +2392,11 @@ mining.")
"external/src/curl"
"external/src/libuv"
"external/src/libzmq"
- "external/src/rapidjson")))))
+ "external/src/rapidjson"
+ "external/src/robin-hood-hashing")))))
(build-system cmake-build-system)
(inputs
- (list cppzmq curl gss libuv rapidjson zeromq))
+ (list cppzmq curl gss libuv rapidjson robin-hood-hashing zeromq))
(arguments
(list ; FIXME: Linking fails when LTO is activated.
#:configure-flags #~(list "-DWITH_LTO=OFF")
@@ -2411,7 +2407,7 @@ mining.")
(when tests?
(mkdir-p "tests")
(chdir "tests")
- (invoke "cmake" "../../source/tests")
+ (invoke "cmake" "-DWITH_LTO=OFF" "../../source/tests")
(invoke "make" "-j" (number->string (parallel-job-count)))
(invoke "gzip" "-d" "sidechain_dump.dat.gz")
(invoke "gzip" "-d" "sidechain_dump_mini.dat.gz")