summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 4f3415232c..eadaa46102 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2016, 2023 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016-2018, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2016, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2017 Carlo Zancanaro <carlo@zancanaro.id.au>
@@ -93,6 +93,7 @@
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages golang)
+ #:use-module (gnu packages golang-web)
#:use-module (gnu packages graphviz)
#:use-module (gnu packages groff)
#:use-module (gnu packages gsasl)
@@ -142,7 +143,7 @@
;; <https://bitcoincore.org/en/lifecycle/#schedule>.
(package
(name "bitcoin-core")
- (version "25.1")
+ (version "26.0")
(source (origin
(method url-fetch)
(uri
@@ -150,7 +151,7 @@
version "/bitcoin-" version ".tar.gz"))
(sha256
(base32
- "1jcq2686x6f1g8xk91h3qfw89v1klw931wbpbcvc5a6zv2cabhmy"))))
+ "18f0rl7nzr64m54d6hmrphg7z39mmj2ix47kv78n5nr8dqkrj7db"))))
(build-system gnu-build-system)
(native-inputs
(list autoconf
@@ -952,7 +953,9 @@ Bech32 and segwit addresses.")
(when tests?
(invoke "pytest" "-v")))))))
(propagated-inputs
- (list python-configargparse
+ (list python-bech32
+ python-configargparse
+ python-cryptography
python-daemon
python-docutils
python-ecdsa
@@ -965,8 +968,6 @@ Bech32 and segwit addresses.")
python-wheel))
(native-inputs ; Only needed for running the tests
(list gnupg
- python-bech32
- python-cryptography
python-mock
python-pytest))
(home-page "https://github.com/romanz/trezor-agent")
@@ -1957,13 +1958,13 @@ that allows you to run services and through them access the Bitcoin Cash network
(define-public beancount
(package
(name "beancount")
- (version "2.3.5")
+ (version "2.3.6")
(source
(origin
(method url-fetch)
(uri (pypi-uri "beancount" version))
(sha256
- (base32 "0sn3x6c5vwvdfak1qm0y4vv284izrc4dly31mqyd9jz9l8jmdqql"))
+ (base32 "0nj7sdh7wxc0hv8wxwqhw9v1zgx1sn4w92368ci2wzdmssz967w0"))
(patches (search-patches "beancount-disable-googleapis-fonts.patch"))))
(build-system python-build-system)
(arguments
@@ -2299,7 +2300,7 @@ mining.")
(define-public p2pool
(package
(name "p2pool")
- (version "3.7")
+ (version "3.10")
(source
(origin
(method git-fetch)
@@ -2308,7 +2309,7 @@ mining.")
(commit (string-append "v" version))
(recursive? #t)))
(file-name (git-file-name name version))
- (sha256 (base32 "1sghdk8yq8si0bq0z83fji48q8yrq0ymvsxbbh5mscw6223syrjq"))
+ (sha256 (base32 "0lp9slfwaq3wp4x6xpsiazam5lv6dz57m20adzlzzk0anb1ascr0"))
(modules '((guix build utils)))
(snippet
#~(for-each delete-file-recursively