summaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm196
1 files changed, 157 insertions, 39 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 3554c9a541..6d1fc14f37 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2016 Jookia <166291@gmail.com>
;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016 Dmitry Nikolaev <cameltheman@gmail.com>
-;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016-2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2016 Toni Reina <areina@riseup.net>
;;; Copyright © 2017–2022 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -35,7 +35,7 @@
;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
;;; Copyright © 2020, 2021 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
-;;; Copyright © 2020, 2021 Simen Endsjø <simendsjo@gmail.com>
+;;; Copyright © 2020, 2021, 2022 Simen Endsjø <simendsjo@gmail.com>
;;; Copyright © 2020 Tim Van den Langenbergh <tmt_vdl@gmx.com>
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
;;; Copyright © 2021 Antoine Côté <antoine.cote@posteo.net>
@@ -85,6 +85,7 @@
#:use-module (gnu packages bash)
#:use-module (gnu packages compression)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages gd)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
@@ -118,14 +119,18 @@ titling.")
(package
(name "font-ibm-plex")
(version "6.1.1")
+ ;; We prefer git-fetch since it lets us get the opentype, truetype and web
+ ;; fonts all in one download. The zip archive releases separate the
+ ;; opentype, truetype and web fonts into three separate archives.
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/IBM/plex/releases/download/"
- "v" version "/OpenType.zip"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/IBM/plex")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1z9nxac9ha6gqz5yvfy5lp6hyl39f8f8hdrw3llcp89rdpjfqdn9"))))
+ "1jxyd0zl7jssn7mwz8x5xvjmw59x4mn82s2kywf9583k1pg949k1"))))
(build-system font-build-system)
(home-page "https://github.com/IBM/plex")
(synopsis "IBM Plex typeface")
@@ -843,7 +848,7 @@ for use at smaller text sizes")))
(define-public font-gnu-unifont
(package
(name "font-gnu-unifont")
- (version "14.0.04")
+ (version "15.0.01")
(source
(origin
(method url-fetch)
@@ -853,31 +858,45 @@ for use at smaller text sizes")))
(string-append "mirror://gnu/unifont/unifont-"
version "/unifont-" version ".tar.gz")))
(sha256
- (base32 "1fzycjxmgnq77r2s5914w1phg3qdwwnwa6p3zyfa1cscrxy52phz"))))
+ (base32 "1m9lfss6sbmcr0b6h7pxxmdl71j9dmnvk8idvxzylqrwpwjaj4bx"))
+ (snippet
+ '(begin
+ (use-modules (guix build utils))
+ (delete-file-recursively "font/precompiled")))))
(build-system gnu-build-system)
- (outputs '("out" ; TrueType version
+ (outputs '("out" ; TrueType/OpenType version
"pcf" ; PCF (bitmap) version
"psf" ; PSF (console) version
"bin")) ; Utilities to manipulate '.hex' format
(arguments
`(#:tests? #f ; no check target
#:make-flags
- (list (string-append "CC=" ,(cc-for-target)))
+ (list (string-append "CC=" ,(cc-for-target))
+ "BUILDFONT=TRUE")
#:phases
(modify-phases %standard-phases
(delete 'configure)
+ (add-after 'unpack 'patch-source
+ (lambda _
+ (substitute* (find-files "." "Makefile")
+ (("/bin/sh -s") (string-append (which "sh") " -s")))))
(replace 'install
(lambda* (#:key make-flags outputs #:allow-other-keys)
(let* ((ttf (string-append (assoc-ref outputs "out")
"/share/fonts/truetype"))
+ (otf (string-append (assoc-ref outputs "out")
+ "/share/fonts/opentype"))
(pcf (string-append (assoc-ref outputs "pcf")
"/share/fonts/misc"))
(psf (string-append (assoc-ref outputs "psf")
"/share/consolefonts"))
(bin (assoc-ref outputs "bin")))
+ ;; This directory isn't created in fonts/Makefile.
+ (mkdir-p otf)
(apply invoke "make" "install"
(string-append "PREFIX=" bin)
(string-append "TTFDEST=" ttf)
+ (string-append "OTFDEST=" otf)
(string-append "PCFDEST=" pcf)
(string-append "CONSOLEDEST=" psf)
make-flags)
@@ -886,8 +905,10 @@ for use at smaller text sizes")))
(invoke "gzip" "-9n" "doc/unifont.info")
(install-file "doc/unifont.info.gz"
(string-append bin "/share/info"))))))))
+ (native-inputs
+ (list bdftopcf console-setup fontforge))
(inputs
- (list perl)) ; for utilities
+ (list perl perl-gd)) ; for utilities
(synopsis
"Large bitmap font covering Unicode's Basic Multilingual Plane")
(description
@@ -918,6 +939,81 @@ all languages with a consistent look and aesthetic. Its goal is to properly
display all Unicode symbols.")
(license license:silofl1.1)))
+(define-public font-google-noto-emoji
+ (package
+ (name "font-google-noto-emoji")
+ (version "2.038")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/googlefonts/noto-emoji")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1rgmcc6nqq805iqr8kvxxlk5cf50q714xaxk3ld6rjrd69kb8ix9"))))
+ (build-system font-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-unsupported
+ (lambda* _
+ (delete-file "fonts/NotoColorEmoji_WindowsCompatible.ttf")
+ (delete-file "fonts/Noto-COLRv1-noflags.ttf")
+ (delete-file "fonts/Noto-COLRv1.ttf"))))))
+ (home-page "https://fonts.google.com/noto/specimen/Noto+Color+Emoji")
+ (synopsis "Font for rendering color emoji characters")
+ (description
+ "This package provides the color emoji font from the Google Noto font
+family.")
+ (license license:silofl1.1)))
+
+(define-public font-google-noto-sans-cjk
+ (package
+ (name "font-google-noto-sans-cjk")
+ (version "2.004")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/googlefonts/noto-cjk/releases/download/Sans"
+ version "/03_NotoSansCJK-OTC.zip"))
+ (file-name (string-append name "-" version ".zip"))
+ (sha256
+ (base32 "1v9yda7r98g4a3pk0y3cjbgc1i2lv4ax0f0v6aqasfzz4ldlx3sj"))))
+ (build-system font-build-system)
+ (home-page "https://www.google.com/get/noto/")
+ (synopsis "Fonts to cover all languages")
+ (description "Google Noto Fonts is a family of fonts designed to support
+all languages with a consistent look and aesthetic. Its goal is to properly
+display all Unicode symbols. This package provides the Sans Serif variant of
+CJK fonts.")
+ (license license:silofl1.1)))
+
+(define-public font-google-noto-serif-cjk
+ (package
+ (name "font-google-noto-serif-cjk")
+ (version "2.001")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/googlefonts/noto-cjk/releases/download/Serif"
+ version "/04_NotoSerifCJKOTC.zip"))
+ (file-name (string-append name "-" version ".zip"))
+ (sha256
+ (base32 "1l6r3sz2s0vcyfx6ria7wqcq45zp40gxgg97lh8hpmajhzw301ig"))))
+ (build-system font-build-system)
+ (home-page "https://www.google.com/get/noto/")
+ (synopsis "Fonts to cover all languages")
+ (description "Google Noto Fonts is a family of fonts designed to support
+all languages with a consistent look and aesthetic. Its goal is to properly
+display all Unicode symbols. This package provides the Serif variant of CJK
+fonts.")
+ (license license:silofl1.1)))
+
(define-public font-google-roboto
(package
(name "font-google-roboto")
@@ -1433,7 +1529,7 @@ guix repl <<EOF
(ice-9 string-fun)
(gnu packages fonts))
-(let ((new-version "15.2.0")
+(let ((new-version "16.4.0")
(iosevka-hashes #nil)
(iosevka-fails #nil))
(for-each (lambda (font)
@@ -1467,7 +1563,7 @@ EOF
(define-public font-iosevka
(package
(name "font-iosevka")
- (version "15.2.0")
+ (version "16.4.0")
(source
(origin
(method url-fetch/zipbomb)
@@ -1475,7 +1571,7 @@ EOF
"/releases/download/v" version
"/ttc-iosevka-" version ".zip"))
(sha256
- (base32 "0yyz8vmpi8pww0p9na564lvbkwhdhpk4bcyrli91dn5gq0pc1pvv"))))
+ (base32 "07v98pr0anqbxn1yc55245k5ixxzfk2wmfq67zhz84aa18viqhbc"))))
(build-system font-build-system)
(home-page "https://be5invis.github.io/Iosevka/")
(synopsis "Coders' typeface, built from code")
@@ -1498,7 +1594,7 @@ programming. Iosevka is completely generated from its source code.")
"/releases/download/v" version
"/ttc-iosevka-slab-" version ".zip"))
(sha256
- (base32 "1qy86kdl6lgq5k1qb97adibpfjm4vg1wdnxbqizhqka5bc7avyzb"))))))
+ (base32 "063qk1d75l1jq7gdwzqxd7j8j56g7da0aagsqm0lvwl217l7x48b"))))))
(define-public font-iosevka-term
(package
@@ -1512,7 +1608,7 @@ programming. Iosevka is completely generated from its source code.")
"/releases/download/v" version
"/ttf-iosevka-term-" version ".zip"))
(sha256
- (base32 "15znvvkhldgbl9k04pwrrnvmjnanw2fr92c0zspg7bbw7id2v510"))))
+ (base32 "17465bvg6fap53xfqwrg2g4fasv01w86wh658n1rf6djs3yzn1gx"))))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -1533,7 +1629,7 @@ programming. Iosevka is completely generated from its source code.")
"releases/download/v" version "/"
"ttf-iosevka-term-slab-" version ".zip"))
(sha256
- (base32 "1rla7kcb94c7daklp4av27gix86cmwsrqg6884zmv5zfnhz0r700"))))
+ (base32 "00pc4d8awdiziyzncah3fnh0ppvcdvi9cd7vyknl68f6fj283fvm"))))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -1554,7 +1650,7 @@ programming. Iosevka is completely generated from its source code.")
"/releases/download/v" version
"/ttc-iosevka-aile-" version ".zip"))
(sha256
- (base32 "1lciycahvxgvmcniq4h3m1v3rc42nmv8ydb0fpbl9g4sc0qp81hq"))))))
+ (base32 "03y0xijb7c0kampm3gjb69mv8hikhsgqhlw1w3zfcjhr2vc62g6q"))))))
(define-public font-iosevka-curly
(package
@@ -1568,7 +1664,7 @@ programming. Iosevka is completely generated from its source code.")
"releases/download/v" version "/"
"ttc-iosevka-curly-" version ".zip"))
(sha256
- (base32 "02jvrj7kzd4bx3maj1bq2p9j746b8c5713d8lqkxx4fn9fm0zppq"))))))
+ (base32 "1i31zj0j8npgx7wn2qibih48s76qjxakz14sa2hgx908p8xyfwq5"))))))
(define-public font-iosevka-curly-slab
(package
@@ -1582,7 +1678,7 @@ programming. Iosevka is completely generated from its source code.")
"releases/download/v" version "/"
"ttc-iosevka-curly-slab-" version ".zip"))
(sha256
- (base32 "1bhvf95xs74wm8srsvl4yxwvl36llk93mpl1y9acc5z9rdcpzjqq"))))))
+ (base32 "1xijhk5vbgs3c89a7g9cfjqjqv801gimjja4wqpvaficab692jh2"))))))
(define-public font-iosevka-etoile
(package
@@ -1596,12 +1692,12 @@ programming. Iosevka is completely generated from its source code.")
"/releases/download/v" version
"/ttc-iosevka-etoile-" version ".zip"))
(sha256
- (base32 "1zmgfxfsbxv1k4fwnc7g2jlfhmlzp5kap8m3f10fqanpnkd0yf08"))))))
+ (base32 "1rqagk6gyja15fa4m107ylbjwbhn811gbl9lbr9yzashw4drjpp9"))))))
(define-public font-sarasa-gothic
(package
(name "font-sarasa-gothic")
- (version "0.36.8")
+ (version "0.39.0")
(source
(origin
(method url-fetch)
@@ -1609,7 +1705,7 @@ programming. Iosevka is completely generated from its source code.")
"/releases/download/v" version
"/sarasa-gothic-ttc-" version ".7z"))
(sha256
- (base32 "01fn5mzr1rcz0c8nbhabwbv1pq1c3ylf2msxldc9adks1pi45fmh"))))
+ (base32 "19a4a9zsfzkg7xak2sys6jiia7qw1j69206qzn8r2vchrib5lvcz"))))
(build-system font-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -1832,7 +1928,7 @@ ExtraLight, Light, Book, Medium, Semibold, Bold & ExtraBold")
#t))))))
(native-inputs
(list fontforge))
- (home-page "http://culmus.sourceforge.net/")
+ (home-page "https://culmus.sourceforge.io/")
(synopsis "TrueType Hebrew Fonts for X11")
(description "14 Hebrew trivial families. Contain ASCII glyphs from various
sources. Those families provide a basic set of a serif (Frank Ruehl), sans
@@ -2487,7 +2583,7 @@ and heavily inspired by Creep.")
(define-public font-montserrat
(package
(name "font-montserrat")
- (version "7.210")
+ (version "7.222")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2496,14 +2592,15 @@ and heavily inspired by Creep.")
(file-name (git-file-name name version))
(sha256
(base32
- "0jn1yvfamq5xazw85sfnxgriji60g7mkss9mkf8d0117vdk838bn"))))
+ "03cfk45r5g694dqp2gjgg0qwra8w78nl6hc6p56qwd5dcfgr2l3r"))))
(build-system font-build-system)
(home-page "https://github.com/JulietaUla/Montserrat")
(synopsis "The Montserrat font")
- (description "The old posters and signs in the traditional Montserrat
-neighborhood of Buenos Aires inspired Julieta Ulanovsky to design this
-typeface and rescue the beauty of urban typography that emerged in the first
-half of the twentieth century.")
+ (description
+ "The old posters and signs in the traditional Montserrat neighborhood of
+Buenos Aires inspired Julieta Ulanovsky to design this typeface and rescue the
+beauty of urban typography that emerged in the first half of the twentieth
+century.")
(license license:silofl1.1)))
(define-public font-overpass
@@ -2708,6 +2805,27 @@ This package contains the following outputs:
")
(license license:gpl2)))
+(define-public font-arphic-ukai
+ (package
+ (name "font-arphic-ukai")
+ (version "0.2.20080216.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://deb.debian.org/debian/pool/main"
+ "/f/fonts-arphic-ukai/fonts-arphic-ukai_"
+ version ".orig.tar.bz2"))
+ (sha256
+ (base32
+ "1lp3i9m6x5wrqjkh1a8vpyhmsrhvsa2znj2mx13qfkwza5rqv5ml"))))
+ (build-system font-build-system)
+ (home-page "https://www.freedesktop.org/wiki/Software/CJKUnifonts/")
+ (synopsis "Truetype fonts for Taiwanese and Hakka")
+ (description
+ "This package provides a set of Truetype fonts, which contain all
+characters necessary to display Taiwanese and Hakka.")
+ (license (license:fsdg-compatible
+ "https://www.freedesktop.org/wiki/Arphic_Public_License/"))))
+
(define-public font-atui-feather
(let ((version "0")
(commit "c51fe7cedbcf2cbf4f1b993cef5d8def612dec1d")
@@ -2736,7 +2854,7 @@ and readability. This package bundles those icons into a font.")
(define-public font-lxgw-wenkai
(package
(name "font-lxgw-wenkai")
- (version "1.245")
+ (version "1.250")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2744,7 +2862,7 @@ and readability. This package bundles those icons into a font.")
version "/lxgw-wenkai-v" version ".tar.gz"))
(sha256
(base32
- "01x5nfw0cy7v8vsjw32zayc0ryskiwj22yzqi28252896073mm9k"))))
+ "04c1cszxhs2zw3qn7rs3ik2aaczvf8n28gq9ch6iv782fv2p8irn"))))
(build-system font-build-system)
(home-page "https://lxgw.github.io/2021/01/28/Klee-Simpchin/")
(synopsis "Simplified Chinese Imitation Song typeface")
@@ -2758,7 +2876,7 @@ within GB 2312, standard glyphs for Mainland China is used.")
(package
(inherit font-lxgw-wenkai)
(name "font-lxgw-wenkai-tc")
- (version "0.922")
+ (version "0.931")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2766,7 +2884,7 @@ within GB 2312, standard glyphs for Mainland China is used.")
version "/lxgw-wenkai-tc-v" version ".tar.gz"))
(sha256
(base32
- "0kb12sfb8ihsj14yzk5ib657xvswqy0hy5gr1vfbn1n05vzy8wyk"))))
+ "1dba201p8ch09n5wcr5gx263rd2851v76m6f3xac5m3pd9f4i8fg"))))
(home-page "https://github.com/lxgw/LxgwWenKaitc")
(synopsis "Traditional Chinese Imitation Song typeface")
(description
@@ -2777,7 +2895,7 @@ dialects in Hong Kong and Taiwan.")))
(define-public font-chiron-sung-hk
(package
(name "font-chiron-sung-hk")
- (version "1.006")
+ (version "1.007")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2786,7 +2904,7 @@ dialects in Hong Kong and Taiwan.")))
(file-name (git-file-name name version))
(sha256
(base32
- "0cibyhy363yqmif31lwv4qmcaar5np2gdd3nbnxxp55mb4qn0kms"))))
+ "1mhw3vgahfc9kyb7sw5w5zswp93a4sz7q12f7qba069f834j5qjq"))))
(build-system font-build-system)
(home-page "https://chiron-fonts.github.io/")
(synopsis "Traditional Chinese Song typeface")
@@ -2801,7 +2919,7 @@ prevalent typefaces in Traditional Chinese regions.")
(package
(inherit font-chiron-sung-hk)
(name "font-chiron-hei-hk")
- (version "2.504")
+ (version "2.505")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2810,7 +2928,7 @@ prevalent typefaces in Traditional Chinese regions.")
(file-name (git-file-name name version))
(sha256
(base32
- "0d0k88sbhgr597sv2jzz2rcg8g4k60lcjka1xlnkv08n3bdgvmhr"))))
+ "1h2ps2kdv2s29pp9an4gpb84xwmkizqrgsk4hs5f0g0004897hi5"))))
(synopsis "Traditional Chinese Gothic typeface")
(description
"Chiron Hei HK is a Traditional Chinese Gothic typeface based on the Hong