summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm117
1 files changed, 78 insertions, 39 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 5e64a0bff7..818d9966dd 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -28,6 +28,7 @@
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -103,6 +104,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages qt)
#:use-module (gnu packages rdesktop)
#:use-module (gnu packages rsync)
#:use-module (gnu packages samba)
@@ -352,8 +354,7 @@ tests.")
(base32 "0vnf0pk516fwwh41v96c29l2i7h1pnwhivlkbf53kkx1q35g7lb3"))))
(build-system meson-build-system)
(arguments
- `(#:meson ,meson-0.59
- #:glib-or-gtk? #t
+ `(#:glib-or-gtk? #t
#:phases
(modify-phases %standard-phases
;; AppInfo not available inside build environment.
@@ -621,10 +622,6 @@ the freedesktop.org XDG Base Directory specification.")
;; existing in the build environment.
(invoke "sed" "/src\\/test\\/test-user-util.c/,+2s/^/#/g"
"-i" "src/test/meson.build")
- ;; FIXME: This one times out for unknown reasons.
- (invoke "sed"
- "/src\\/libelogind\\/sd-event\\/test-event.c/,+2s/^/#/g"
- "-i" "src/test/meson.build")
;; This test tries to copy some bytes from /usr/lib/os-release,
;; which does not exist in the build container. Choose something
;; more likely to be available.
@@ -1000,6 +997,7 @@ Python.")
("dot" ,graphviz)
("doxygen" ,doxygen)
("pkg-config" ,pkg-config)
+ ("python" ,python)
("xmlto" ,xmlto)
("xsltproc" ,libxslt)
,@(if (%current-target-system)
@@ -1036,7 +1034,7 @@ fullscreen) or other display servers.")
(inputs
(list wayland))
(native-inputs
- (list pkg-config))
+ (list pkg-config python))
(synopsis "Wayland protocols")
(description "Wayland-Protocols contains Wayland protocols that add
functionality not available in the Wayland core protocol. Such protocols either
@@ -1377,8 +1375,7 @@ message bus.")
(base32 "16wwd633jak9ajyr1f1h047rmd09fhf3kzjz6g5xjsz0lwcj8azz"))))
(build-system meson-build-system)
(arguments
- `(#:meson ,meson-0.59 ;see https://github.com/mesonbuild/meson/issues/6470
- #:tests? #f ; XXX: tests require DocBook 4.1.2
+ `(#:tests? #f ; XXX: tests require DocBook 4.1.2
#:configure-flags
'("--localstatedir=/var"
"-Dsystemdsystemunitdir=/tmp/empty"
@@ -2219,7 +2216,7 @@ fallback to generic Systray support if none of those are available.")
(define-public libportal
(package
(name "libportal")
- (version "0.4")
+ (version "0.5")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2228,30 +2225,27 @@ fallback to generic Systray support if none of those are available.")
(file-name (git-file-name name version))
(sha256
(base32
- "1jh6wd96y4i218zbmmqw12zir8p88nm8dlsa3yx3lsqxd5c1krky"))))
+ "0i4v0wjyiryg7jq9hp9iaplqyhwj1cqy5891s4jfldcdzvcwxwx0"))))
(build-system meson-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'install 'move-doc
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (doc (assoc-ref outputs "doc"))
- (html "/share/gtk-doc"))
- (copy-recursively (string-append out html)
- (string-append doc html))
- (delete-file-recursively (string-append out html))
- #t))))))
+ `(#:configure-flags
+ (list "-Dbackends=gtk4,gtk3,qt5"
+ "-Ddocs=false"))) ; requires unpackaged gi-docgen
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("gtk-doc" ,gtk-doc/stable)
- ("docbook-xsl" ,docbook-xsl)
- ("docbook-xml" ,docbook-xml)
- ("libxml2" ,libxml2)
- ("glib:bin" ,glib "bin")))
+ (list pkg-config
+ docbook-xsl
+ docbook-xml
+ `(,glib "bin")
+ gobject-introspection
+ libxml2
+ vala))
+ (inputs
+ (list gtk
+ gtk+
+ qtbase-5
+ qtx11extras))
(propagated-inputs
(list glib))
- (outputs '("out" "doc"))
(home-page "https://github.com/flatpak/libportal")
(synopsis "Flatpak portal library")
(description
@@ -2378,7 +2372,7 @@ interfaces.")
(define-public xdg-desktop-portal-wlr
(package
(name "xdg-desktop-portal-wlr")
- (version "0.4.0")
+ (version "0.5.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2387,21 +2381,39 @@ interfaces.")
(file-name (git-file-name name version))
(sha256
(base32
- "13fbzh8bjnhk4xs8j9bpc01q3hy27zpbf0gkk1fnh3hm5pnyfyiv"))))
+ "1ipg35gv8ja39ijwbyi96qlyq2y1fjdggl40s38rv68bsya8zry1"))
+ (patches (search-patches "xdg-desktop-portal-wlr-harcoded-length.patch"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags
'("-Dsystemd=disabled"
- "-Dsd-bus-provider=libelogind")))
+ "-Dsd-bus-provider=libelogind")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'hardcode-binaries
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((sh (search-input-file inputs "/bin/sh"))
+ (grim (search-input-file inputs "/bin/grim"))
+ (slurp (search-input-file inputs "/bin/slurp")))
+ (substitute* "src/screenshot/screenshot.c"
+ (("grim") grim)
+ (("slurp") slurp)
+ (("execl\\(\"/bin/sh\", \"/bin/sh\"")
+ (string-append "execl(\"" sh "\", \"" sh "\"")))
+ (substitute* "src/screencast/screencast.c"
+ (("execvp\\(\"sh")
+ (string-append "execvp(\"" sh)))))))))
(native-inputs
(list cmake pkg-config))
- (inputs
- `(("elogind" ,elogind)
- ("iniparser" ,iniparser)
- ("pipewire" ,pipewire-0.3)
- ("inih" ,libinih)
- ("wayland" ,wayland)
- ("wayland-protocols" ,wayland-protocols)))
+ (inputs (list elogind
+ bash-minimal
+ grim
+ iniparser
+ libinih
+ pipewire-0.3
+ slurp
+ wayland
+ wayland-protocols))
(home-page "https://github.com/emersion/xdg-desktop-portal-wlr")
(synopsis "@code{xdg-desktop-portal} backend for wlroots")
(description
@@ -2411,6 +2423,33 @@ remote-desktop @code{xdg-desktop-portal} interfaces for wlroots based
compositors.")
(license license:expat)))
+(define-public poweralertd
+ (package
+ (name "poweralertd")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~kennylevinsen/poweralertd")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "19rw9q4pcqw56nmzjfglfikzx5wwjl4n08awwdhg0jy1k0bm3dvp"))))
+ (build-system meson-build-system)
+ (arguments
+ '(#:configure-flags '("-Dman-pages=enabled")))
+ (native-inputs
+ (list scdoc pkg-config bash-minimal))
+ (inputs
+ (list elogind))
+ (home-page "https://sr.ht/~kennylevinsen/poweralertd")
+ (synopsis "Power alert daemon")
+ (description "poweralertd is a daemon that watches for UPower events and
+notifies the user using any notification daemon implementing
+@code{org.freedesktop.Notifications}.")
+ (license license:gpl3+)))
+
(define-public waypipe
(package
(name "waypipe")