summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm20
1 files changed, 13 insertions, 7 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 89dab53cbc..83374bce6e 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -252,7 +252,17 @@ the freedesktop.org XDG Base Directory specification.")
(substitute* "src/login/org.freedesktop.login1.service"
(("^Exec=.*")
(string-append "Exec=" (assoc-ref %outputs "out")
- "/libexec/elogind/elogind\n"))))))))
+ "/libexec/elogind/elogind\n")))))
+ (add-after 'install 'add-libcap-to-search-path
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; Add a missing '-L' for libcap in libelogind.la. See
+ ;; <https://lists.gnu.org/archive/html/guix-devel/2017-09/msg00084.html>.
+ (let ((libcap (assoc-ref inputs "libcap"))
+ (out (assoc-ref outputs "out")))
+ (substitute* (string-append out "/lib/libelogind.la")
+ (("-lcap")
+ (string-append "-L" libcap "/lib -lcap")))
+ #t))))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
@@ -451,7 +461,6 @@ applications, X servers (rootless or fullscreen) or other display servers.")
`(("cairo" ,cairo-xcb)
("dbus" ,dbus)
("elogind" ,elogind)
- ("libcap" ,libcap)
("libinput" ,libinput-minimal)
("libunwind" ,libunwind)
("libxcursor" ,libxcursor)
@@ -583,7 +592,6 @@ Analysis and Reporting Technology) functionality.")
`(("acl" ,acl)
("libatasmart" ,libatasmart)
("libgudev" ,libgudev)
- ("libcap" ,libcap)
("polkit" ,polkit)
("util-linux" ,util-linux)))
(outputs '("out"
@@ -684,8 +692,7 @@ message bus.")
("intltool" ,intltool)
("pkg-config" ,pkg-config)))
(inputs
- `(("libcap" ,libcap)
- ("shadow" ,shadow)
+ `(("shadow" ,shadow)
("polkit" ,polkit)))
(home-page "http://www.freedesktop.org/wiki/Software/AccountsService/")
(synopsis "D-Bus interface for user account query and manipulation")
@@ -782,8 +789,7 @@ which speak the Qualcomm MSM Interface (QMI) protocol.")
(propagated-inputs
`(("glib" ,glib))) ; required by mm-glib.pc
(inputs
- `(("libcap" ,libcap)
- ("libgudev" ,libgudev)
+ `(("libgudev" ,libgudev)
("libmbim" ,libmbim)
("libqmi" ,libqmi)
("polkit" ,polkit)))