summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm22
1 files changed, 15 insertions, 7 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 1146939408..954a4ad4a0 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1489,13 +1489,13 @@ surface (i.e., gridding) with a hint of machine learning.")
(define-public python-cartopy
(package
(name "python-cartopy")
- (version "0.22.0")
+ (version "0.23.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Cartopy" version))
(sha256
- (base32 "0jdv92az0b7qxdvalh29kasw3knsl570cz7q3vql67ck400zj05k"))))
+ (base32 "0xknmq73pvkm3k718zrsx8p4r83dbskwqna9v4qvmwh1ayrkf7r3"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -1506,8 +1506,16 @@ surface (i.e., gridding) with a hint of machine learning.")
"-m" "not natural_earth and not network"
"-k"
(string-append
- ;; This one too but it's not marked as such.
- "not test_gridliner_labels_bbox_style"
+ ;; These ones too but are not marked as such.
+ "not test_feature_artist_draw"
+ " and not test_feature_artist_draw_facecolor_list"
+ " and not test_feature_artist_draw_cmap"
+ " and not test_feature_artist_draw_styled_feature"
+ " and not test_feature_artist_draw_styler"
+ " and not test_gridliner_constrained_adjust_datalim"
+ " and not test_gridliner_remove"
+ " and not test_gridliner_title_adjust"
+ " and not test_gridliner_labels_bbox_style"
;; Accuracy problems
" and not test_single_spole"
" and not test_single_npole"
@@ -2507,7 +2515,7 @@ data.")
proj
qtbase-5
qtdeclarative-5
- qtlocation
+ qtlocation-5
qtwebchannel-5
qtwebengine-5
quazip
@@ -2743,7 +2751,7 @@ track your position right from your laptop.")
proj
qtbase-5
qtimageformats-5
- qtlocation
+ qtlocation-5
qtsensors-5
zlib))
(native-inputs
@@ -3205,7 +3213,7 @@ SET\\(PYQT5_SIP_DIR \"\\$\\{Python_SITEARCH\\}/PyQt5/bindings\"\\)")
qtbase-5
qtdeclarative-5
qtkeychain
- qtlocation
+ qtlocation-5
qtmultimedia-5
qtserialport-5
qtsvg-5