summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm62
1 files changed, 33 insertions, 29 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b4caaf29a7..010bf2f275 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -78,6 +78,7 @@
;;; Copyright © 2023 Dominik Delgado Steuter <d@delgado.nrw>
;;; Copyright © 2023 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2024 Dariqq <dariqq@posteo.net>
+;;; Copyright © 2024 James Smith <jsubuntuxp@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8983,7 +8984,7 @@ library.")
"--localstatedir=/var"
(string-append "-Ddefault-path="
- (string-join '("/run/setuid-programs"
+ (string-join '("/run/privileged/bin"
"/run/current-system/profile/bin"
"/run/current-system/profile/sbin")
":"))
@@ -11555,34 +11556,34 @@ views can be printed as PDF or PostScript files, or exported to HTML.")
(define-public lollypop
(package
(name "lollypop")
- (version "1.4.35")
+ (version "1.4.40")
(source
(origin
(method url-fetch)
(uri (string-append "https://adishatz.org/lollypop/"
"lollypop-" version ".tar.xz"))
(sha256
- (base32 "0rvwj18x1gs7fgvniijzvlmgmzcgr7il22zclzsn5nkl8xbwgzk0"))))
+ (base32 "1laj5xwfz2bz29scga2ahhnhlgll4a0n21wwy8mlr4jsl81g0jsa"))))
(build-system meson-build-system)
(arguments
- `(#:imported-modules (,@%meson-build-system-modules
- (guix build python-build-system))
- #:modules ((guix build meson-build-system)
- ((guix build python-build-system) #:prefix python:)
- (guix build utils))
- #:glib-or-gtk? #t
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'disable-gtk-update-icon-cache
- (lambda _
- (setenv "DESTDIR" "/")))
- (add-after 'install 'wrap-program
- (lambda* (#:key outputs #:allow-other-keys)
- (wrap-program (search-input-file outputs "bin/lollypop")
- `("GI_TYPELIB_PATH" ":" prefix
- (,(getenv "GI_TYPELIB_PATH"))))))
- (add-after 'install 'wrap-python
- (assoc-ref python:%standard-phases 'wrap)))))
+ (list #:imported-modules `(,@%meson-build-system-modules
+ (guix build python-build-system))
+ #:modules '((guix build meson-build-system)
+ ((guix build python-build-system) #:prefix python:)
+ (guix build utils))
+ #:glib-or-gtk? #t
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-gtk-update-icon-cache
+ (lambda _
+ (setenv "DESTDIR" "/")))
+ (add-after 'install 'wrap-program
+ (lambda* (#:key outputs #:allow-other-keys)
+ (wrap-program (search-input-file outputs "bin/lollypop")
+ (list "GI_TYPELIB_PATH" ":" 'prefix
+ (list (getenv "GI_TYPELIB_PATH"))))))
+ (add-after 'install 'wrap-python
+ (assoc-ref python:%standard-phases 'wrap)))))
(native-inputs
(list gettext-minimal
`(,glib "bin") ; For glib-compile-resources
@@ -13510,17 +13511,17 @@ profiler via Sysprof, debugging support, and more.")
(define-public komikku
(package
(name "komikku")
- (version "1.34.2")
+ (version "1.46.0")
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://gitlab.com/valos/Komikku/")
+ (url "https://codeberg.org/valos/Komikku/")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "044m3z7h1hi2avx4z6qgjzhgn1fkf1iclxhr4j7pb6flbqvwnxhs"))))
+ "1ggg4hgd1kyc69b06kcgvvjwmz72xgjakva19gs3nrszr4cinank"))))
(build-system meson-build-system)
(arguments
(list
@@ -13546,7 +13547,9 @@ profiler via Sysprof, debugging support, and more.")
(lambda* (#:key outputs #:allow-other-keys)
(wrap-program (search-input-file outputs "bin/komikku")
`("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH")))
- `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH")))))))))
+ `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH")))
+ `("GDK_PIXBUF_MODULE_FILE" =
+ (,(getenv "GDK_PIXBUF_MODULE_FILE")))))))))
(inputs
(list bash-minimal
gtk
@@ -13572,7 +13575,8 @@ profiler via Sysprof, debugging support, and more.")
python-rarfile
python-requests
python-unidecode
- webkitgtk))
+ webkitgtk
+ webp-pixbuf-loader))
(native-inputs
(list blueprint-compiler
desktop-file-utils
@@ -13580,7 +13584,7 @@ profiler via Sysprof, debugging support, and more.")
`(,glib "bin")
gobject-introspection
pkg-config))
- (home-page "https://gitlab.com/valos/Komikku")
+ (home-page "https://apps.gnome.org/Komikku")
(synopsis "Manga reader for GNOME")
(description "Komikku is an online/offline manga reader for GNOME,
developed with the aim of being used with the Librem 5 phone.")
@@ -13752,7 +13756,7 @@ Document Analysis and Recognition program.")
(define-public libadwaita
(package
(name "libadwaita")
- (version "1.4.0")
+ (version "1.5.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/libadwaita/"
@@ -13760,7 +13764,7 @@ Document Analysis and Recognition program.")
"libadwaita-" version ".tar.xz"))
(sha256
(base32
- "1hj7kxza6263x662v4ffndlz8dhfx19cz3y4iwhnhdflaj50j6p5"))))
+ "05icswk84kf4pbcybv8j9r9n98q1dgr1m7zn6k72p4dlbh0fxyn9"))))
(build-system meson-build-system)
(arguments
`(#:phases