summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 27216e745d..cda7d24de0 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -872,21 +872,18 @@ their component bytes.")
(license license:mpl2.0)))
(define-public go-github-com-hashicorp-go-version
- (let ((commit
- "03c5bf6be031b6dd45afec16b1cf94fc8938bc77")
- (revision "0"))
(package
(name "go-github-com-hashicorp-go-version")
- (version (git-version "0.0.0" revision commit))
+ (version "1.6.0")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/hashicorp/go-version")
- (commit commit)))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0sjq57gpfznaqdrbyb2p0bn90g9h661cvr0jrk6ngags4pbw14ik"))))
+ (base32 "0fw6hwvjadpbfj10yk7f64ypw8lmv5s5ny3s4ria0nv6xam1wpai"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/hashicorp/go-version"))
@@ -898,7 +895,7 @@ constraints")
constraints, and verifying versions against a set of constraints. It can sort
a collection of versions properly, handles prerelease/beta versions, can
increment versions.")
- (license license:mpl2.0))))
+ (license license:mpl2.0)))
(define-public go-github-com-hhrutter-tiff
(package