summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm29
1 files changed, 0 insertions, 29 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6533914f80..062985c0ce 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9609,35 +9609,6 @@ GNU/Linux, this is a proxy for the @command{xdg-open} command.")
(home-page "https://github.com/skratchdot/open-golang")
(license license:expat))))
-(define-public go-github-com-alecthomas-kingpin
- (package
- (name "go-github-com-alecthomas-kingpin")
- (version "2.2.6")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/alecthomas/kingpin")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0mndnv3hdngr3bxp7yxfd47cas4prv98sqw534mx7vp38gd88n5r"))))
- (build-system go-build-system)
- (native-inputs
- (list go-github-com-alecthomas-template go-github-com-alecthomas-units
- go-github-com-stretchr-testify))
- (arguments
- '(#:import-path "github.com/alecthomas/kingpin"
- #:phases %standard-phases))
- (synopsis "Go library provides utilities for building command line interfaces")
- (description
- "Go library provides utilities for building command line interfaces.")
- (home-page "https://github.com/alecthomas/kingpin")
- (license license:expat)))
-
-(define-public go-github-com-kingpin
- (deprecated-package "go-github-com-kingpin" go-github-com-alecthomas-kingpin))
-
(define-public go-github-com-alecthomas-template
(let ((commit "a0175ee3bccc567396460bf5acd36800cb10c49c")
(revision "0"))