summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm124
1 files changed, 104 insertions, 20 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index f1dbc46fcc..45dded1a6e 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -28,21 +28,33 @@
#:use-module (gnu packages audio)
#:use-module (gnu packages bison)
#:use-module (gnu packages cdrom)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages compression)
#:use-module (gnu packages flex)
+ #:use-module (gnu packages freedesktop)
+ #:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages gnupg)
+ #:use-module (gnu packages graphics)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
+ #:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
#:use-module (gnu packages mp3)
#:use-module (gnu packages perl)
#:use-module (gnu packages pulseaudio)
+ #:use-module (gnu packages qt)
+ #:use-module (gnu packages rdf)
#:use-module (gnu packages video)
#:use-module (gnu packages xorg)
#:use-module (gnu packages xiph)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages ssh)
+ #:use-module (gnu packages telephony)
+ #:use-module (gnu packages tls)
+ #:use-module (gnu packages version-control)
#:use-module (gnu packages yasm)
#:use-module (gnu packages xml))
@@ -83,7 +95,7 @@ arrays of data.")
(define-public gstreamer
(package
(name "gstreamer")
- (version "1.6.1")
+ (version "1.6.3")
(source
(origin
(method url-fetch)
@@ -92,7 +104,7 @@ arrays of data.")
version ".tar.xz"))
(sha256
(base32
- "172w1bpnkn6mm1wi37n03apdbb6cdkykhzjf1vfxchcd7hhkyflp"))))
+ "093zldafh7xh3lrlwzm7j0vvjz6k9ca83wqil40gfz5qcy6mdy92"))))
(build-system gnu-build-system)
(outputs '("out" "doc"))
(arguments
@@ -131,15 +143,15 @@ This package provides the core library and elements.")
(define-public gst-plugins-base
(package
(name "gst-plugins-base")
- (version "1.6.1")
+ (version "1.6.3")
(source
(origin
(method url-fetch)
- (uri (string-append "http://gstreamer.freedesktop.org/src/" name "/"
+ (uri (string-append "https://gstreamer.freedesktop.org/src/" name "/"
name "-" version ".tar.xz"))
(sha256
(base32
- "18sbyjcp281zb3bsqji3pglsdsxi0s6ai7rx90sx8cpflkxdqcwm"))))
+ "0xbskifk95rw7jd85sqjrmqh2kys1bpi0inrxyapx1x4vf7ly5dn"))))
(build-system gnu-build-system)
(outputs '("out" "doc"))
(propagated-inputs
@@ -168,12 +180,11 @@ This package provides the core library and elements.")
(assoc-ref %outputs "doc")
"/share/gtk-doc/html"))
#:phases
- (alist-cons-before
- 'configure 'patch
- (lambda _
- (substitute* "tests/check/libs/pbutils.c"
- (("/bin/sh") (which "sh"))))
- %standard-phases)))
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch
+ (lambda _
+ (substitute* "tests/check/libs/pbutils.c"
+ (("/bin/sh") (which "sh"))))))))
(home-page "http://gstreamer.freedesktop.org/")
(synopsis
"Plugins for the GStreamer multimedia library")
@@ -185,16 +196,16 @@ for the GStreamer multimedia library.")
(define-public gst-plugins-good
(package
(name "gst-plugins-good")
- (version "1.6.1")
+ (version "1.6.3")
(source
(origin
(method url-fetch)
(uri (string-append
- "https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-"
- version ".tar.xz"))
+ "https://gstreamer.freedesktop.org/src/" name "/"
+ name "-" version ".tar.xz"))
(sha256
(base32
- "0darc3058kbnql3mnlpizl0sq0hhli7vkm0rpqb7nywz14abim46"))))
+ "0xx16h0q63gs3pxlzdflnpyssba3vcrh1qnzplg4d0ra1fvrvc94"))))
(build-system gnu-build-system)
(inputs
`(("aalib" ,aalib)
@@ -228,7 +239,7 @@ for the GStreamer multimedia library.")
'unpack 'disable-failing-rtprtx-tests
(lambda _
;; Disable rtprtx tests that frequently fail.
- ;; XXX FIXME: Try removing this for version > 1.6.1.
+ ;; XXX FIXME: Try removing this for version > 1.6.3.
(substitute* "tests/check/elements/rtprtx.c"
(("tcase_add_test \\(tc_chain,\
(test_rtxsender_max_size_packets|test_rtxreceive_data_reconstruction)\\);" all)
@@ -242,10 +253,83 @@ GStreamer multimedia library. This set contains those plug-ins which the
developers consider to have good quality code and correct functionality.")
(license lgpl2.0+)))
+(define-public gst-plugins-bad
+ (package
+ (name "gst-plugins-bad")
+ (version "1.6.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://gstreamer.freedesktop.org/src/"
+ name "/" name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0q9s5da54819gwncmdi95l5qzx97l9vxk6adx4zmx73a3l82j6wp"))))
+ (outputs '("out" "doc"))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; XXX: 11 of 54 tests fail
+ #:configure-flags
+ (list (string-append "--with-html-dir="
+ (assoc-ref %outputs "doc")
+ "/share/gtk-doc/html"))))
+ (propagated-inputs
+ `(("gst-plugins-base" ,gst-plugins-base)))
+ (native-inputs
+ `(("glib:bin" ,glib "bin") ; for glib-mkenums, etc.
+ ("gobject-introspection" ,gobject-introspection)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python)))
+ (inputs
+ ;; XXX: The following dependencies are missing:
+ ;; vo-amrwbenc, vo-aacenc, bs2b, chromaprint, directfb, daala, libdts,
+ ;; faac, flite, libgsm, libde265, libmms, libmimic, mjpegtools,
+ ;; mpeg2enc, libofa, opencv, openh264, openni2, libtimemmgr, wildmidi,
+ ;; openspc, gme, sbc, schroedinger, zbar, librtmp, spandsp, x265
+ `(("bluez" ,bluez)
+ ("curl" ,curl)
+ ("faad2" ,faad2)
+ ("fluidsynth" ,fluidsynth)
+ ("gtk+" ,gtk+)
+ ("ladspa" ,ladspa)
+ ("libass" ,libass)
+ ("libdvdnav" ,libdvdnav)
+ ("libdvdread" ,libdvdread)
+ ("libgcrypt" ,libgcrypt)
+ ("libgudev" ,libgudev)
+ ("libkate" ,libkate)
+ ("libmodplug" ,libmodplug)
+ ("librsvg" ,librsvg)
+ ("libsndfile" ,libsndfile)
+ ("libsrtp" ,libsrtp)
+ ("libssh2" ,libssh2)
+ ("libusb" ,libusb)
+ ("libvdpau" ,libvdpau)
+ ("libwebp" ,libwebp)
+ ("libxml2" ,libxml2)
+ ("lrdf" ,lrdf)
+ ("mesa" ,mesa)
+ ("mpg123" ,mpg123)
+ ("neon" ,neon)
+ ("openal" ,openal)
+ ("openexr" ,openexr)
+ ("openjpeg" ,openjpeg)
+ ("openssl" ,openssl)
+ ("opus" ,opus)
+ ("orc" ,orc)
+ ("qt" ,qt)
+ ("soundtouch" ,soundtouch)
+ ("wayland" ,wayland)))
+ (home-page "http://gstreamer.freedesktop.org/")
+ (synopsis "Plugins for the GStreamer multimedia library")
+ (description
+ "GStreamer Bad Plug-ins is a set of plug-ins whose quality aren't up to
+par compared to the rest.")
+ (license lgpl2.0+)))
+
(define-public gst-plugins-ugly
(package
(name "gst-plugins-ugly")
- (version "1.6.1")
+ (version "1.6.3")
(source
(origin
(method url-fetch)
@@ -253,7 +337,7 @@ developers consider to have good quality code and correct functionality.")
name "/" name "-" version ".tar.xz"))
(sha256
(base32
- "0mvasl1pwq70w2kmrkcrg77kggl5q7jqybi7fkvy3vr28c7gkhqc"))))
+ "0r6h3ys5n90jv3c06crxzcac561z07s4h04hy5i8ybw8qyvzgv1g"))))
(build-system gnu-build-system)
(inputs
`(("gst-plugins-base" ,gst-plugins-base)
@@ -283,7 +367,7 @@ distribution problems in some jurisdictions, e.g. due to patent threats.")
(define-public gst-libav
(package
(name "gst-libav")
- (version "1.6.1")
+ (version "1.6.3")
(source (origin
(method url-fetch)
(uri (string-append
@@ -291,7 +375,7 @@ distribution problems in some jurisdictions, e.g. due to patent threats.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1a9pc7zp5rg0cvpx8gqkr21w73i6p9xa505a34day9f8p3lfim94"))))
+ "1aylbg1xnm68c3wc49mzx813qhsjfg23hqnjqqwdwdq31839qyw5"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--with-system-libav")