summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm15
1 files changed, 3 insertions, 12 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 12b37ffe12..01474e29a7 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -723,6 +723,8 @@ model to base your own plug-in on, here it is.")
;("qtdeclarative" ,qtdeclarative)
;("qtx11extras" ,qtx11extras)
("soundtouch" ,soundtouch)
+ ;; GStreamer is not yet compatible with srt > 1.4.1.
+ ("srt" ,srt-1.4.1)
("x265" ,x265)
("wayland" ,wayland)))
(home-page "https://gstreamer.freedesktop.org/")
@@ -919,18 +921,7 @@ non-linear editors.")
(description
"This package contains GObject Introspection overrides for Python that can
be used by Python applications using GStreamer.")
- (license license:lgpl2.1+)
- (properties `((python2-variant . ,(delay python2-gst))))))
-
-(define-public python2-gst
- (package (inherit python-gst)
- (name "python2-gst")
- (native-inputs
- `(("pkg-config" ,pkg-config)
- ("python" ,python-2)))
- (propagated-inputs
- `(("gst-plugins-base" ,gst-plugins-base)
- ("python-pygobject" ,python2-pygobject)))))
+ (license license:lgpl2.1+)))
(define-public gst123
(package