summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm46
1 files changed, 28 insertions, 18 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 56763cd835..04183fa806 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1171,19 +1171,29 @@ application suites.")
'("-Dgtk_doc=false")
'("-Dgtk_doc=true"))
"-Dman-pages=true")
- #:test-options '(list "--setup=x11" ;defaults to wayland
- ;; Use the same test options as upstream uses for
- ;; their CI.
- "--suite=gtk"
- "--no-suite=failing"
- "--no-suite=flaky"
- "--no-suite=headless" ; requires mutter…
- "--no-suite=gsk-compare-broadway"
- ;; These seem to fail on aarch64, and Debian has
- ;; also disabled these, see:
- ;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1050075
- "--no-suite=wayland_failing"
- "--no-suite=wayland_gles_failing")
+ #:test-options #~(list "--setup=x11" ;defaults to wayland
+ ;; Use the same test options as upstream uses for
+ ;; their CI.
+ "--suite=gtk"
+ "--no-suite=failing"
+ "--no-suite=flaky"
+ "--no-suite=headless" ; requires mutter…
+ "--no-suite=gsk-compare-broadway"
+ ;; These seem to fail on aarch64, and Debian has
+ ;; also disabled these, see:
+ ;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1050075
+ "--no-suite=wayland_failing"
+
+ ;; The correct name of the test that fails on
+ ;; AArch64 is 'wayland_gles2_failing':
+ ;; <https://gitlab.gnome.org/GNOME/gtk/-/commit/b916c4dac1075572>.
+ ;; The second arm of the 'if' is kept to avoid a
+ ;; rebuild on other architectures. TODO: Remove
+ ;; on the next rebuild cycle.
+ #$(if (and (not (%current-target-system))
+ (string=? (%current-system) "aarch64-linux"))
+ "--no-suite=wayland_gles2_failing"
+ "--no-suite=wayland_gles_failing"))
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'generate-gdk-pixbuf-loaders-cache-file
@@ -2741,7 +2751,7 @@ displayed on the other side of the bus.")
(define-public gtk-layer-shell
(package
(name "gtk-layer-shell")
- (version "0.6.0")
+ (version "0.8.0")
(source
(origin
(method git-fetch)
@@ -2750,10 +2760,10 @@ displayed on the other side of the bus.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1kcp4p3s7sdh9lwniybjdarfy8z69j2j23hfrw98amhwhq39gdcc"))))
+ (base32 "0cf1fjlsplslmabpvyfdnvngkn5wfsk6jd7gbq6h74x0n9hczf37"))))
(build-system meson-build-system)
(arguments `(#:configure-flags (list "-Dtests=true")))
- (native-inputs (list pkg-config gobject-introspection))
+ (native-inputs (list pkg-config gobject-introspection vala))
(inputs (list wayland gtk+))
(home-page "https://github.com/wmww/gtk-layer-shell")
(synopsis "Library to create Wayland desktop components using the Layer
@@ -2970,7 +2980,7 @@ Unix desktop environment under X11 as well as Wayland.")
(define-public webp-pixbuf-loader
(package
(name "webp-pixbuf-loader")
- (version "0.0.4")
+ (version "0.2.4")
(source
(origin
(method git-fetch)
@@ -2979,7 +2989,7 @@ Unix desktop environment under X11 as well as Wayland.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1kshsz91mirjmnmv796nba1r8jg8a613anhgd38dhh2zmnladcwn"))))
+ (base32 "0dsdkw0i8fg3051653zmz68s068a2w23d708av64afzvav1xvhv0"))))
(build-system meson-build-system)
(arguments
(list