summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 9252315fd2..8fabd16222 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1163,6 +1163,17 @@ application suites.")
(add-after 'unpack 'generate-gdk-pixbuf-loaders-cache-file
(assoc-ref glib-or-gtk:%standard-phases
'generate-gdk-pixbuf-loaders-cache-file))
+ #$@(if (target-aarch64?)
+ #~((add-after 'unpack 'skip-failing-test
+ (lambda _
+ ;; MESA: error: ZINK: failed to load libvulkan.so.1
+ ;; libEGL warning: egl: failed to create dri2 screen
+ ;; MESA: error: ZINK: failed to load libvulkan.so.1
+ ;; glx: failed to create drisw screen
+ ;; failed to load driver: zink
+ (substitute* "testsuite/gsk/meson.build"
+ ((".*big-checkerboard-scaled-down2',\n") "")))))
+ #~())
(add-after 'unpack 'patch-rst2man
(lambda _
(substitute* "docs/reference/gtk/meson.build"