summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm26
1 files changed, 2 insertions, 24 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 5ef51e27a9..50d0c0920e 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -44,7 +44,7 @@
;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
;;; Copyright © 2022 Taiju HIGASHI <higashi@taiju.info>
;;; Copyright © 2022, 2023 Zheng Junjie <873216071@qq.com>
-;;; Copyright © 2022 Evgeny Pisemsky <evgeny@pisemsky.com>
+;;; Copyright © 2022 Evgeny Pisemsky <mail@pisemsky.site>
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;; Copyright © 2023 Andrew Tropin <andrew@trop.in>
;;; Copyright © 2024 Ilya Chernyshov <ichernyshovvv@gmail.com>
@@ -1053,27 +1053,6 @@ HTML (via SXML) or any other format for rendering.")
(home-page "https://dthompson.us/projects/guile-syntax-highlight.html")
(license license:lgpl3+)))
-;; gitile requires a more recent version than the latest release.
-(define-public guile-syntax-highlight-for-gitile
- (let ((commit "897fa5156ff41588e0d281eb00e4e94de63ccd8a")
- (revision "0"))
- (package
- (inherit guile-syntax-highlight)
- (version (git-version "0.1" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.dthompson.us/guile-syntax-highlight.git")
- (commit commit)))
- (file-name (git-file-name "guile-syntax-highlight" version))
- (sha256
- (base32
- "18zlg4mkgd3swgv2ggfz91ivnnzc0zhvc9ybgrxg1y762va9hyvj"))))
- (native-inputs
- (modify-inputs (package-native-inputs guile-syntax-highlight)
- (prepend autoconf automake texinfo)))
- (properties '((hidden? . #t))))))
-
(define-public guile2.2-syntax-highlight
(package
(inherit guile-syntax-highlight)
@@ -2718,8 +2697,7 @@ many readers as needed).")
(guix build utils))
#:imported-modules ((guix build guile-build-system)
,@%gnu-build-system-modules)
- #:configure-flags (list "--with-ncursesw" ; Unicode support
- "--with-gnu-filesystem-hierarchy")
+ #:configure-flags (list "--with-gnu-filesystem-hierarchy")
#:phases
(modify-phases %standard-phases
(add-before 'build 'fix-libguile-ncurses-file-name