summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 379d9aa264..2877b7d199 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -618,6 +618,21 @@ Unix-style DSV format and RFC 4180 format.")
(search-patches "guile-fibers-wait-for-io-readiness.patch"
"guile-fibers-epoll-instance-is-dead.patch"))))
(build-system gnu-build-system)
+ (arguments
+ (list #:make-flags
+ #~(list "GUILE_AUTO_COMPILE=0")
+ #:phases
+ (if (target-x86-64?)
+ #~%standard-phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'disable-some-tests
+ (lambda _
+ ;; This test can take more than an hour on some systems.
+ (substitute* "tests/basic.scm"
+ ((".*spawn-fiber loop-to-1e4.*") ""))
+ ;; These tests can take more than an hour and/or segfault.
+ (substitute* "Makefile"
+ (("tests/speedup.scm") ""))))))))
(native-inputs
(list texinfo pkg-config autoconf automake libtool
guile-3.0 ;for 'guild compile