summaryrefslogtreecommitdiff
path: root/gnu/packages/hardware.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/hardware.scm')
-rw-r--r--gnu/packages/hardware.scm21
1 files changed, 18 insertions, 3 deletions
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index e1514fb40b..4765d1c55d 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -481,15 +481,23 @@ RGB animations.")
(define-public ddcutil
(package
(name "ddcutil")
- (version "1.4.2")
+ (version "1.4.5")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.ddcutil.com/tarballs/"
"ddcutil-" version ".tar.gz"))
(sha256
- (base32 "015l13j7fp9fmlc5d7m6nfjbzjbp8vc0g5py35ljw7li2xk16v60"))))
+ (base32 "17zrqdz5mzwyccvc5m166yjlbbg9k2m9cwyg0y30h3184p1b2wlq"))))
(build-system gnu-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'install-missing-pkgconfig-file
+ (lambda _
+ (install-file "ddcutil.pc"
+ (string-append #$output "/lib/pkgconfig")))))))
(native-inputs
(list pkg-config))
(inputs
@@ -798,6 +806,7 @@ information can be viewed in real time and/or logged to a file.")
also provides extensions for proprietary methods of interfacing with Dell
specific SMBIOS tables.")
(home-page "https://github.com/dell/libsmbios")
+ (supported-systems (list "i686-linux" "x86_64-linux"))
(license
(list license:osl2.1 license:gpl2+ license:bsd-3 license:boost1.0))))
@@ -1089,11 +1098,17 @@ technology, such as head mounted displays with built in head tracking.")
(("dependencies/json")
(string-append #$(this-package-input "nlohmann-json")
"/include/nlohmann")))))
+ (add-after 'unpack 'patch-chmod
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "scripts/build-udev-rules.sh"
+ (("/bin/chmod") (string-append (assoc-ref inputs "coreutils")
+ "/bin/chmod")))))
;; Call qmake instead of configure to create a Makefile.
(replace 'configure
(lambda _ (invoke "qmake" "PREFIX=/" "OpenRGB.pro"))))))
(inputs
- (list hidapi
+ (list coreutils
+ hidapi
hueplusplus
nlohmann-json
libusb