summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-crypto.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/haskell-crypto.scm')
-rw-r--r--gnu/packages/haskell-crypto.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/haskell-crypto.scm b/gnu/packages/haskell-crypto.scm
index f1c9b9f26c..d930536e3f 100644
--- a/gnu/packages/haskell-crypto.scm
+++ b/gnu/packages/haskell-crypto.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
-;;; Copyright © 2015, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 ng0 <ng0@infotropique.org>
;;; Copyright © 2017 rsiddharth <s@ricketyspace.net>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -257,7 +257,7 @@ the C implementation.")
(define-public ghc-cryptonite
(package
(name "ghc-cryptonite")
- (version "0.19")
+ (version "0.20")
(source (origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/"
@@ -265,7 +265,7 @@ the C implementation.")
version ".tar.gz"))
(sha256
(base32
- "1rw5k34vpn4134yrzdhf0rsshsrkixfbv9ap18di2n00z2cw1shw"))))
+ "0m63np0affci7ba9mrkvw2flzxn0s2mk930xldc4dwijw32gl6r6"))))
(build-system haskell-build-system)
(inputs
`(("ghc-memory" ,ghc-memory)
@@ -419,14 +419,14 @@ libraries, like OpenSSL.")
(define-public ghc-x509
(package
(name "ghc-x509")
- (version "1.6.3")
+ (version "1.6.4")
(source (origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/"
"x509/x509-" version ".tar.gz"))
(sha256
(base32
- "1pmsby29abn485fvnymsgipvb3p1ch9c591xj5ncszkf0ivjiiin"))))
+ "0hixx76wpb4qxida017ka5zr6lrsycahrqyw8z90q9mxvndpy3my"))))
(build-system haskell-build-system)
(inputs
`(("ghc-memory" ,ghc-memory)
@@ -449,7 +449,7 @@ libraries, like OpenSSL.")
(define-public ghc-x509-store
(package
(name "ghc-x509-store")
- (version "1.6.1")
+ (version "1.6.2")
(source (origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/"
@@ -457,7 +457,7 @@ libraries, like OpenSSL.")
version ".tar.gz"))
(sha256
(base32
- "01abx528i9f7djq2772xyna8x2mykrnwqkcfrapcx7z3bhprvml3"))))
+ "0yw09nwkvr324qz4sc27c0p28bz2h6gns6lkaz9mz92mgqf2dza9"))))
(build-system haskell-build-system)
(inputs
`(("ghc-mtl" ,ghc-mtl)
@@ -476,7 +476,7 @@ collections, certificates, revocation lists, and exception lists.")
(define-public ghc-x509-validation
(package
(name "ghc-x509-validation")
- (version "1.6.3")
+ (version "1.6.5")
(source (origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/"
@@ -484,7 +484,7 @@ collections, certificates, revocation lists, and exception lists.")
version ".tar.gz"))
(sha256
(base32
- "1qr1v561hdlhjgqjv9pj9mbk0q1xf2mr1j67ghy93nlxxyzd7dw0"))))
+ "190w1sr3w6w49v3yvqz4grb0v09ym4gll3n8bxwijvbvcybk3xyi"))))
(build-system haskell-build-system)
(inputs
`(("ghc-memory" ,ghc-memory)
@@ -508,7 +508,7 @@ list validation.")
(define-public ghc-x509-system
(package
(name "ghc-x509-system")
- (version "1.6.1")
+ (version "1.6.4")
(source (origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/"
@@ -516,7 +516,7 @@ list validation.")
version ".tar.gz"))
(sha256
(base32
- "10qf60d2f9jqwnbrhsb2cwpi86xg66m6dxndlxw967v1cdb3h6gf"))))
+ "0k7zc0xp7r6kqmi39rpiicvq78xb0pr2cq6q5s3kmmsshllg13nr"))))
(build-system haskell-build-system)
(inputs
`(("ghc-mtl" ,ghc-mtl)