summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 0c79ece194..c53dc064b1 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -568,7 +568,7 @@ Haskell's Web Application Interface (WAI).")
("ghc-tasty-hedgehog" ,ghc-tasty-hedgehog)
("ghc-tasty-hunit" ,ghc-tasty-hunit)
("ghc-doctest" ,ghc-doctest)))
- (home-page "http://github.com/sjakobi/bsb-http-chunked")
+ (home-page "https://github.com/sjakobi/bsb-http-chunked")
(synopsis "Chunked HTTP transfer encoding for bytestring builders")
(description "This Haskell library contains functions for encoding
bytestring builders for chunked Hypertext Transfer Protocol (HTTP) 1.1
@@ -616,7 +616,7 @@ transfers.")
("ghc-hunit" ,ghc-hunit)
("ghc-http-client" ,ghc-http-client)
("hspec-discover" ,hspec-discover)))
- (home-page "http://github.com/yesodweb/wai")
+ (home-page "https://github.com/yesodweb/wai")
(synopsis "HTTP server library for Haskell's WAI")
(description "Warp is a server library for HTTP/1.x and HTTP/2
based WAI (Web Application Interface in Haskell).")
@@ -671,7 +671,7 @@ limitation, automatic pruning, energy saving and replay resistance.")
("ghc-tls-session-manager" ,ghc-tls-session-manager)
("ghc-wai" ,ghc-wai)
("ghc-warp" ,ghc-warp)))
- (home-page "http://github.com/yesodweb/wai")
+ (home-page "https://github.com/yesodweb/wai")
(synopsis "SSL/TLS support for Warp")
(description "This package provides SSL/TLS support for Warp,
a WAI handler, via the native Haskell TLS implementation.")
@@ -807,7 +807,7 @@ attacks.")
`(("ghc-attoparsec" ,ghc-attoparsec)
("ghc-hspec" ,ghc-hspec)
("ghc-quickcheck" ,ghc-quickcheck)))
- (home-page "http://www.yesodweb.com/")
+ (home-page "https://www.yesodweb.com/")
(synopsis "CSS parser and renderer")
(description "This package provides a CSS parser and renderer for
Haskell.")
@@ -1288,7 +1288,7 @@ functions, widgets, etc.")
("ghc-wai-extra" ,ghc-wai-extra)
("ghc-yesod-core" ,ghc-yesod-core)
("ghc-persistent-sqlite" ,ghc-persistent-sqlite)))
- (home-page "http://www.yesodweb.com/")
+ (home-page "https://www.yesodweb.com/")
(synopsis "Helpers for using Persistent from Yesod")
(description "This Haskell package provides helpers for using Persistent
from Yesod.")
@@ -1447,7 +1447,7 @@ ignored.")
(inputs
`(("ghc-hxt-charproperties" ,ghc-hxt-charproperties)
("ghc-hunit" ,ghc-hunit)))
- (home-page "http://www.haskell.org/haskellwiki/Regular_expressions_for_XML_Schema")
+ (home-page "https://wiki.haskell.org/Regular_expressions_for_XML_Schema")
(synopsis "Regular expression library for W3C XML Schema regular expressions")
(description
"This library supports full W3C XML Schema regular expressions inclusive