summaryrefslogtreecommitdiff
path: root/gnu/packages/ipfs.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ipfs.scm')
-rw-r--r--gnu/packages/ipfs.scm428
1 files changed, 402 insertions, 26 deletions
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index d75a99c4e1..ccf5728e4f 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -29,6 +29,7 @@
#:use-module (guix git-download)
#:use-module (guix download)
#:use-module (guix build-system go)
+ #:use-module (gnu packages gcc)
#:use-module (gnu packages golang)
#:use-module (gnu packages golang-build)
#:use-module (gnu packages golang-check)
@@ -36,10 +37,36 @@
#:use-module (gnu packages golang-crypto)
#:use-module (gnu packages golang-web)
#:use-module (gnu packages golang-xyz)
+ #:use-module (gnu packages prometheus)
#:use-module (gnu packages python)
#:use-module (gnu packages shells)
#:use-module (gnu packages specifications))
+(define-public go-github-com-ipfs-bbloom
+ (package
+ (name "go-github-com-ipfs-bbloom")
+ (version "0.0.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipfs/bbloom")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0dcdn7nlysynl7yrbivv8m7j83jq7pabhcff8mvfjdk583rgnkp2"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/ipfs/bbloom"))
+ (home-page "https://github.com/ipfs/bbloom")
+ (synopsis "Fast bit set Bloom filter")
+ (description
+ "This package implements a fast bloom filter with real @code{bitset} and
+JSONMarshal/JSONUnmarshal to store/reload the Bloom filter.")
+ (license (list license:expat ; bbloom.go
+ license:public-domain)))) ; siphash.go
+
(define-public go-github-com-ipfs-go-block-format
(package
(name "go-github-com-ipfs-go-block-format")
@@ -56,7 +83,6 @@
(build-system go-build-system)
(arguments
(list
- #:go go-1.21
#:import-path "github.com/ipfs/go-block-format"))
(propagated-inputs
(list go-github-com-multiformats-go-multihash
@@ -72,6 +98,73 @@ by a @acronym{Content Identifiers,CID}. The CID contains the multihash
corresponding to the block.")
(license license:expat)))
+(define-public go-github-com-ipfs-go-ipfs-blockstore
+ (package
+ (name "go-github-com-ipfs-go-ipfs-blockstore")
+ (version "1.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipfs/go-ipfs-blockstore")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1a3a0fm8k8njdlq2w795qff01piadjfp6r5r2hww69fxqsplln9l"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/ipfs/go-ipfs-blockstore"))
+ (propagated-inputs
+ (list go-github-com-hashicorp-golang-lru
+ go-github-com-ipfs-bbloom
+ go-github-com-ipfs-go-block-format
+ go-github-com-ipfs-go-cid
+ go-github-com-ipfs-go-datastore
+ go-github-com-ipfs-go-ipfs-ds-help
+ go-github-com-ipfs-go-ipfs-util
+ go-github-com-ipfs-go-ipld-format
+ go-github-com-ipfs-go-log
+ go-github-com-ipfs-go-metrics-interface
+ go-github-com-multiformats-go-multihash
+ go-go-uber-org-atomic))
+ (home-page "https://github.com/ipfs/go-ipfs-blockstore")
+ (synopsis "Caching wrapper over a IPFS datastore")
+ (description
+ "@code{go-ipfs-blockstore} implements a thin wrapper over an IPFS datastore,
+giving a clean interface for getting and putting block objects.")
+ (license license:expat)))
+
+(define-public go-github-com-ipfs-go-ipfs-blocksutil
+ ;; Use the latest commit from the "master" branch to fix the build with
+ ;; go-1.21, see <https://github.com/ipfs/go-ipfs-blocksutil/issues/25>.
+ (let ((commit "ce0497f5ee55c479db98905aec8ff56c27aad2a2")
+ (revision "0"))
+ (package
+ (name "go-github-com-ipfs-go-ipfs-blocksutil")
+ (version (git-version "0.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipfs/go-ipfs-blocksutil")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ya6376wphp51rv48nmv4jw3x0mf6ym5yx1650fbkp5l5crqpdb8"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/ipfs/go-ipfs-blocksutil"))
+ (propagated-inputs
+ (list go-github-com-ipfs-go-block-format))
+ (home-page "https://github.com/ipfs/go-ipfs-blocksutil")
+ (synopsis "Utility functions for working with IPFS blocks")
+ (description
+ "This package provides an utility functions for working with
+@url{https://github.com/ipfs/go-block-format, IPFS blocks}.")
+ (license license:expat))))
+
(define-public go-github-com-ipfs-go-cid
(package
(name "go-github-com-ipfs-go-cid")
@@ -88,7 +181,6 @@ corresponding to the block.")
(build-system go-build-system)
(arguments
(list
- #:go go-1.21
#:import-path "github.com/ipfs/go-cid"))
(propagated-inputs
(list go-github-com-multiformats-go-multihash
@@ -117,7 +209,6 @@ used in @code{go-ipfs} and related packages to refer to a typed hunk of data.")
(build-system go-build-system)
(arguments
(list
- #:go go-1.21
#:import-path "github.com/ipfs/go-cidutil"))
(propagated-inputs
(list go-github-com-ipfs-go-cid
@@ -150,7 +241,9 @@ with @url{https://github.com/ipld/cid, CIDs}.")
"0qk6fshgdmhp8dip2ksm13j6nywi41m9mn0czkvmw6b697z85l2r"))))
(build-system go-build-system)
(arguments
- `(#:go ,go-1.16
+ `(#:go ,@(if (supported-package? go-1.16)
+ `(,go-1.16)
+ `(,gccgo-11))
#:unpack-path "github.com/ipfs/go-ipfs-cmdkit"
#:import-path "github.com/ipfs/go-ipfs-cmdkit/files"))
(home-page "https://github.com/ipfs/go-ipfs-cmdkit")
@@ -184,6 +277,35 @@ that are shared between @command{go-ipfs/commands} and its rewrite
objects.")
(license license:expat)))
+(define-public go-github-com-ipfs-go-ipfs-ds-help
+ (package
+ (name "go-github-com-ipfs-go-ipfs-ds-help")
+ (version "1.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipfs/go-ipfs-ds-help")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1xmn9pdyrcim9ahqs9pkh0c9ac71gilb3pb48kcagq8zxf22i4bj"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/ipfs/go-ipfs-ds-help"))
+ (propagated-inputs
+ (list go-github-com-ipfs-go-cid
+ go-github-com-ipfs-go-datastore
+ go-github-com-multiformats-go-base32
+ go-github-com-multiformats-go-multihash))
+ (home-page "https://github.com/ipfs/go-ipfs-ds-help")
+ (synopsis "Utilities for parsing and creating datastore keys")
+ (description
+ "@code{go-ipfs-ds-help} provides utilities for parsing and creating datastore
+keys used by @code{go-ipfs} (Kubo).")
+ (license license:expat)))
+
(define-public go-github-com-ipfs-go-datastore
(package
(name "go-github-com-ipfs-go-datastore")
@@ -237,13 +359,38 @@ throughout its lifetime.")
(build-system go-build-system)
(arguments
(list
- #:go go-1.21
#:import-path "github.com/ipfs/go-detect-race"))
(home-page "https://github.com/ipfs/go-detect-race")
(synopsis "Detect if compiled with race")
(description "Check if the race detector is running.")
(license license:expat)))
+(define-public go-github-com-ipfs-go-ipfs-exchange-interface
+ (package
+ (name "go-github-com-ipfs-go-ipfs-exchange-interface")
+ (version "0.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipfs/go-ipfs-exchange-interface")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0h5jizhjq4yz9sikqc6yhv5gsb8fgv67v0qjzagyhfznfx8kwv1d"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/ipfs/go-ipfs-exchange-interface"))
+ (propagated-inputs
+ (list go-github-com-ipfs-go-block-format
+ go-github-com-ipfs-go-cid))
+ (home-page "https://github.com/ipfs/go-ipfs-exchange-interface")
+ (synopsis "The IPFS Exchange interface")
+ (description
+ "@code{go-ipfs-exchange-interface} defines the IPFS exchange interface.")
+ (license license:expat)))
+
(define-public go-github-com-ipfs-go-ipfs-util
(package
(name "go-github-com-ipfs-go-ipfs-util")
@@ -262,7 +409,6 @@ throughout its lifetime.")
go-github-com-multiformats-go-multihash))
(arguments
(list
- #:go go-1.21
#:import-path "github.com/ipfs/go-ipfs-util"))
(home-page "https://github.com/ipfs/go-ipfs-util")
(synopsis "Common utilities used by @code{go-ipfs} and related packages")
@@ -270,6 +416,79 @@ throughout its lifetime.")
"Common utilities used by @code{go-ipfs} and other related Go packages.")
(license license:expat)))
+(define-public go-github-com-ipfs-go-ipld-cbor
+ (package
+ (name "go-github-com-ipfs-go-ipld-cbor")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipfs/go-ipld-cbor")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0yxk4sbf1fk9aaizzpz3h30049wqvaz0s3jnbdd5akhj7wg89h21"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/ipfs/go-ipld-cbor"))
+ (propagated-inputs
+ (list go-github-com-ipfs-go-block-format
+ go-github-com-ipfs-go-cid
+ go-github-com-ipfs-go-ipfs-util
+ go-github-com-ipfs-go-ipld-format
+ go-github-com-multiformats-go-multihash
+ go-github-com-polydawn-refmt
+ go-github-com-whyrusleeping-cbor-gen))
+ (home-page "https://github.com/ipfs/go-ipld-cbor")
+ (synopsis "A cbor implementation of the @code{go-ipld-format}")
+ (description
+ "An implementation of a @url{https://cbor.io/, CBOR} encoded merkledag object.")
+ (license license:expat)))
+
+(define-public go-github-com-ipfs-go-ipld-git
+ (package
+ (name "go-github-com-ipfs-go-ipld-git")
+ (version "0.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipfs/go-ipld-git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1v52qzgmx7qym0qzkzkry2kfj58f9hh7c8qycg74sqbd9zb1ynjj"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ ;; XXX: It requires .git/objects, check if it's applicable to generate
+ ;; git repo during check phase with make-test-repo.sh.
+ #:tests? #f
+ #:import-path "github.com/ipfs/go-ipld-git"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-test-data-files
+ (lambda* (#:key import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (for-each delete-file
+ (list "testdata.tar.gz"
+ "codecov.yml"
+ "make-test-repo.sh"))))))))
+ (propagated-inputs
+ (list go-github-com-multiformats-go-multihash
+ go-github-com-ipld-go-ipld-prime
+ go-github-com-ipfs-go-cid
+ go-github-com-ipfs-go-block-format))
+ (home-page "https://github.com/ipfs/go-ipld-git")
+ (synopsis "IPLD handlers for git objects")
+ (description
+ "This is an IPLD codec which handles git objects. Objects are transformed into
+IPLD graph as detailed below. Objects are demonstrated here using both
+@url{https://ipld.io/docs/schemas/,IPLD Schemas} and example JSON forms.")
+ (license license:expat)))
+
(define-public go-github-com-ipfs-go-ipld-format
(package
(name "go-github-com-ipfs-go-ipld-format")
@@ -286,7 +505,6 @@ throughout its lifetime.")
(build-system go-build-system)
(arguments
(list
- #:go go-1.21
#:import-path "github.com/ipfs/go-ipld-format"))
(propagated-inputs
(list go-github-com-multiformats-go-multihash
@@ -299,6 +517,64 @@ throughout its lifetime.")
order to be a part of the @acronym{IPLD, InterPlanetary Linked Data} merkle-forest.")
(license license:expat)))
+(define-public go-github-com-ipfs-go-ipld-legacy
+ (package
+ (name "go-github-com-ipfs-go-ipld-legacy")
+ (version "0.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipfs/go-ipld-legacy")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0sc2zc3lyxy30fzynwdpfrl8jhh1ynwixn1crrv8hzn93yix6550"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.21
+ #:import-path "github.com/ipfs/go-ipld-legacy"))
+ (native-inputs (list go-github-com-stretchr-testify))
+ (propagated-inputs (list go-github-com-ipfs-go-block-format
+ go-github-com-ipfs-go-cid
+ go-github-com-ipfs-go-ipld-format
+ go-github-com-ipld-go-ipld-prime))
+ (home-page "https://github.com/ipfs/go-ipld-legacy")
+ (synopsis "Translation layer for IPLD legacy code")
+ (description
+ "@code{go-ipld-format} is a translation layer between @code{go-ipld-prime} nodes
+and @code{go-ipld-format} legacy interface.")
+ (license (list license:expat license:asl2.0))))
+
+(define-public go-github-com-ipld-go-codec-dagpb
+ (package
+ (name "go-github-com-ipld-go-codec-dagpb")
+ (version "1.6.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipld/go-codec-dagpb")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1jbrwbgr222wsi95gdflbj350csja6k8vphdq7c9bm50ipr8bvkq"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.21
+ #:import-path "github.com/ipld/go-codec-dagpb"))
+ (propagated-inputs (list go-github-com-ipfs-go-cid
+ go-github-com-ipld-go-ipld-prime
+ go-google-golang-org-protobuf))
+ (home-page "https://github.com/ipld/go-codec-dagpb/")
+ (synopsis "Implementation of the DAG-PB spec for Go")
+ (description
+ "An implementation of the @url{https://ipld.io/, IPLD DAG-PB} spec for
+@code{go-ipld-prime}.")
+ (license (list license:expat license:asl2.0))))
+
(define-public go-github-com-ipld-go-ipld-prime
(package
(name "go-github-com-ipld-go-ipld-prime")
@@ -315,7 +591,6 @@ order to be a part of the @acronym{IPLD, InterPlanetary Linked Data} merkle-fore
(build-system go-build-system)
(arguments
(list
- #:go go-1.21
#:unpack-path "github.com/ipld/go-ipld-prime/"
#:import-path "github.com/ipld/go-ipld-prime/"
#:phases
@@ -332,7 +607,7 @@ order to be a part of the @acronym{IPLD, InterPlanetary Linked Data} merkle-fore
go-github-com-warpfork-go-testmark
specification-ipld))
(propagated-inputs
- (list go-github-com-google-go-cmp-cmp
+ (list go-github-com-google-go-cmp
go-github-com-ipfs-go-block-format
go-github-com-ipfs-go-cid
go-github-com-multiformats-go-multicodec
@@ -415,7 +690,6 @@ basic operations on IPLD objects (traversals, etc).")
go-go-uber-org-zap))
(arguments
(list
- #:go go-1.21
#:import-path "github.com/ipfs/go-log/v2"))
(home-page "https://github.com/ipfs/go-log")
(synopsis "Logging library used by @code{go-ipfs}")
@@ -446,9 +720,98 @@ their levels to be controlled individually.")
go-go-uber-org-zap))
(arguments
(list
- #:go go-1.21
#:import-path "github.com/ipfs/go-log"))))
+(define-public go-github-com-ipfs-go-metrics-interface
+ (package
+ (name "go-github-com-ipfs-go-metrics-interface")
+ (version "0.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipfs/go-metrics-interface")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "09xc71175sfnqlizkbw066jagnbag9ihvs240z6g6dm2yx3w5xgy"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/ipfs/go-metrics-interface"))
+ (propagated-inputs
+ (list go-github-com-ipfs-go-cid
+ go-github-com-ipfs-go-datastore
+ go-github-com-multiformats-go-base32
+ go-github-com-multiformats-go-multihash))
+ (home-page "https://github.com/ipfs/go-metrics-interface")
+ ;; XXX: The project neither has no a proper description, nor a README, see
+ ;; <https://github.com/ipfs/go-metrics-interface/issues/1>.
+ (synopsis "Metrics interface for IPFS")
+ (description
+ "Metrics interface for IPFS (Kubo).")
+ (license license:expat)))
+
+(define-public go-github-com-libp2p-go-socket-activation
+ (package
+ (name "go-github-com-libp2p-go-socket-activation")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libp2p/go-socket-activation")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1cqxzmjfg7838xifs07kigys9icardwlj1wl426mzgzmbwn6pg5s"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/libp2p/go-socket-activation"))
+ (propagated-inputs
+ (list go-github-com-coreos-go-systemd-v22
+ go-github-com-ipfs-go-log
+ go-github-com-multiformats-go-multiaddr-0.12))
+ (home-page "https://github.com/libp2p/go-socket-activation")
+ (synopsis "Multiaddr backed systemd socket activation")
+ (description
+ "This package provides access to sockets registered by the system's init
+daemon as described in
+@url{http://0pointer.de/blog/projects/socket-activation}.")
+ (license license:expat)))
+
+(define-public go-github-com-whyrusleeping-cbor-gen
+ (package
+ (name "go-github-com-whyrusleeping-cbor-gen")
+ (version "v0.0.0-20230818171029-f91ae536ca25")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/whyrusleeping/cbor-gen")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "08by7pqh4fcwf2va01iif75yqkfssi6d48334404mmv9jmhzim60"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/whyrusleeping/cbor-gen"))
+ (propagated-inputs
+ (list go-github-com-ipfs-go-cid
+ go-github-com-google-go-cmp
+ go-golang-org-x-xerrors))
+ (home-page "https://github.com/whyrusleeping/cbor-gen")
+ (synopsis "Codegen for CBOR codecs on the specified types")
+ (description
+ "Basic utilities to generate fast path @url{https://cbor.io/, CBOR} codecs for
+types.")
+ (license license:expat)))
+
+;; XXX: No updates for 4 years, and depends on dated Golang modules which
+;; require go-1.16 to compile, see
+;; <https://github.com/whyrusleeping/gx/issues/247>.
(define-public gx
(package
(name "gx")
@@ -507,6 +870,9 @@ powerful and simple.")
'(#:unpack-path "github.com/whyrusleeping/gx"
#:import-path "github.com/whyrusleeping/gx/gxutil"))))
+;; XXX: No updates for 4 years, and depends on dated Golang modules which
+;; require go-1.16 to compile, see
+;; <https://github.com/whyrusleeping/gx-go/issues/65>.
(define-public gx-go
(package
(name "gx-go")
@@ -586,6 +952,7 @@ written in Go.")
"vendor/github.com/docker"
"vendor/github.com/dustin"
"vendor/github.com/elgris"
+ "vendor/github.com/facebookgo"
"vendor/github.com/felixge"
"vendor/github.com/flynn"
"vendor/github.com/francoispqt"
@@ -609,13 +976,19 @@ written in Go.")
"vendor/github.com/ipfs/go-detect-race"
"vendor/github.com/ipfs/go-ipfs-delay"
"vendor/github.com/ipfs/go-ipfs-util"
+ "vendor/github.com/ipfs/go-ipld-cbor"
"vendor/github.com/ipfs/go-ipld-format"
+ "vendor/github.com/ipfs/go-ipld-git"
+ "vendor/github.com/ipfs/go-ipld-legacy"
"vendor/github.com/ipfs/go-log"
+ "vendor/github.com/ipfs/go-metrics-interface"
+ "vendor/github.com/ipld/go-codec-dagpb"
"vendor/github.com/ipld/go-ipld-prime"
"vendor/github.com/jackpal"
"vendor/github.com/jbenet"
"vendor/github.com/julienschmidt"
"vendor/github.com/klauspost"
+ "vendor/github.com/libp2p/go-socket-activation"
"vendor/github.com/mattn"
"vendor/github.com/mgutz"
"vendor/github.com/miekg"
@@ -638,7 +1011,7 @@ written in Go.")
"vendor/github.com/stretchr"
"vendor/github.com/syndtr"
"vendor/github.com/tidwall"
- "vendor/github.com/whyrusleeping/go-sysinfo"
+ "vendor/github.com/whyrusleeping"
"vendor/go.uber.org"
"vendor/golang.org"
"vendor/gopkg.in"
@@ -648,7 +1021,6 @@ written in Go.")
(list
#:unpack-path "github.com/ipfs/kubo"
#:import-path "github.com/ipfs/kubo/cmd/ipfs"
- #:go go-1.21
#:phases
#~(modify-phases %standard-phases
;; https://github.com/ipfs/kubo/blob/master/docs/command-completion.md
@@ -679,7 +1051,7 @@ written in Go.")
go-github-com-coreos-go-systemd-v22
go-github-com-dustin-go-humanize
go-github-com-elgris-jsondiff
- ;;go-github-com-facebookgo-atomicfile
+ go-github-com-facebookgo-atomicfile
go-github-com-fsnotify-fsnotify
go-github-com-google-uuid
go-github-com-hashicorp-go-multierror
@@ -688,26 +1060,27 @@ written in Go.")
go-github-com-ipfs-go-cid
go-github-com-ipfs-go-cidutil
go-github-com-ipfs-go-datastore
+ go-github-com-ipfs-go-detect-race
;;go-github-com-ipfs-go-ds-badger
;;go-github-com-ipfs-go-ds-flatfs
;;go-github-com-ipfs-go-ds-leveldb
;;go-github-com-ipfs-go-ds-measure
;;go-github-com-ipfs-go-fs-lock
;;go-github-com-ipfs-go-ipfs-cmds
- ;;go-github-com-ipfs-go-ipld-cbor
+ go-github-com-ipfs-go-ipld-cbor
go-github-com-ipfs-go-ipld-format
- ;;go-github-com-ipfs-go-ipld-git
- ;;go-github-com-ipfs-go-ipld-legacy
+ go-github-com-ipfs-go-ipld-git
+ go-github-com-ipfs-go-ipld-legacy
go-github-com-ipfs-go-log
go-github-com-ipfs-go-log-v2
- ;;go-github-com-ipfs-go-metrics-interface
+ go-github-com-ipfs-go-metrics-interface
;;go-github-com-ipfs-go-metrics-prometheus
;;go-github-com-ipfs-go-unixfsnode
;;go-github-com-ipfs-shipyard-nopfs
;;go-github-com-ipfs-shipyard-nopfs-ipfs
;;go-github-com-ipld-go-car
;;go-github-com-ipld-go-car-v2
- ;;go-github-com-ipld-go-codec-dagpb
+ go-github-com-ipld-go-codec-dagpb
go-github-com-ipld-go-ipld-prime
go-github-com-jbenet-go-random
go-github-com-jbenet-go-temp-err-catcher
@@ -723,8 +1096,7 @@ written in Go.")
;;go-github-com-libp2p-go-libp2p-record
;;go-github-com-libp2p-go-libp2p-routing-helpers
;;go-github-com-libp2p-go-libp2p-testing
- ;;go-github-com-libp2p-go-socket-activation
- go-github-com-ipfs-go-ipfs-util
+ go-github-com-libp2p-go-socket-activation
go-github-com-mitchellh-go-homedir
go-github-com-multiformats-go-multiaddr-0.12
go-github-com-multiformats-go-multiaddr-dns
@@ -733,13 +1105,13 @@ written in Go.")
go-github-com-multiformats-go-multihash
go-github-com-opentracing-opentracing-go
go-github-com-pbnjay-memory
- go-github-com-pkg-errors
go-github-com-prometheus-client-golang
go-github-com-stretchr-testify
- go-github-com-syndtr-goleveldb-leveldb
+ go-github-com-syndtr-goleveldb
+ go-github-com-tidwall-gjson
go-github-com-tidwall-sjson
go-github-com-whyrusleeping-go-sysinfo
- ;;go-github-com-whyrusleeping-multiaddr-filter
+ go-github-com-whyrusleeping-multiaddr-filter
;;go-go-opencensus-io
;;go-go-opentelemetry-io-contrib-instrumentation-net-http-otelhttp
;;go-go-opentelemetry-io-contrib-propagators-autoprop
@@ -751,12 +1123,11 @@ written in Go.")
go-go-uber-org-multierr
go-go-uber-org-zap
go-golang-org-x-crypto
- go-golang-org-x-exp-2023
+ go-golang-org-x-exp
go-golang-org-x-mod
go-golang-org-x-sync
go-golang-org-x-sys
go-google-golang-org-protobuf
- go-gopkg-in-yaml-v3
;;
;; A list of indirect dependencies required for the vendored
@@ -765,6 +1136,7 @@ written in Go.")
;; available.
;;
go-github-com-alecthomas-units ; github.com/ipfs/boxo
+ go-github-com-cespare-xxhash
go-github-com-docker-go-units ; github.com/containerd/cgroups
go-github-com-felixge-httpsnoop ; go.opentelemetry.io/contrib/instrumentation/net/http/otelhttp
go-github-com-flynn-noise ; github.com/libp2p/go-libp2p
@@ -781,6 +1153,10 @@ written in Go.")
go-github-com-multiformats-go-multiaddr-fmt ; github.com/libp2p/go-libp2p
go-github-com-multiformats-go-multistream ; github.com/libp2p/go-libp2p
go-github-com-quic-go-quic-go ; github.com/libp2p/go-libp2p
+ go-github-com-whyrusleeping-base32 ; github.com/ipfs/boxo
+ go-github-com-whyrusleeping-cbor ; github.com/ipld/go-car
+ go-github-com-whyrusleeping-chunker ; github.com/ipfs/boxo
+ go-github-com-whyrusleeping-go-keyspace ; github.com/libp2p/go-libp2p-kad-dht
go-golang-org-x-oauth2 ; github.com/ipfs/boxo
go-golang-org-x-term ; github.com/ipfs/go-ipfs-cmds
go-golang-org-x-xerrors ; github.com/whyrusleeping/cbor-gen