summaryrefslogtreecommitdiff
path: root/gnu/packages/libffi.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/libffi.scm')
-rw-r--r--gnu/packages/libffi.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/libffi.scm b/gnu/packages/libffi.scm
index 701feeb773..76d699f071 100644
--- a/gnu/packages/libffi.scm
+++ b/gnu/packages/libffi.scm
@@ -43,17 +43,16 @@
(define-public libffi
(package
(name "libffi")
- (version "3.3")
+ (version "3.4.2")
(source (origin
(method url-fetch)
(uri
- (string-append "ftp://sourceware.org/pub/libffi/"
+ (string-append "https://github.com/libffi/libffi/releases"
+ "/download/v" version "/"
name "-" version ".tar.gz"))
(sha256
(base32
- "0mi0cpf8aa40ljjmzxb7im6dbj45bb0kllcd09xgmp834y9agyvj"))
- (patches (search-patches "libffi-3.3-powerpc-fixes.patch"
- "libffi-float128-powerpc64le.patch"))))
+ "081nx7wpzds168jbr59m34n6s3lyiq6r8zggvqxvlslsc4hvf3sl"))))
(build-system gnu-build-system)
(arguments
`(;; Prevent the build system from passing -march and -mtune to the