summaryrefslogtreecommitdiff
path: root/gnu/packages/librewolf.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/librewolf.scm')
-rw-r--r--gnu/packages/librewolf.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/librewolf.scm b/gnu/packages/librewolf.scm
index c84bcaf3ce..45fbb84e4f 100644
--- a/gnu/packages/librewolf.scm
+++ b/gnu/packages/librewolf.scm
@@ -22,6 +22,8 @@
;;; Copyright © 2022 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2023 Tomas Volf <wolf@wolfsden.cz>
;;; Copyright © 2023 Ian Eure <ian@retrospec.tv>
+;;; Copyright © 2024 Remco van 't Veer <remco@remworks.net>
+;;; Copyright © 2024 Ashvith Shetty <ashvithshetty10@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -261,7 +263,10 @@
"--disable-crashreporter"
"--allow-addon-sideload"
"--with-unsigned-addon-scopes=app,system"
- "--disable-eme"
+
+ ;; switch only available on x86, whereas EME
+ ;; is not supported on other targets
+ ,@(if #$(target-x86?) '("--disable-eme") '())
;; Build details
"--disable-debug"
@@ -409,6 +414,7 @@
(setenv "CC" "clang")
(setenv "CXX" "clang++")
(setenv "MOZ_NOSPAM" "1")
+ (setenv "MOZ_APP_REMOTINGNAME" "LibreWolf")
(setenv "MOZ_APP_NAME" "librewolf")
(setenv "MOZBUILD_STATE_PATH"
@@ -622,8 +628,7 @@
(("-NewPrivateWindow")
"-new-private-window")
(("StartupNotify=true")
- "StartupNotify=true
-StartupWMClass=Navigator"))
+ "StartupNotify=true\nStartupWMClass=LibreWolf"))
(copy-file desktop-file "librewolf.desktop")
(install-file "librewolf.desktop" applications))))
(add-after 'install-desktop-entry 'install-icons