summaryrefslogtreecommitdiff
path: root/gnu/packages/libusb.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/libusb.scm')
-rw-r--r--gnu/packages/libusb.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/libusb.scm b/gnu/packages/libusb.scm
index 3842f3fead..7b13d98d95 100644
--- a/gnu/packages/libusb.scm
+++ b/gnu/packages/libusb.scm
@@ -128,7 +128,7 @@ version of libusb to run with newer libusb.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/usb4java/libusb4java.git")
+ (url "https://github.com/usb4java/libusb4java")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -166,12 +166,14 @@ with usb4java.")
(name "java-usb4java")
(version "1.2.0")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/usb4java/usb4java/"
- "archive/usb4java-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/usb4java/usb4java")
+ (commit (string-append "usb4java-" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0gzpsnzwgsdyra3smq288yvxnwrgvdwxr6g8jbknnsk56kv6wc34"))))
+ "0aip6k24czz5g58qwb963mpick0b6ks774drfpdd8gcdvj9iv87j"))))
(build-system ant-build-system)
(arguments
`(#:jar-name "usb4java.jar"
@@ -354,7 +356,7 @@ I2C and SPI devices attached to the USB Hub.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/libimobiledevice/libplist.git")
+ (url "https://github.com/libimobiledevice/libplist")
(commit version)))
(file-name (git-file-name name version))
(sha256
@@ -594,7 +596,7 @@ devices.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/libusb/hidapi.git")
+ (url "https://github.com/libusb/hidapi")
(commit (string-append "hidapi-" version))))
(file-name (git-file-name name version))
(sha256