summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm202
1 files changed, 142 insertions, 60 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1fde34b251..a2a3601246 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -81,6 +81,7 @@
;;; Copyright © 2024 Gabriel Wicki <gabriel@erlikon.ch>
;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2024 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -509,20 +510,37 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(sha256 hash)))
+;; The current "mainline" kernel.
+
+(define-public linux-libre-6.10-version "6.10.2")
+(define-public linux-libre-6.10-gnu-revision "gnu")
+(define deblob-scripts-6.10
+ (linux-libre-deblob-scripts
+ linux-libre-6.10-version
+ linux-libre-6.10-gnu-revision
+ (base32 "1j43v1z4g1f681wvna2dh9vxaz0pgni0wchbh1xhyhhfcqbm1f47")
+ (base32 "00bx8g1ijswi9zypmwqhxsk9fdkzmarxdbdx5h6gpn7z4d1qly3j")))
+(define-public linux-libre-6.10-pristine-source
+ (let ((version linux-libre-6.10-version)
+ (hash (base32 "0w4vsb0c8bp34j90l89qms50nx6r6mmyf23jbvyar9fbv46m5n3k")))
+ (make-linux-libre-source version
+ (%upstream-linux-source version hash)
+ deblob-scripts-6.10)))
+
;; The current "stable" kernels. That is, the most recently released major
;; versions that are still supported upstream.
-(define-public linux-libre-6.9-version "6.9.7")
+(define-public linux-libre-6.9-version "6.9.12")
(define-public linux-libre-6.9-gnu-revision "gnu")
(define deblob-scripts-6.9
(linux-libre-deblob-scripts
linux-libre-6.9-version
linux-libre-6.9-gnu-revision
(base32 "1izfwmk0mxikx3bblcwiyrxdd4bg9v0jsph3i8gvrpjb7kw0lhna")
- (base32 "0b8hsr0s4f3hps27bmd5qj1yknhd73q4zplr4v3lmq7sr57mgly6")))
+ (base32 "18vfz1fx4vjssfh1w7aqfjf91y2g34a2qnzbl9pyawa7qnqxq33n")))
(define-public linux-libre-6.9-pristine-source
(let ((version linux-libre-6.9-version)
- (hash (base32 "1y01w26sas7pl24l09yczdr8mzzy2nadykz1wmhx9ygfj76qixg4")))
+ (hash (base32 "08ngskni7d9wi93vlwcmbdg7sb2jl1drhhzn62k9nsrg1r7crrss")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-6.9)))
@@ -532,67 +550,67 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
;; Here are the support timelines:
;; <https://www.kernel.org/category/releases.html>
-(define-public linux-libre-6.6-version "6.6.36")
+(define-public linux-libre-6.6-version "6.6.43")
(define-public linux-libre-6.6-gnu-revision "gnu")
(define deblob-scripts-6.6
(linux-libre-deblob-scripts
linux-libre-6.6-version
linux-libre-6.6-gnu-revision
(base32 "1a28pdl645bj4d8gac71dmwmll6a2kgd3k7gkpfvi94yqkzd9r2z")
- (base32 "05ypqx1sz54yhb8jyxphvg5pwgb2cnzb4zqqaiyyywpqsrnya9kq")))
+ (base32 "15xb4miirfmi1khlq4zhb8zmmh82f41jhsfbsfpv8v98yfka2nmb")))
(define-public linux-libre-6.6-pristine-source
(let ((version linux-libre-6.6-version)
- (hash (base32 "1mfdw2prjb54r19y22sm37q8spnk6lyk162ima7gps1pnwl6hrxr")))
+ (hash (base32 "0pha226h5011kl5r2iiddxi0rib3xraslmcdjjnil2kq38d3pn0a")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-6.6)))
-(define-public linux-libre-6.1-version "6.1.96")
+(define-public linux-libre-6.1-version "6.1.102")
(define-public linux-libre-6.1-gnu-revision "gnu")
(define deblob-scripts-6.1
(linux-libre-deblob-scripts
linux-libre-6.1-version
linux-libre-6.1-gnu-revision
(base32 "1sf80f2i4vf888xjcn84ymn4w5ynn30ib9033zwmv7f09yvfhapy")
- (base32 "0nq8b6rnn031wl0qz7ahyfs3hcb0qsr7hzdmxi2g33ycsm9955lk")))
+ (base32 "11jbnj0d3262grf9vkn0668kvfxifxw98ccvn81wkaykll01k5nx")))
(define-public linux-libre-6.1-pristine-source
(let ((version linux-libre-6.1-version)
- (hash (base32 "1ab290vm6h8vj1qi1qhxzh9kc6dbgpkwybcwzw1aprz5kl3cjxry")))
+ (hash (base32 "1v4p4i8pfg4i6v90dr7m65npkxjnqv3fxcj8zs3pbb8y84xzk98v")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-6.1)))
-(define-public linux-libre-5.15-version "5.15.161")
+(define-public linux-libre-5.15-version "5.15.164")
(define-public linux-libre-5.15-gnu-revision "gnu")
(define deblob-scripts-5.15
(linux-libre-deblob-scripts
linux-libre-5.15-version
linux-libre-5.15-gnu-revision
(base32 "18ac30kxg2mf2f6gk3p935hzhz2qs110jy4xwk21kblnnkskbxj8")
- (base32 "121shkzgixmywa19xx5f2yxg1primarpg4bxin3jyw0214xbfh2n")))
+ (base32 "1l8dhfby3qx8vs8fq6yybixzrghbh03wflzwly4rq08wabcr87z8")))
(define-public linux-libre-5.15-pristine-source
(let ((version linux-libre-5.15-version)
- (hash (base32 "0k277hz6nq62v0xfc1n2hc69cyvmnxpl0qcbszinajywh23gfafn")))
+ (hash (base32 "11linb9jzarr8wz0vim3g9gkhi5ldqm82bkpl5xs9f34xpx9hq7c")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-5.15)))
-(define-public linux-libre-5.10-version "5.10.220")
+(define-public linux-libre-5.10-version "5.10.223")
(define-public linux-libre-5.10-gnu-revision "gnu1")
(define deblob-scripts-5.10
(linux-libre-deblob-scripts
linux-libre-5.10-version
linux-libre-5.10-gnu-revision
(base32 "1b33rkn32b923025iiz4xzxiy8y5ii9j5qk4021mg575890rl4ch")
- (base32 "12csh2zyjrqzgqcv799gv8h4xaw1irxh2zqddn4jqp5p7psx4j5k")))
+ (base32 "1isiih0laz4wbivsg0pcvlgrflq3lv10fakv9lvg2b4s0yd9ybdn")))
(define-public linux-libre-5.10-pristine-source
(let ((version linux-libre-5.10-version)
- (hash (base32 "16z1xqm7djm8pl15s5wvgc4pwq81gydcf00jpxfplw794kwszhvw")))
+ (hash (base32 "189b3yl4lsjzh6qpza0phj8hgsvnyh38cgrd70rnqw3rddmdh2fa")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-5.10)))
-(define-public linux-libre-5.4-version "5.4.278")
+(define-public linux-libre-5.4-version "5.4.281")
(define-public linux-libre-5.4-gnu-revision "gnu1")
(define deblob-scripts-5.4
(linux-libre-deblob-scripts
@@ -602,12 +620,12 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(base32 "0x0xg0fcykpd117x3q0gim8jilhx922ashhckjvafxv2gk2zzjhj")))
(define-public linux-libre-5.4-pristine-source
(let ((version linux-libre-5.4-version)
- (hash (base32 "1245zf7vk2fyprw9fspljqy9wlzma9bayri7xx2g8iam2430d875")))
+ (hash (base32 "1ckja83km101h2dwlp86xrnnlzdzvjly48iywhy53xric3kw7824")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-5.4)))
-(define-public linux-libre-4.19-version "4.19.316")
+(define-public linux-libre-4.19-version "4.19.319")
(define-public linux-libre-4.19-gnu-revision "gnu1")
(define deblob-scripts-4.19
(linux-libre-deblob-scripts
@@ -617,7 +635,7 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(base32 "0fgkp3v7qgqpn7l1987xcwwlrmwsbscqnxfv06p8nkavrhymrv3c")))
(define-public linux-libre-4.19-pristine-source
(let ((version linux-libre-4.19-version)
- (hash (base32 "0lmyhwr4la7kvim7jqdi29scjkvqp9crpvdbhpb4j8d7mj5kgzz4")))
+ (hash (base32 "0c7bhb31hpbbw1is1ykppk9lm0x025yyd4hrmlg1s6yg75rxqkal")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-4.19)))
@@ -650,6 +668,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(patches (append (origin-patches source)
patches))))
+(define-public linux-libre-6.10-source
+ (source-with-patches linux-libre-6.10-pristine-source
+ (list %boot-logo-patch
+ %linux-libre-arm-export-__sync_icache_dcache-patch)))
+
(define-public linux-libre-6.9-source
(source-with-patches linux-libre-6.9-pristine-source
(list %boot-logo-patch
@@ -770,6 +793,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(description "Headers of the Linux-Libre kernel.")
(license license:gpl2)))
+(define-public linux-libre-headers-6.10
+ (make-linux-libre-headers* linux-libre-6.10-version
+ linux-libre-6.10-gnu-revision
+ linux-libre-6.10-source))
+
(define-public linux-libre-headers-6.9
(make-linux-libre-headers* linux-libre-6.9-version
linux-libre-6.9-gnu-revision
@@ -1146,6 +1174,14 @@ Linux kernel. It has been modified to remove all non-free binary blobs.")
(define-public linux-libre-source linux-libre-6.9-source)
(define-public linux-libre linux-libre-6.9)
+(define-public linux-libre-6.10
+ (make-linux-libre* linux-libre-6.10-version
+ linux-libre-6.10-gnu-revision
+ linux-libre-6.10-source
+ '("x86_64-linux" "i686-linux" "armhf-linux"
+ "aarch64-linux" "powerpc64le-linux" "riscv64-linux")
+ #:configuration-file kernel-config))
+
(define-public linux-libre-6.6
(make-linux-libre* linux-libre-6.6-version
linux-libre-6.6-gnu-revision
@@ -1300,6 +1336,34 @@ Linux kernel. It has been modified to remove all non-free binary blobs.")
("CONFIG_SND_SOC_ES8316" . m))
(default-extra-linux-options linux-libre-version))))
+(define-public linux-libre-lts-arm64-generic
+ (make-linux-libre* linux-libre-lts-version
+ linux-libre-lts-gnu-revision
+ linux-libre-lts-source
+ '("aarch64-linux")
+ #:defconfig "defconfig"
+ #:extra-version "arm64-generic"
+ #:extra-options
+ (append
+ `(;; Provide support for ath9k wireless
+ ("CONFIG_ATH9K_HTC" . m)
+ ;; needed to fix the RTC on rockchip platforms
+ ("CONFIG_RTC_DRV_RK808" . #t)
+ ;; Pinebook display, battery, charger and usb
+ ("CONFIG_DRM_ANALOGIX_ANX6345" . m)
+ ("CONFIG_CHARGER_AXP20X" . m)
+ ("CONFIG_INPUT_AXP20X_PEK" . m)
+ ("CONFIG_CHARGER_AXP20X" . m)
+ ("CONFIG_BATTERY_AXP20X" . m)
+ ("CONFIG_PINCTRL_AXP209" . m)
+ ("CONFIG_AXP20X_POWER" . m)
+ ("CONFIG_AXP20X_ADC" . m)
+ ;; Pinebook PRO battery and sound support
+ ("CONFIG_BATTERY_CW2015" . m)
+ ("CONFIG_CHARGER_GPIO" . m)
+ ("CONFIG_SND_SOC_ES8316" . m))
+ (default-extra-linux-options linux-libre-lts-version))))
+
(define-public linux-libre-arm64-generic-5.10
(make-linux-libre* linux-libre-5.10-version
linux-libre-5.10-gnu-revision
@@ -1547,20 +1611,20 @@ and the notification, WiFi, and Bluetooth LED.")
(define-public tuxedo-keyboard
(package
(name "tuxedo-keyboard")
- (version "3.2.10")
+ (version "4.6.1")
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/tuxedocomputers/tuxedo-keyboard.git")
+ (url "https://gitlab.com/tuxedocomputers/development/packages/tuxedo-drivers.git")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1kbspr1vs6jpfsb3c4hbw2d8y06v2a3m4c27rhggkfksf4x82gip"))))
+ (base32 "0hbqk28qi3yxw0g3j8yarsplyigpd8kgliri7c48d3yhliiiz7l5"))))
(build-system linux-module-build-system)
(arguments
(list #:tests? #f)) ; no test suite
- (home-page "https://github.com/tuxedocomputers/tuxedo-keyboard")
+ (home-page "https://gitlab.com/tuxedocomputers/development/packages/tuxedo-drivers")
(synopsis "Linux kernel modules to control keyboard on most Tuxedo computers")
(description
"This package provides the @code{tuxedo_keyboard}, @code{tuxedo_io},
@@ -1747,7 +1811,7 @@ graphics card on Optimus laptops.")
(define-public ddcci-driver-linux
(package
(name "ddcci-driver-linux")
- (version "0.4.4")
+ (version "0.4.5")
(source
(origin
(method git-fetch)
@@ -1757,8 +1821,7 @@ graphics card on Optimus laptops.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "19vi7dk4jv5wm18cznz4lj2fb1c7m7j3ig62x4a6qy9djxf9z472"))
- (patches (search-patches "ddcci-driver-linux-linux-6.8.patch"))))
+ (base32 "0j2bgzadrbcyf3k4zplv7p5yqb9pw2ca6wzkqjhhidaah2722vlf"))))
(build-system linux-module-build-system)
(arguments
(list #:tests? #f ; no tests
@@ -2381,7 +2444,7 @@ partitions. Write functionality is also provided but check the README.")
(define-public dwarves
(package
(name "dwarves")
- (version "1.26")
+ (version "1.27")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2390,7 +2453,7 @@ partitions. Write functionality is also provided but check the README.")
(file-name (git-file-name name version))
(sha256
(base32
- "0xfq0r3whc3dk922ss8i5vwyfcqhgc95dy27mm69j5niy7i5kzrd"))
+ "0qwc3772az1h3c78pyswawyvyq9spj5s1prj7ckfij9nazp3a007"))
(patches
(search-patches "dwarves-threading-reproducibility.patch"))))
(build-system cmake-build-system)
@@ -5323,7 +5386,7 @@ thanks to the use of namespaces.")
(substitute* (find-files "libexec/cli" "\\.exec$")
(("\\$SINGULARITY_libexecdir/singularity/bin/([a-z]+)-suid"
_ program)
- (string-append "/run/setuid-programs/singularity-"
+ (string-append "/run/privileged/bin/singularity-"
program "-helper")))
;; These squashfs mount options are apparently no longer
@@ -7171,7 +7234,7 @@ not as a replacement for it.")
(define-public hotspot
(package
(name "hotspot")
- (version "1.5.0")
+ (version "1.5.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -7183,7 +7246,7 @@ not as a replacement for it.")
(file-name (git-file-name name version))
(sha256
(base32
- "17m96h0iahfjhbsa9flmsmbczvliy34vqvayzyh8bhldd8yh768l"))))
+ "04k2rvf2lgi8hp7dzqzn65fcd2lsiylwr04d44q75j0wvgbjjv1v"))))
(build-system qt-build-system)
(arguments
(list
@@ -7191,7 +7254,9 @@ not as a replacement for it.")
;; installed to a custom prefix and the build fails with "file cannot
;; create directory: /polkit-1/actions. Maybe need administrative"
;; (see: https://bugs.kde.org/show_bug.cgi?id=363678).
- #:configure-flags #~(list "-DINSTALL_KAUTH_HELPER=OFF")
+ #:configure-flags #~(list "-DINSTALL_KAUTH_HELPER=OFF"
+ "-DQT6_BUILD=ON")
+ #:qtbase qtbase
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'patch-perfparser
@@ -7262,6 +7327,7 @@ not as a replacement for it.")
kcoreaddons
kddockwidgets
kgraphviewer
+ ki18n
kio
kiconthemes
kitemmodels
@@ -7272,12 +7338,8 @@ not as a replacement for it.")
kwindowsystem
libxkbcommon
perf
- qcustomplot
- qtbase-5
- qtdeclarative-5
- qtquickcontrols2-5
- qtsvg-5
- qtx11extras
+ qtdeclarative
+ qtsvg
solid
threadweaver
`(,zstd "lib"))
@@ -8856,7 +8918,7 @@ comparing system environments.")
(define-public libfabric
(package
(name "libfabric")
- (version "1.19.0")
+ (version "1.22.0")
(source
(origin
(method url-fetch)
@@ -8864,14 +8926,20 @@ comparing system environments.")
(string-append "https://github.com/ofiwg/libfabric/releases/download/v"
version "/libfabric-" version ".tar.bz2"))
(sha256
- (base32 "17pg0fb4fa77r1bmp0xk535m8n8fadpfdg93cb280ghhx55pck7i"))))
+ (base32 "1znmw83rmippv0fwz0x7lgylfk17dr9ckll8lrm4z7kclspnqpj8"))))
(build-system gnu-build-system)
(inputs `(("rdma-core" ,rdma-core)
,@(match (%current-system)
((member (package-supported-systems psm))
`(("psm" ,psm)))
(_ `()))
+ ("psm2" ,psm2)
("libnl" ,libnl)))
+ (arguments
+ (list #:configure-flags
+ #~(list "--enable-psm2"
+ "--enable-efa"
+ "--enable-verbs")))
(home-page "https://ofiwg.github.io/libfabric/")
(synopsis "Open Fabric Interfaces")
(description
@@ -9262,31 +9330,45 @@ nfnetlink_queue, nfnetlink_conntrack) and their respective users and/or
management tools in userspace.")
(license license:gpl2)))
-(define-public go-netlink
+(define-public go-github-com-vishvananda-netlink
(package
- (name "go-netlink")
- (version "1.0.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/vishvananda/netlink")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0hpzghf1a4cwawzhkiwdzin80h6hd09fskl77d5ppgc084yvj8x0"))))
+ (name "go-github-com-vishvananda-netlink")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vishvananda/netlink")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1vhl30p1gx636a088ls4h6a0l8jjyfvz79fr5w0qzdrg4qg9h08h"))))
(build-system go-build-system)
(arguments
- `(#:tests? #f ; Tests depend on specific kernel modules.
- #:import-path "github.com/vishvananda/netlink"))
- (native-inputs
- (list go-golang-org-x-sys go-netns))
+ (list
+ ;; The tests are unsupported on all architectures except x86_64-linux:
+ ;; cannot use 0xabcdef99 (untyped int constant 2882400153) as int value
+ ;; in struct literal (overflows)
+ #:tests? (and (not (%current-target-system)) (target-x86-64?))
+ #:import-path "github.com/vishvananda/netlink"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda* (#:key tests? unpack-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" unpack-path)
+ (substitute* (find-files "." "\\_test.go$")
+ ;; Disable tests requiring root access.
+ (("TestNetNsIdByFd") "OffTestNetNsIdByFd")
+ (("TestNetNsIdByPid") "OffTestNetNsIdByPid"))))))))
+ (propagated-inputs
+ (list go-golang-org-x-sys go-github-com-vishvananda-netns))
(home-page "https://github.com/vishvananda/netlink")
(synopsis "Simple netlink library for Go")
- (description "The netlink package provides a simple netlink library for
-Go. Netlink is the interface a user-space program in Linux uses to
-communicate with the kernel. It can be used to add and remove interfaces, set
-IP addresses and routes, and configure IPsec.")
+ (description
+ "The netlink package provides a simple netlink library for Go. Netlink
+is the interface a user-space program in Linux uses to communicate with the
+kernel. It can be used to add and remove interfaces, set IP addresses and
+routes, and configure IPsec.")
(license license:asl2.0)))
(define-public libinih