summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm33
1 files changed, 16 insertions, 17 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 03d77014ac..c6fce0992f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2379,23 +2379,22 @@ slabtop, tload, top, vmstat, w, watch and sysctl.")
(build-system gnu-build-system)
(outputs (list "out" "python"))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'bootstrap 'patch-bootstrap-scripts
- (lambda _
- (substitute* "usbhid-dump/bootstrap"
- (("/bin/sh") (which "sh")))))
- (add-after 'install 'separate-python-output
- ;; Separating one Python script shaves more than 106 MiB from :out.
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (out:python (assoc-ref outputs "python")))
- (for-each (lambda (file)
- (let ((old (string-append out "/" file))
- (new (string-append out:python "/" file)))
- (mkdir-p (dirname new))
- (rename-file old new)))
- (list "bin/lsusb.py"))))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'bootstrap 'patch-bootstrap-scripts
+ (lambda _
+ (substitute* "usbhid-dump/bootstrap"
+ (("/bin/sh") (which "sh")))))
+ (add-after 'install 'separate-python-output
+ ;; Separating one Python script shaves more than 106 MiB from :out.
+ (lambda _
+ (for-each (lambda (file)
+ (let ((old (string-append #$output "/" file))
+ (new (string-append #$output:python "/" file)))
+ (mkdir-p (dirname new))
+ (rename-file old new)))
+ (list "bin/lsusb.py")))))))
(inputs
(list eudev libusb python))
(native-inputs