summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm43
1 files changed, 35 insertions, 8 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e50be451b2..867cee0763 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -44,7 +44,7 @@
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
-;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020, 2022 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Anders Thuné <asse.97@gmail.com>
;;; Copyright © 2020, 2021 Greg Hogan <code@greghogan.com>
;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
@@ -1469,7 +1469,7 @@ supported under @file{/sys/class/backlight/}.")
(define-public v4l2loopback-linux-module
(package
(name "v4l2loopback-linux-module")
- (version "0.12.5")
+ (version "0.12.7")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1478,7 +1478,7 @@ supported under @file{/sys/class/backlight/}.")
(file-name (git-file-name name version))
(sha256
(base32
- "1qi4l6yam8nrlmc3zwkrz9vph0xsj1cgmkqci4652mbpbzigg7vn"))))
+ "1yghxl7gjr1zxi3a1kiz6d7yh68z64xayzm925zan4jqhrwv1h68"))))
(build-system linux-module-build-system)
(arguments
(list #:tests? #f)) ; no test suite
@@ -8695,11 +8695,11 @@ of Linux application development.")
(base32
"066g4ri2k8pdflclvr2919f6x98gmqrqyj1xyiingw2nn2pwgcf1"))))
(arguments
- '(#:configure-flags
- (list (string-append "-Dudevrulesdir=" (assoc-ref %outputs "out")
- "/lib/udev/rules.d")
- "-Dsystemd=disabled"
- "-Dsession-managers=[]")))
+ (list
+ #:configure-flags
+ #~(list (string-append "-Dudevrulesdir=" #$output "/lib/udev/rules.d")
+ "-Dsystemd=disabled"
+ "-Dsession-managers=[]")))
(inputs (modify-inputs (package-inputs pipewire)
(prepend avahi
bluez
@@ -9331,3 +9331,30 @@ desktop.")
directly from the kernel device and prints a device description and the events
with the value and the symbolic name.")
(license license:gpl2+)))
+
+(define-public tp-smapi-module
+ (package
+ (name "tp-smapi-module")
+ (version "0.43")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/linux-thinkpad/tp_smapi")
+ (commit (string-append "tp-smapi/" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1rjb0njckczc2mj05cagvj0lkyvmyk6bw7wkiinv81lw8m90g77g"))))
+ (build-system linux-module-build-system)
+ (arguments
+ `(#:tests? #f)) ;there are none.
+ (home-page "https://github.com/linux-thinkpad/tp_smapi")
+ (synopsis
+ "Linux Kernel module exposing features of ThinkPad hardware")
+ (description
+ "This package provides a Linux Kernel module that allows to control
+battery charging of specific ThinkPad laptops. It also includes an improved
+version of the HDAPS driver. The underlying hardware interfaces are
+@acronym{SMAPI, System Management Application Program Interface} and direct
+access to the embedded controller.")
+ (license license:gpl2+)))