summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm43
1 files changed, 40 insertions, 3 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 06b4825570..4daf7afd84 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -9995,8 +9995,8 @@ implementation specific equivalent.")
(sbcl-package->ecl-package sbcl-trivial-macroexpand-all))
(define-public sbcl-serapeum
- (let ((commit "47217ab69f76673db7e1fa65665ab804fb46d974")
- (revision "11"))
+ (let ((commit "c08442a9757b7fa30ac345cb040e1642f97f6b78")
+ (revision "12"))
(package
(name "sbcl-serapeum")
(version (git-version "0.0.0" revision commit))
@@ -10009,7 +10009,7 @@ implementation specific equivalent.")
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "1mr868z1za6vfhb7gq3j7c1rb606gqfzschxdy7wcqx5xv3ndgpa"))))
+ (base32 "1sabd048agvgv7bhbw126rci9hf45fk08zhghcv6an2h6xwmc3qv"))))
(build-system asdf-build-system/sbcl)
(inputs
(list sbcl-alexandria
@@ -19190,6 +19190,43 @@ Lisp.")
(define-public cl-percent-encoding
(sbcl-package->cl-source-package sbcl-percent-encoding))
+(define-public sbcl-machine-state
+ (let ((commit "afa7392bc5dcb689cd170bcca765fb6ce6e4efc5")
+ (revision "1"))
+ (package
+ (name "sbcl-machine-state")
+ (version (git-version "1.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Shinmera/machine-state")
+ (commit commit)))
+ (file-name (git-file-name "machine-state" version))
+ (sha256
+ (base32 "1b897wj06cnalzf5nl6rif1skpa79rzc9a562x1bdhvanhsp7hwa"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ (list sbcl-bordeaux-threads
+ sbcl-cffi
+ sbcl-cl-opengl
+ sbcl-documentation-utils))
+ (arguments
+ '(#:tests? #f ; No tests.
+ #:asd-systems '("machine-state" "machine-state/opengl")))
+ (home-page "https://notabug.org/cage/cl-mount-info.git")
+ (synopsis "Retrieve machine state information about CPU time, memory usage and more")
+ (description
+ "This library implements various functions to access status information
+about the machine, process, etc.")
+ (license license:zlib))))
+
+(define-public ecl-machine-state
+ (sbcl-package->ecl-package sbcl-machine-state))
+
+(define-public cl-machine-state
+ (sbcl-package->cl-source-package sbcl-machine-state))
+
(define-public sbcl-cl-mount-info
(let ((commit "2024f5037a7f63db3e3587dc9972cd7b9318f06b")
(revision "1"))