summaryrefslogtreecommitdiff
path: root/gnu/packages/lxde.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/lxde.scm')
-rw-r--r--gnu/packages/lxde.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index 9fcd6e1414..e840f1c969 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -139,7 +139,8 @@ able to change themes, icons, and fonts used by GTK+ applications.")
"04n3vgh3ix12p8jfs4w0dyfq3anbjy33h7g53wbbqqc0f74xyplb"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
+ `(#:configure-flags (list "--enable-gtk3")
+ #:phases
(modify-phases %standard-phases
(add-after 'unpack 'xrandr-absolutely
;; lxrandr is useless without xrandr and gives an unhelpful error
@@ -147,9 +148,8 @@ able to change themes, icons, and fonts used by GTK+ applications.")
(lambda* (#:key input #:allow-other-keys)
(substitute* "src/lxrandr.c"
(("(\"|')xrandr\"" _ match)
- (string-append match (which "xrandr") "\"")))
- #t)))))
- (inputs (list gtk+-2 xrandr))
+ (string-append match (which "xrandr") "\""))))))))
+ (inputs (list gtk+ xrandr))
(native-inputs (list intltool pkg-config))
(synopsis "LXDE monitor configuration tool")
(description "LXRandR is a very basic monitor configuration tool. It