summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 73026012a9..be458a2d92 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -53,6 +53,7 @@
;;; Copyright © 2022 ( <paren@disroot.org>
;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
;;; Copyright © 2023 Arjan Adriaanse <arjan@adriaan.se>
+;;; Copyright © 2023 Wilko Meyer <w@wmeyer.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1885,7 +1886,7 @@ delivery.")
(define-public exim
(package
(name "exim")
- (version "4.96")
+ (version "4.96.1")
(source
(origin
(method url-fetch)
@@ -1899,7 +1900,7 @@ delivery.")
(string-append "https://ftp.exim.org/pub/exim/exim4/old/"
file-name))))
(sha256
- (base32 "18ziihkpa23lybm7m2l9wp2farxw0bd5ng7xm9ylgcrfgf95d6i9"))))
+ (base32 "0g83cxkq3znh5b3r2a3990qxysw7d2l71jwcxaxzvq8pqdahgb4k"))))
(build-system gnu-build-system)
(arguments
(list #:phases
@@ -2228,6 +2229,16 @@ hashing scheme (such as scrypt) plug-in for @code{Dovecot}.")
;; Likely to be included in next version
(search-patches "isync-openssl3-fix.patch"))))
(build-system gnu-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'substitute-openssl-path
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (substitute* (string-append #$output "/bin/mbsync-get-cert")
+ (("openssl s_client")
+ (string-append (search-input-file inputs "/bin/openssl")
+ " s_client"))))))))
(native-inputs
(list perl))
(inputs