summaryrefslogtreecommitdiff
path: root/gnu/packages/markup.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/markup.scm')
-rw-r--r--gnu/packages/markup.scm100
1 files changed, 50 insertions, 50 deletions
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index ad2d74f742..4a9a382104 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;; Copyright © 2022 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -125,39 +126,39 @@ convert it to structurally valid XHTML (or HTML).")
"See License.text in the distribution."))))
(define-public lowdown
- (let ((commit "1de10c1d71bfb4348ae0beaec8b1547d5e114969")
- (revision "1"))
- (package
- (name "lowdown")
- (version (git-version "0.10.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/kristapsdz/lowdown")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1wh07nkiihvp1m79sj4qlnqklnn0rfp3hwls8sqcp0bfd96wpa1h"))))
- (build-system gnu-build-system)
- (arguments
- (list
- #:test-target "regress"
- #:phases
- #~(modify-phases %standard-phases
- (replace 'configure
- (lambda _
- (invoke "./configure"
- (string-append "PREFIX=" #$output)
- (string-append "MANDIR=" #$output "/share/man")))))
- #:make-flags #~(list "CFLAGS=-fPIC")))
- (native-inputs
- (list which))
- (home-page "https://kristaps.bsd.lv/lowdown/")
- (synopsis "Simple Markdown translator")
- (description "Lowdown is a Markdown translator producing HTML5,
-roff documents in the ms and man formats, LaTeX, gemini, and terminal output.")
- (license license:isc))))
+ (package
+ (name "lowdown")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://kristaps.bsd.lv/lowdown/snapshots/lowdown-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0y88gffrg1zrin0y53j4gbkmpia0r8p0kyklj501wavkqi83j7pk"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:test-target "regress"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (invoke "./configure"
+ (string-append "PREFIX=" #$output)
+ (string-append "MANDIR=" #$output "/share/man"))))
+ (replace 'install
+ (lambda _
+ (invoke "make" "install" "install_libs"))))
+ #:make-flags #~(list "CFLAGS=-fPIC")))
+ (native-inputs
+ (list which))
+ (home-page "https://kristaps.bsd.lv/lowdown/")
+ (synopsis "Simple Markdown translator")
+ (description "Lowdown is a Markdown translator producing HTML5, roff
+documents in the ms and man formats, LaTeX, gemini, and terminal output.")
+ (license license:isc)))
(define-public discount
(package
@@ -391,7 +392,7 @@ CommonMark C library libcmark. It closely follows the original API.")
(package
(inherit cmark)
(name "cmark-gfm")
- (version "0.29.0.gfm.2")
+ (version "0.29.0.gfm.13")
(home-page "https://github.com/github/cmark-gfm")
(source (origin
(method git-fetch)
@@ -399,16 +400,15 @@ CommonMark C library libcmark. It closely follows the original API.")
(file-name (git-file-name name version))
(sha256
(base32
- "0vz6zs3m22k7jzfj4782lahciwfjlbi4m3qz5crsmssip3rwdy7h"))))
+ "1apy9i76rgs0bmgdlpjszv0fpqhlap2s12m68wvnsv8j3fsqc90y"))))
(arguments
- '(#:test-target "test"
- #:phases (modify-phases %standard-phases
- (add-after 'install 'install-config
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- ;; XXX: cmark-gfm-core-extensions.h includes this file.
- (install-file "src/config.h"
- (string-append out "/include"))))))))
+ (list #:test-target "test"
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'install 'install-config
+ (lambda _
+ ;; XXX: cmark-gfm-core-extensions.h includes this file.
+ (install-file "src/config.h"
+ (string-append #$output "/include")))))))
(synopsis "GitHub flavored CommonMark")
(description
"This package is a fork of @code{cmark}, with GitHub-specific Markdown
@@ -429,13 +429,13 @@ additions.")))
(base32 "1jm7lhnzjx4q7gcwlkvsbffcy0zppywyh50d71ami6dnq182vvcc"))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags (list "CC=gcc"
- (string-append "PREFIX="
- (assoc-ref %outputs "out")))
- #:tests? #f ; no tests included
- #:phases
- (modify-phases %standard-phases
- (delete 'configure))))
+ (list #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:tests? #f ; no tests included
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure))))
(home-page "https://github.com/Gottox/smu")
(synopsis "Simple markup")
(description