summaryrefslogtreecommitdiff
path: root/gnu/packages/mastodon.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/mastodon.scm')
-rw-r--r--gnu/packages/mastodon.scm45
1 files changed, 25 insertions, 20 deletions
diff --git a/gnu/packages/mastodon.scm b/gnu/packages/mastodon.scm
index 8a8e2e7786..d6fd1db2b6 100644
--- a/gnu/packages/mastodon.scm
+++ b/gnu/packages/mastodon.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2021 Taiju HIGASHI <higashi@taiju.info>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,6 +25,7 @@
#:use-module (guix build-system meson)
#:use-module (guix build-system python)
#:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages)
#:use-module (gnu packages check)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
@@ -79,15 +81,21 @@ Features include:
(name "tootle")
(version "1.0")
(source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/bleakgrey/tootle")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1nm57239mhdq462an6bnhdlijpijxmjs9mqbyirwxwa048d3n4rm"))))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bleakgrey/tootle")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1nm57239mhdq462an6bnhdlijpijxmjs9mqbyirwxwa048d3n4rm"))
+ (patches
+ (search-patches
+ ;; https://github.com/bleakgrey/tootle/pull/339
+ "tootle-glib-object-naming.patch"
+ ;; https://github.com/bleakgrey/tootle/pull/322
+ "tootle-reason-phrase.patch"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
@@ -97,8 +105,7 @@ Features include:
;; Don't create 'icon-theme.cache'.
(lambda _
(substitute* "meson/post_install.py"
- (("gtk-update-icon-cache") "true"))
- #t))
+ (("gtk-update-icon-cache") "true"))))
(add-after 'unpack 'patch-source
(lambda _
(substitute* "src/Dialogs/NewAccount.vala"
@@ -107,25 +114,23 @@ Features include:
(substitute* "src/Build.vala"
(("(os_name = ).*" _ first) (string-append first "\"GNU\";\n"))
(("(os_ver = ).*" _ first) (string-append first "\"Guix\";\n"))
- (("GLib.Environment.get_os_info.*") "\"unknown\";\n"))
- #t))
+ (("GLib.Environment.get_os_info.*") "\"unknown\";\n"))))
(add-after 'install 'symlink-package
(lambda* (#:key outputs #:allow-other-keys)
(symlink "com.github.bleakgrey.tootle"
- (string-append (assoc-ref outputs "out") "/bin/tootle"))
- #t)))))
+ (string-append (assoc-ref outputs "out")
+ "/bin/tootle")))))))
(native-inputs
- `(("gettext" ,gettext-minimal)
- ("glib:bin" ,glib "bin") ; for glib-compile-resources
- ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
- ("pkg-config" ,pkg-config)))
+ (list gettext-minimal
+ `(,glib "bin") ; for glib-compile-resources
+ gsettings-desktop-schemas pkg-config))
(inputs
(list glib-networking
gtk+
json-glib
libgee
libhandy
- libsoup
+ libsoup-minimal-2
vala
xdg-utils))
(home-page "https://github.com/bleakgrey/tootle")