summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm176
1 files changed, 96 insertions, 80 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index d39292e825..0a9f2ab7fb 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -22,7 +22,7 @@
;;; Copyright © 2017, 2019, 2022 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Dave Love <me@fx@gnu.org>
-;;; Copyright © 2018, 2019, 2020, 2021, 2022 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2018, 2019, 2020, 2021, 2022, 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;; Copyright © 2018 Nadya Voronova <voronovank@gmail.com>
;;; Copyright © 2018 Adam Massmann <massmannak@gmail.com>
@@ -1400,19 +1400,19 @@ in the terminal or with an external viewer.")
(define-public gnuplot
(package
(name "gnuplot")
- (version "5.4.9")
+ (version "6.0.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/gnuplot/gnuplot/"
version "/gnuplot-"
version ".tar.gz"))
(sha256
- (base32 "15vabi30s4ln4vi82csx4nvfms3ik8704rk0prcm9h1xylhs0a53"))))
+ (base32 "16ipf7m2c2v1cldp3kwxbjj6db6bzy0rkrpp4kzhh61a3866cnp8"))))
(build-system gnu-build-system)
(native-inputs
(list pkg-config (texlive-updmap.cfg)))
(inputs
- (list cairo gd lua pango readline))
+ (list cairo gd libcerf lua pango readline))
(arguments
(list #:configure-flags
#~(list "--with-qt=no"
@@ -1459,7 +1459,7 @@ C++ with a C API. It contains a LU and LLt solver, and a few other things.")
(define-public primesieve
(package
(name "primesieve")
- (version "11.1")
+ (version "12.3")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1468,7 +1468,7 @@ C++ with a C API. It contains a LU and LLt solver, and a few other things.")
(file-name (git-file-name name version))
(sha256
(base32
- "0ja3kxvpya7bwrib40hnyahsiiiavf65ppk7i7afvc093b7gg9bg"))))
+ "1lxvs1jgch0zgpa5axx6zlvgab4rmm3lqpbah75072xpj8ndhhld"))))
(build-system cmake-build-system)
(arguments
(list #:configure-flags #~(list "-DBUILD_STATIC_LIBS=off"
@@ -1486,7 +1486,7 @@ C++ with a C API. It contains a LU and LLt solver, and a few other things.")
(define-public cminpack
(package
(name "cminpack")
- (version "1.3.8")
+ (version "1.3.9")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1495,7 +1495,7 @@ C++ with a C API. It contains a LU and LLt solver, and a few other things.")
(file-name (git-file-name name version))
(sha256
(base32
- "1bg0954mwry22izsvikpai16pkfp8srz4z34n267bhkmrvvb0zgy"))))
+ "05cjb54in7kks70rrnmvczwkg4nsxhwyf23abxqdj143zwbz4yyr"))))
(build-system cmake-build-system)
(arguments
(list #:configure-flags #~(list "-DBUILD_SHARED_LIBS=ON")))
@@ -1814,7 +1814,7 @@ extremely large and complex data collections.")
(define-public hdf5-1.14
(package
(inherit hdf5-1.8)
- (version "1.14.0")
+ (version "1.14.3")
(source
(origin
(method url-fetch)
@@ -1828,8 +1828,19 @@ extremely large and complex data collections.")
(take (string-split version #\.) 2))
"/src/hdf5-" version ".tar.bz2")))
(sha256
- (base32 "181bdh8hp7v9xqwcby3lknr92lxlicc2hqscba3f5nhf8lrr9rz4"))
- (patches (search-patches "hdf5-config-date.patch"))))))
+ (base32 "05zr11y3bivfwrbvzbky1q2gjf6r7n92cvvdnh5jilbmxljg49cl"))
+ (patches (search-patches "hdf5-config-date.patch"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments hdf5-1.8)
+ ((#:phases phases #~%standard-phases)
+ #~(modify-phases #$phases
+ (add-after 'configure 'skip-version-test
+ (lambda _
+ ;; Skip test_check_version since the 'patch-settings' phase
+ ;; modifies the test reference.
+ (substitute* "test/test_check_version.sh.in"
+ (("TESTING\\(\\).*" all)
+ (string-append all "\nSKIP; exit 0\n")))))))))))
(define-public hdf5
;; Default version of HDF5.
@@ -2069,35 +2080,34 @@ Swath).")
(license (license:non-copyleft home-page))))
(define-public hdf5-parallel-openmpi
- (package/inherit hdf5-1.10 ;use the latest
+ (package/inherit hdf5-1.14 ;use the latest
(name "hdf5-parallel-openmpi")
(inputs
`(("mpi" ,openmpi)
,@(package-inputs hdf5)))
(arguments
- (substitute-keyword-arguments (package-arguments hdf5)
+ (substitute-keyword-arguments (package-arguments hdf5-1.14)
((#:configure-flags flags)
- ``("--enable-parallel"
- ,@(delete "--enable-cxx"
- (delete "--enable-threadsafe" ,flags))))
+ #~(cons "--enable-parallel"
+ (delete "--enable-cxx"
+ (delete "--enable-threadsafe" #$flags))))
((#:phases phases)
- `(modify-phases ,phases
- (add-after 'build 'mpi-setup
- ,%openmpi-setup)
- (add-before 'check 'patch-tests
- (lambda _
- ;; OpenMPI's mpirun will exit with non-zero status if it
- ;; detects an "abnormal termination", i.e. any process not
- ;; calling MPI_Finalize(). Since the test is explicitly
- ;; avoiding MPI_Finalize so as not to have at_exit and thus
- ;; H5C_flush_cache from being called, mpirun will always
- ;; complain, so turn this test off.
- (substitute* "testpar/Makefile"
- (("(^TEST_PROG_PARA.*)t_pflush1(.*)" front back)
- (string-append front back "\n")))
- (substitute* "tools/test/h5diff/testph5diff.sh"
- (("/bin/sh") (which "sh")))
- #t))))))
+ #~(modify-phases #$phases
+ (add-after 'build 'mpi-setup
+ #$%openmpi-setup)
+ (add-before 'check 'patch-tests
+ (lambda _
+ ;; OpenMPI's mpirun will exit with non-zero status if it
+ ;; detects an "abnormal termination", i.e. any process not
+ ;; calling MPI_Finalize(). Since the test is explicitly
+ ;; avoiding MPI_Finalize so as not to have at_exit and thus
+ ;; H5C_flush_cache from being called, mpirun will always
+ ;; complain, so turn this test off.
+ (substitute* "testpar/Makefile"
+ (("(^TEST_PROG_PARA.*)t_pflush1(.*)" front back)
+ (string-append front back "\n")))
+ (substitute* "tools/test/h5diff/testph5diff.sh"
+ (("/bin/sh") (which "sh")))))))))
(synopsis "Management suite for data with parallel IO support")))
(define-public hdf5-blosc
@@ -3529,7 +3539,8 @@ September 2004}")
"--with-openblas=1"
(string-append "--with-openblas-dir="
#$(this-package-input "openblas"))
- "--with-superlu=1")
+ "--with-superlu=1"
+ "--with-debugging=0")
#:make-flags
;; Honor (parallel-job-count) for build. Do not use --with-make-np,
;; whose value is dumped to $out/lib/petsc/conf/petscvariables.
@@ -3544,6 +3555,11 @@ September 2004}")
(let* ((prefix (assoc-ref outputs "out"))
(flags `(,(string-append "--prefix=" prefix)
,@configure-flags)))
+ ;; Sort source files in configure (for reproducibility).
+ (substitute* "config/gmakegen.py"
+ (("join\\(srcs\\[lang\\]\\)")
+ "join(sorted(srcs[lang]))"))
+
(format #t "build directory: ~s~%" (getcwd))
(format #t "configure flags: ~s~%" flags)
(apply invoke "./configure" flags)
@@ -3558,8 +3574,8 @@ September 2004}")
(substitute* (find-files "." "^petsc(conf|machineinfo).h$")
;; Prevent build directory from leaking into compiled code
(((getcwd)) out)
- ;; Scrub timestamp for reproducibility
- ((".*Libraries compiled on.*") ""))
+ (("Machine characteristics: Linux-[0-9]+\\.[0-9]+\\.[0-9]+")
+ "Machine characteristics: Linux-x.x.x"))
(substitute* (find-files "." "petscvariables")
;; Do not expose build machine characteristics, set to defaults.
(("MAKE_NP = [:digit:]+") "MAKE_NP = 2")
@@ -7066,7 +7082,7 @@ evaluates expressions using the standard order of operations.")
(define-public xaos
(package
(name "xaos")
- (version "4.2.1")
+ (version "4.3.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -7075,53 +7091,53 @@ evaluates expressions using the standard order of operations.")
(file-name (git-file-name name version))
(sha256
(base32
- "0maw5am6rrkyjrprfg113zjq37mqj0iaznkg4h2927ff7wrprc94"))))
+ "0a5n3g1xcsd8k65q5skm4xsdllr3mmkahh4vi59db1l0jv81v06q"))))
(build-system gnu-build-system)
(native-inputs `(("gettext" ,gettext-minimal)
- ("qtbase" ,qtbase-5)
- ("qttools-5" ,qttools-5)))
+ ("qtbase" ,qtbase)
+ ("qttools" ,qttools)))
(inputs (list libx11 zlib libpng gsl))
;; The upstream project file ("XaoS.pro") and the Makefile it generates are
;; not enough for this package to install properly. These phases fix that.
(arguments
- `(#:tests? #f ;no "check" target
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'make-qt-deterministic
- (lambda _
- ;; Make Qt deterministic.
- (setenv "QT_RCC_SOURCE_DATE_OVERRIDE" "1")
- #t))
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (substitute* "XaoS.pro"
- ;; The DESTDIR is originally set to install the xaos binary to
- ;; the "bin" folder inside the build directory. Setting make
- ;; flags doesn't seem to change this.
- (("DESTDIR.*$")
- (string-append "DESTDIR=" out "/bin"))
- ;; Set the correct path to the lrelease binary.
- (("lrelease-qt5") "lrelease"))
- (substitute* "src/include/config.h"
- (("/usr/share/XaoS")
- (string-append out "/share/XaoS")))
- (invoke "qmake"))))
- (add-after 'install 'install-data
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (share (string-append out "/share")))
- (mkdir-p share)
- (for-each
- (lambda (folder)
- (copy-recursively folder
- (string-append share "/XaoS/" folder)))
- '("catalogs" "examples" "tutorial"))
- (install-file "xdg/xaos.png"
- (string-append share "/pixmaps"))
- (install-file "xdg/xaos.desktop"
- (string-append share "/applications")))
- #t)))))
+ (list #:tests? #f ;no "check" target
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'make-qt-deterministic
+ (lambda _
+ ;; Make Qt deterministic.
+ (setenv "QT_RCC_SOURCE_DATE_OVERRIDE" "1")))
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "XaoS.pro"
+ ;; The DESTDIR is originally set to install the xaos binary to
+ ;; the "bin" folder inside the build directory. Setting make
+ ;; flags doesn't seem to change this.
+ (("DESTDIR.*$")
+ (string-append "DESTDIR=" out "/bin"))
+ (("/usr/local")
+ out)
+ ;; Set the correct path to the lrelease binary.
+ (("lrelease-qt6") "lrelease"))
+ (substitute* "src/include/config.h"
+ (("/usr/share/XaoS")
+ (string-append out "/share/XaoS")))
+ (invoke "qmake"))))
+ (add-after 'install 'install-data
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (share (string-append out "/share")))
+ (mkdir-p share)
+ (for-each
+ (lambda (folder)
+ (copy-recursively folder
+ (string-append share "/XaoS/" folder)))
+ '("catalogs" "examples" "tutorial"))
+ (install-file "xdg/xaos.png"
+ (string-append share "/pixmaps"))
+ (install-file "xdg/io.github.xaos_project.XaoS.desktop"
+ (string-append share "/applications"))))))))
(synopsis "Real-time fractal zoomer")
(description "GNU XaoS is a graphical program that generates fractal
patterns and allows you to zoom in and out of them infinitely in a fluid,
@@ -7909,7 +7925,7 @@ reduction.")
(define-public mcrl2
(package
(name "mcrl2")
- (version "202206.1")
+ (version "202307.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -7917,7 +7933,7 @@ reduction.")
version ".tar.gz"))
(sha256
(base32
- "1rbfyw47bi31qla1sa4fd1npryb5kbdr0vijmdc2gg1zhpqfv0ia"))))
+ "147002dl3gq2jsk5gcmvw7hj3mfxrpgxwcfda5mfrj26rcxw48fc"))))
(inputs
(list boost glu mesa qtbase-5))
(build-system cmake-build-system)